Module dependency errors after new kernel and stty error

Module dependency errors after new kernel and stty error

Post by Adam L. Kle » Sun, 02 Mar 1997 04:00:00



After untarring and installing the 2.0.29 kernel, I did a make config and
answered the questions (as I had previously with 2.0.0), make dep, make clean,
make modules, make modules_install, and make zlilo.

After doing so, I can boot, but get thte following errors:

after "Updating module dependecies for Linux 2.0.29" I get
        "can't locate module lp"
        "can't locate module slip"
        "can't locate module ppp"

after "Loading the iBCS module", I get
        "Cannot open /lib/modules/misc/iBCS.o"

I did not get these errors under a (recently made) 2.0.0 kernel.  I checked,
and the missing modules (listed above) are under /lib/modules/2.0.0/ (misc,
net, and misc) respectively but they are NOT under /lib/modules/2.0.29.  
I can't just copy them over (I get "this module compiled under 2.0.0" errors).

Also, when doing a shutdown, I often get "stty: standard input Invalid
Argument".  

Any advice on fixing these problems would be very appreciated.  

Thanks.

Adam Klein

--
Adam Klein             "A foolish consistency is the hobgoblin of little minds"

 
 
 

Module dependency errors after new kernel and stty error

Post by Ulf Jaenicke-Roessle » Tue, 04 Mar 1997 04:00:00



> After untarring and installing the 2.0.29 kernel, I did a make config and
> answered the questions (as I had previously with 2.0.0), make dep, make clean,
> make modules, make modules_install, and make zlilo.

Did you see errors for 'make modules' or did you trink coffee while
compiling? The actual compiling sequence is make config; make dep;
make clean; make zlilo; make modules; make modules_install

Good luck,

 Ulf

 
 
 

Module dependency errors after new kernel and stty error

Post by @sprintmail.co » Tue, 04 Mar 1997 04:00:00




> > After untarring and installing the 2.0.29 kernel, I did a make config and
> > answered the questions (as I had previously with 2.0.0), make dep, make clean,
> > make modules, make modules_install, and make zlilo.

> Did you see errors for 'make modules' or did you trink coffee while
> compiling? The actual compiling sequence is make config; make dep;
> make clean; make zlilo; make modules; make modules_install

> Good luck,

>  Ulf

umm, depmod -a ????
 
 
 

1. Kernel Module Dependency Error

Hello,

I recently download Kernel 2.2.14 from http://www.kernel.org.  After
compiling the kernel many times (for couple days), I finally get a
working kernel.  Except one thing.  When the system is booting up, I get
a Module Dependency error for "/lib/modules/2.2.14/fs/lockd.o".

I try to find a reference for "lockd" and "lockd.o" in
"/usr/src/linux/Documentation/Configure.help" and
"/usr/src/linux/Documentation/filesystems" using the command "cat * |
grep lockd", but no success.

Could someone point me to the right direction?  I am new to linux.
Thanks.

Patrick Kong

2. oxygen rpm drivers in xfree86 v 4.1.0?

3. How to "clean up" after installing the new kernel (system map, module dependencies, etc.)

4. Chmod 777 pppd, still only root can use it. Drat!

5. New kernel stops booting at ''finding module dependencies''

6. FTP Help needed

7. New kernel causes 'infinite' finding module dependencies...

8. Trouble with USB 2.0 !

9. Fix for module errors with new kernel compile

10. KSH: error when redirecting in subshell: stty: syntax error

11. Strange module error after building new kernel

12. module loading error after new kernel compilation

13. no dependency information for module ERROR - How to resolve???