XEmacs-20.4 and RH 5.0

XEmacs-20.4 and RH 5.0

Post by Morten Ranhe » Sat, 25 Jul 1998 04:00:00



If there is someone out there who is a xemacs guru, please respond to
this.

I'm using RH 5.0 with the most recent updates of all libraries and
programs. Currently I'm using vi which suits my needs, but I want to
look at xemacs because I got the 'feeling' that it can give me more
juice.

I have downloaded the xemacs rpm files and tar files. When I installs
the rpm files I get an error that it 'can't find libc.so.5' which reside
under /usr/i486-linux-libc5/lib. libc.so.5 is alive and kicking. I'm not
familiar with the right "doings" on how the rpm can find specific libs
so I downloaded the xemacs-20.4.tar.gz file. I read the readme files
and the installation files and tried to compiled with these steps:

1: ./configure --dynamic=yes --with-mule --with-xpm=yes # xpm = xpm3.4k

Everything goes well.

2: make > errors    # > errors is just to give me warning and errors

And then I get this:

doc.c: In function `Fsnarf_documentation':
doc.c:610: warning: label `weird_function' defined but not used
eval.c: In function `funcall_recording_as':
eval.c:3153: warning: `val' might be used uninitialized in this
function
eval.c: At top level:
eval.c:3556: warning: `funcall_subr' defined but not used
events.c: In function `Fmake_event':
events.c:402: warning: unused variable `val'
events.c:402: warning: unused variable `prop'
database.c: In function `Fopen_database':
database.c:654: warning: unused variable `status'
faces.c:549: warning: `update_faces_inheritance' defined but not used
process.c: In function `create_process':
process.c:999: too many arguments to function `getpgrp'
make[1]: *** [process.o] Error 1
make: *** [src] Error 2

So what am I doing wrong here? Anything I've missed..or...?

Thanks for any help :)

--
Morten Ranheim

 
 
 

XEmacs-20.4 and RH 5.0

Post by Jan Vroonho » Tue, 28 Jul 1998 04:00:00



> I have downloaded the xemacs rpm files and tar files. When I installs
> the rpm files I get an error that it 'can't find libc.so.5' which reside
> under /usr/i486-linux-libc5/lib. libc.so.5 is alive and kicking.

You probably got the wrong RPM's. There are also precompiled versions
for redhat 5.x. I cannot tell you where as I do not use redgat.

Quote:> 1: ./configure --dynamic=yes --with-mule --with-xpm=yes # xpm = xpm3.4k

> Everything goes well.

it probably didn't. The golden rule with configure is. Specify only
what is needed, let configure autodetect. Try

./configure --with-mule

Quote:> process.c: In function `create_process':
> process.c:999: too many arguments to function `getpgrp'

It seems like configure misdetected the number of arguments of
getpgrp. This is usually cause by another config test failing
(autoconf is very brittle in this respected).

Jan

 
 
 

1. Problem with Xemacs-20.4 and Linux

Hi everybody,

I compiled Xemacs-20.4 without Mule on my Linux Box (gcc-2.7.2.1,
libc-5.4.33, kernel 2.0.30, Xfree86-3.3.1, options --with-gcc)
and I am seeing some strange behaviour: when I size the Xemacs window
with the mouse, it freezes. Maybe something else goes wrong because
I can move the mouse and click at different windows but I am not able
to enter any text at any window (fvwm2).

any ideas ?

Thomas

2. Using SLIP and Ethernet questions

3. xemacs 20 in Solaris 20 - "Save Options" fails

4. Dtterm and KDE

5. Lilo: L 20 20 20 20

6. USB 2.0 PCMCIA Cards?

7. SMBFS-2.0.2 on RH 5.0 (was Re: make error on RH 5.0)

8. OpenSource Monitors on Solaris (Nagios, MON) - which one 2 choose

9. Emacs-20.2 hangs in RedHat 5.0 alpha

10. Probleme avec crack 5.0 + RH 5.0

11. Installin RH Linux on an IBM Ps/1 -- 486SX 20 Mhz 8Meg Ram hard drive prob

12. help r.h. 7.1 auto partition prob w/20 gig ide

13. 2.4.{19,20,20-ac2} with contest