Message: Device not ready...

Message: Device not ready...

Post by Mauria » Tue, 01 Jul 2003 09:23:16



If I cat /var/log/messages I see this frequent message:

Jun 29 20:06:36 myhost kernel: Device not ready.  Make sure there is a
disc in the drive.

Similar output can be seen from 'dmesg'. I'm using Redhat 9, I had this
also happen in Redhat 7.3.

What causes it? Is this a problem? For what should I be looking? Can I
fix it?

--

Mauriat
----------------------------
Remove 'NOSPAM' to email me.

 
 
 

Message: Device not ready...

Post by dav.. » Tue, 01 Jul 2003 14:14:45



Quote:> Jun 29 20:06:36 myhost kernel: Device not ready.  Make sure there is a
> disc in the drive.

Do you have some automatic script that try to mount your CD/Floppy?

Davide

 
 
 

Message: Device not ready...

Post by Mauria » Wed, 02 Jul 2003 06:23:50




>>Jun 29 20:06:36 myhost kernel: Device not ready.  Make sure there is a
>>disc in the drive.

> Do you have some automatic script that try to mount your CD/Floppy?

> Davide

No.

The removable disks listed in fstab are the floppy, cd(writer) and
parallel zip drive (which is disconnected). Both the /dev/cdrom and
/dev/zip are linked to some sda device.

/dev/cdrom /mnt/cdrom       udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0   /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/zip   /mnt/zip    vfat user,owner,noexec,dev,suid,rw,noauto 0 0

And I have the added lines in my modules.conf for the parallel drive.

alias parport_lowlevel parport_pc
post-install parport_pc modprobe imm

--

Mauriat
----------------------------
Remove 'NOSPAM' to email me.

 
 
 

1. constant "Device not ready" messages

I just upgraded from Red Hat 5.1 to 6.1.  Along with this software
upgrade I installed a SCSI Adapter (Adaptec) and a SCSI CD writer.
Now, I get the following in /var/log/messages:

Oct 27 19:44:31 localhost kernel: Device not ready.  Make sure there is a disc in the drive.
Oct 27 19:45:03 localhost last message repeated 16 times
Oct 27 19:46:05 localhost last message repeated 31 times
Oct 27 19:47:06 localhost last message repeated 30 times
Oct 27 19:48:08 localhost last message repeated 31 times
Oct 27 19:49:10 localhost last message repeated 31 times

...and on and on and on.

Everything appears to be working fine, but I am worried.
Has anyone else had this problem?  How can I find out more about what
device it is referring to?

Thanks,
Rob

I am just learning to post news with emacs, so if my address isn't

2. Sendmail

3. "Drive not ready for command" message in RH 7.2

4. BUILD YOUR OWN C`A.B,L,E B,O`X...FREE C`A.B,L.E`.... 5161

5. "atapi1.0:controller not ready for cmd" CD ROM error message

6. complex problem..

7. Device not Ready

8. Redhat 4.1 and Slackware 3.2 Install problems (longish)

9. ATAPI device hdd: NOT READY ERROR, please help

10. SCSI tape drive, device not ready

11. MkLinux Install Problem (Umax S900) Device not ready?

12. sysback/mkjfsback device not ready problem

13. HELP! device not ready for operation