SS10 headless cannot acces prom - HELP

SS10 headless cannot acces prom - HELP

Post by Simon Adam » Thu, 06 Jan 2000 04:00:00



Hi

I have an emergency situation on a SS10 and I dont have much Sun exp.

The SS10 is headless so a null modem cable is attched and a console
using hyperterminal attched.

The problem is the root file system is full so I need to interrupt the
boot to get it into single user mode.

How can I do this?

Any help much appreciated.

Regards
Simon

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

SS10 headless cannot acces prom - HELP

Post by Griff Mille » Thu, 06 Jan 2000 04:00:00



> Hi

> I have an emergency situation on a SS10 and I dont have much Sun exp.

> The SS10 is headless so a null modem cable is attched and a console
> using hyperterminal attched.

> The problem is the root file system is full so I need to interrupt the
> boot to get it into single user mode.

> How can I do this?

> Any help much appreciated.

Get to the ok> prompt and boot it single-user:

ok> boot -s

--
Griff Miller II                         | People, do the math:
Manager of Information Technology       | 1st day of 1st millennium: 1/1/1
Positron Corporation                    | 1st day of 2nd millennium: 1/1/1001


 
 
 

SS10 headless cannot acces prom - HELP

Post by Anthony Mandi » Fri, 07 Jan 2000 04:00:00



> The SS10 is headless so a null modem cable is attched and a console
> using hyperterminal attched.
> The problem is the root file system is full so I need to interrupt the
> boot to get it into single user mode.

        Send it a break signal. You should be able to do this thru
        hyperterm (but don't quote me on it).

-am

 
 
 

1. Help booting a headless SS10!

I just got a Sparcstation 10 to play with Solaris 9 on.  I bought it over
ebay and (since I don't have a sun monitor/adapter/serial console cable) the
dealer configured it's IP and gateway so I could plug it into my network and
use it for the time being.  Got the SS10, plugged it in, everything was
cool.

Then I messed up.  Following some instructions I found on the web for
configuring DNS, I editted the /etc/nsswitch.conf file and changed the line
"hosts: files" to "hosts: dns".  I rebooted the machine like many times
before, but alas, this time it didn't come up.  I hear it rumbling as though
loading up normally but I'm unable to telnet to it.

My plan on recovery was a simple one - I know the number of lines and spaces
necessary to vi /etc/nsswitch.conf and change back the modification I made.
What I need to know is, what would be on my console were I able to actually
see it?  A prompt for single user mode?  A menu system?  It could depend on
the PROM version I guess in which case I'm SOL.  But if someone could give
me an idea of the commands/keys necessary to get to a shell prompt, PLEASE
let me know.  I borrowed a Sun-to-VGA adapter but my monitor can't handle it
and I have no idea where to get a serial console cable.  Thanks for any help
at all!

2. 2.5 Problem Status Report

3. SS10 Headless operation

4. ncurses

5. Headless ss10?

6. Apache web server on 5.1

7. Reducing SS10's apparent physical memory via console prom?

8. CDROM driver for LMS/Philips

9. Newbie question xhost server acces, cant remove acces

10. HELP HELP HELP NEWBIE Cannot get the DHCP set up properly and cannot connect to internet

11. Help! SS10 rebooting after panic: recursive mutex_enter

12. Help with fax software for SS10 + SupraFAX modem.

13. Help - lpNet eating memory on SS10!