Solstice Backup/Legato 5.5 and error msg

Solstice Backup/Legato 5.5 and error msg

Post by rcyoun » Thu, 01 Sep 2005 11:47:58



Does this ring any bells?

SJI failure [0x7]

 
 
 

Solstice Backup/Legato 5.5 and error msg

Post by Darren Dunha » Fri, 02 Sep 2005 01:25:07



> Does this ring any bells?
> SJI failure [0x7]

You're not giving much context, and Networker 5.5 is *very old*.  

SJI is the Standard Jukebox Interface.  Networker controls and queries
jukeboxes through that library interface.

Probably it tried to do something and the library returned that error
code.  It could be a hardware or software problem.

I don't see any header files for the library, so I'm not sure what that
particular code represents.

--

Senior Technical Consultant         TAOS            http://www.taos.com/
Got some Dr Pepper?                           San Francisco, CA bay area
         < This line left intentionally blank to confuse you. >

 
 
 

Solstice Backup/Legato 5.5 and error msg

Post by rcyoun » Fri, 02 Sep 2005 10:38:42


True, but I have more to go on now. The message below is generated when
trying to do a RESET of the autochanger from Legato. I know 5.5.2 is
"older than dirt", but that's what they have installed.

SJI Failure[0x     7]: Invalid slot address.

I have checked that the autochanger shows up on the scsi  list. Going
to try jbexerciser tomorrow to see if it will take commands from that.

Autochanger had some problems, was serviced by a factory rep, and he
tested it as OK with his diagnostic equipment, but it was NOT tested
with communications to/from  Legato until later.

 
 
 

Solstice Backup/Legato 5.5 and error msg

Post by Darren Dunha » Sat, 03 Sep 2005 01:41:55



> True, but I have more to go on now. The message below is generated when
> trying to do a RESET of the autochanger from Legato. I know 5.5.2 is
> "older than dirt", but that's what they have installed.
> SJI Failure[0x     7]: Invalid slot address.

Can you do a sjirdp on the juke?  Does it show the correct numbers?  

Does the configured jukebox have the same number of slots?

--

Senior Technical Consultant         TAOS            http://www.taos.com/
Got some Dr Pepper?                           San Francisco, CA bay area
         < This line left intentionally blank to confuse you. >

 
 
 

Solstice Backup/Legato 5.5 and error msg

Post by rcyoun » Sat, 03 Sep 2005 19:40:00


Appears to be correct

3 DATA TRANSPORT  starting at address 1 (tape units QUANTUN 7000s)
1 MEDIA TRANSPORT startng at address 1
29 STORAGE elements starting at 1
1 IMPORT/EXPORT elements starting at 1

Ran jbexercise on all 3 drives/jukebox collectively, and then on each
drive individually. Jbexercise ran successfully ONCE on a single drive,
but subsequently failed on that drive multiple times, and failed
consistently on the 2 others.  Also failed consistently when ALL drives
were tested collectively. However, failure appeared to be after tape
was loaded into tape units (like a time out). Tapes were selected,
moved into positions, loaded into tape drives, but then failed when
mounting/reading tapes.

Other tests (similar to the one above) which test out "just" the
jukebox appear to function correctly. However, tests like nsrjb -Hv to
reset jukebox gives the 0x7 error after entering te "box inventory"
phase.

 
 
 

Solstice Backup/Legato 5.5 and error msg

Post by Darren Dunha » Sun, 04 Sep 2005 00:29:09



> Ran jbexercise on all 3 drives/jukebox collectively, and then on each
> drive individually. Jbexercise ran successfully ONCE on a single drive,
> but subsequently failed on that drive multiple times, and failed
> consistently on the 2 others.  Also failed consistently when ALL drives
> were tested collectively. However, failure appeared to be after tape
> was loaded into tape units (like a time out). Tapes were selected,
> moved into positions, loaded into tape drives, but then failed when
> mounting/reading tapes.
> Other tests (similar to the one above) which test out "just" the
> jukebox appear to function correctly. However, tests like nsrjb -Hv to
> reset jukebox gives the 0x7 error after entering te "box inventory"
> phase.

After you load a tape into a drive, does it function properly from the
OS?  Can you write, rewind, read, offline?  

--

Senior Technical Consultant         TAOS            http://www.taos.com/
Got some Dr Pepper?                           San Francisco, CA bay area
         < This line left intentionally blank to confuse you. >

 
 
 

Solstice Backup/Legato 5.5 and error msg

Post by rcyoun » Sun, 04 Sep 2005 04:36:22


Tried mt -f /dev/rmt/2 status &  mt -f /dev/rmt/2cbn status  and both
came back tape not loaded/offline even after a tape had been manually
inserted.

Command like "find /tmp -print > /dev/rmt/xxx" simply gives I/O error.

 
 
 

Solstice Backup/Legato 5.5 and error msg

Post by greek_philosophi.. » Sun, 04 Sep 2005 05:27:08



> Tried mt -f /dev/rmt/2 status &  mt -f /dev/rmt/2cbn status  and both
> came back tape not loaded/offline even after a tape had been manually
> inserted.

> Command like "find /tmp -print > /dev/rmt/xxx" simply gives I/O error.

Any reason not to upgrade the software now?

At least on the machine running the jukebox...

.

 
 
 

Solstice Backup/Legato 5.5 and error msg

Post by Darren Dunha » Sun, 04 Sep 2005 06:12:42



> Tried mt -f /dev/rmt/2 status &  mt -f /dev/rmt/2cbn status  and both
> came back tape not loaded/offline even after a tape had been manually
> inserted.
> Command like "find /tmp -print > /dev/rmt/xxx" simply gives I/O error.

You sure the linkage between which drive is which is correct?

I've seen lots of configurations where the robot puts the tape in drive
1, but instead of drive0 that's drive3 for some reason.

Do a status on all devices of the same type in rmt when one tape is in
place.  If it still fails, this has nothing to do with networker.

for i in /dev/rmt/*cbn ; do echo $i ; mt -f $i status ; done

--

Senior Technical Consultant         TAOS            http://www.taos.com/
Got some Dr Pepper?                           San Francisco, CA bay area
         < This line left intentionally blank to confuse you. >

 
 
 

Solstice Backup/Legato 5.5 and error msg

Post by Darren Dunha » Sun, 04 Sep 2005 06:34:01



> I've seen lots of configurations where the robot puts the tape in drive
> 1, but instead of drive0 that's drive3 for some reason.

Could that be *more* confusing?

I meant:
I've seen lots of configurations where the robot puts the tape in drive
1, but instead of rmt0 it's rmt3 for some reason.

Quote:> Do a status on all devices of the same type in rmt when one tape is in
> place.  If it still fails, this has nothing to do with networker.

Still recommended.

--

Senior Technical Consultant         TAOS            http://www.taos.com/
Got some Dr Pepper?                           San Francisco, CA bay area
         < This line left intentionally blank to confuse you. >

 
 
 

1. Solstice Backup 5.1 / DMO 2.1/Oracle 8.1.5: Tape backup failed : Need of 5.5 Upgrade ?

Hi,

we have the following installation:

Backup Server with

Solaris 2.5.1
Solstice Backup  Server 5.1

Backup client with

Solaris 2.6
Solstice backup Client 5.1

DMO (Database modules for Oracle) 2.1 with the last Patches, which
should give the possibility of scheduled backups

Oracle 8.1.5

Our Problem is:

we cant make a tape-backup with allocate ...'sbt_tape'  startet over
rman. backups to disk are running fine.

Starting a backup over nwadmin we get an error, because there is no
given a user.

Has anybody made a tape-backup from rman or nwadmin, without upgrading
to Solstice Backup 5.5?

TIA,

Nele

2. Trouble w/ installing Slackware Linux

3. Importing Networker 5.5 tapes into Solstice Backup 6.1

4. Help With Make

5. Legato 5.5 client go through firewall

6. Multilingural Mosaic for Solaris needed

7. Firewall1 and Solstice Backup (Legato Networker)

8. Potato not even frozen, Corel released

9. Solstice Backup/Legato Networker problem : need label stored on tape, not jukebox

10. Solstice backup 4.2 (legato or nsr) question

11. Migrating from Legato Windows server to Solstice Backup on Solaris

12. How can I reduce the recycle duration of pools in Solstice (Legato) Backup

13. Solstice Backup/Legato Question....