Linker patch for SunOS 5.5.1

Linker patch for SunOS 5.5.1

Post by Willard Daws » Fri, 15 Aug 1997 04:00:00



-----BEGIN PGP SIGNED MESSAGE-----

103242-05 is SunOS 5.5 linker patch

Is there one for SunOS 5.5.1?

-----BEGIN PGP SIGNATURE-----
Version: 2.6.2
Comment: http://www.geocities.com/BourbonStreet/4209/pgpcpk.txt

iQCVAwUBM/Nz2g+xX6JxltghAQEmGAP/ZYjJj1vaORRjrM3yopMqcKNB0PHqpnK0
tanv80xVEH4qDN12bR/e/n0+yqVtGXBElD6GoBpSmAguti3tUFK50vBC6CgftZtC
Uba5usj3GJgjruOkN4RZtS5pIvhXW6UiJn45WGFgysR8FcyJeMDOt/pVp+WbEPBt
jqC2/1EMKRY=
=Wo4R
-----END PGP SIGNATURE-----
--
Willard Francis Otto Dawson   Standard disclaimer applies.
Not Associated With Anyone    Voice:    +1 770 209 8218

Norcross, GA  30092           http://www.geocities.com/BourbonStreet/4209/

 
 
 

Linker patch for SunOS 5.5.1

Post by Casper H.S. Dik - Network Security Engine » Sat, 23 Aug 1997 04:00:00


[[ Mail or post, don't do both ]]


>Yes.  I'm getting bunches of errors from the latest Netscape
>executables, like:
>ERROR: ld.so.1: /usr/local/netscape/netscape.v402-solaris2.4: elf error: /usr/local/netscape/plugins/NSWhiteboard/sol24/NSWhiteboard: not a shared or relocatable object

What does "file NSWhiteboard" say?  Is it a directory?  I see that netscape
often gives errors like these on readme files and such in teh plugins
directory.

Casper
--
Expressed in this posting are my opinions.  They are in no way related
to opinions held by my employer, Sun Microsystems.
Statements on Sun products included here are not gospel and may
be fiction rather than truth.

 
 
 

Linker patch for SunOS 5.5.1

Post by Willard Daws » Sat, 23 Aug 1997 04:00:00


-----BEGIN PGP SIGNED MESSAGE-----


>[[ Mail or post, don't do both ]]

>>Yes.  I'm getting bunches of errors from the latest Netscape
>>executables, like:
>>ERROR: ld.so.1: /usr/local/netscape/netscape.v402-solaris2.4: elf error: /usr/local/netscape/plugins/NSWhiteboard/sol24/NSWhiteboard: not a shared or relocatable object
>What does "file NSWhiteboard" say?  Is it a directory?  I see that netscape
>often gives errors like these on readme files and such in teh plugins
>directory.

$ file /usr/local/netscape/plugins/NSWhiteboard/sol24/NSWhiteboard
/usr/local/netscape/plugins/NSWhiteboard/sol24/NSWhiteboard:    ELF 32-bit MSB executable SPARC Version 1, dynamically linked, stripped

However, I see that it is perm'ed:

- -rwxr-x---

... let's see what happens if I make that o+rx as well...

Nope, no difference.  All the '*.gif' files are non-executable, but they
generate errors, too.  Hmm...

-----BEGIN PGP SIGNATURE-----
Version: 2.6.2
Comment: http://www.geocities.com/BourbonStreet/4209/pgpcpk.txt

iQCVAwUBM/3k2A+xX6JxltghAQFqJgQAuci+Oa/doilWLayuQ0SmxS2byblw88fP
4DCWuYX5PcIU20YNt363Sv//96wAOaCUdHOwalUIYS50tnlncklO5r37T78fNiss
ilCoKZFTfEX+nKBAAR8MHk4YuNna+U4GKNnPzXzQlua9CMtsokURd7FY8oR6cE6M
SFD2o+Vb40k=
=7J7J
-----END PGP SIGNATURE-----
--
Willard Francis Otto Dawson   Standard disclaimer applies.
Not Associated With Anyone    Voice:    +1 770 209 8218

Norcross, GA  30092           http://www.geocities.com/BourbonStreet/4209/