spaces missing when printing arial from Netscape 7 beta via Xprt

spaces missing when printing arial from Netscape 7 beta via Xprt

Post by Richard L. Hamilt » Sat, 19 Oct 2002 05:13:54



When I configure Netscape 7 beta (Solaris) to print via Xprt, and I have
Arial (8859-1 or 8859-15) selected as the Sans Serif font, then Sans Serif
text prints all run together, without spaces, even though it looks fine
in the browser window and in the print-preview.  If I instead use Lucida
Sans, it works fine.  This wouldn't be that big a deal except thanks to MS,
many web pages look best in their preferred fonts, i.e. Arial for Sans
Serif and Times New Roman for Serif.  I've tried varying the location of
the TTbitmaps directory in the font path for Xprt (from early to after all
other locations where the font might be found) and that doesn't make any
difference. I suppose the next step will be to try to prune the font
path to just one diretory and re-create the problem, so I can see exactly
which font is responsible.  But that still won't tell me why it's
happening.

--

 
 
 

spaces missing when printing arial from Netscape 7 beta via Xprt

Post by Richard L. Hamilt » Sat, 19 Oct 2002 08:23:17





>>   When I configure Netscape 7 beta (Solaris) to print via Xprt, and I have
>>   Arial (8859-1 or 8859-15) selected as the Sans Serif font, then Sans Serif
>>   text prints all run together, without spaces, even though it looks fine
>>   in the browser window and in the print-preview.  If I instead use Lucida
>>   Sans, it works fine.  This wouldn't be that big a deal except thanks to MS,
>>   many web pages look best in their preferred fonts, i.e. Arial for Sans
>>   Serif and Times New Roman for Serif.  I've tried varying the location of
>>   the TTbitmaps directory in the font path for Xprt (from early to after all
>>   other locations where the font might be found) and that doesn't make any
>>   difference. I suppose the next step will be to try to prune the font
>>   path to just one diretory and re-create the problem, so I can see exactly
>>   which font is responsible.  But that still won't tell me why it's
>>   happening.

> First I've heard of Xprt.

> Any of the following helpful?

[...]
> This problem was already reported as Bugid 5236 in bugzilla.
[...]
> Printing does not work for non iso-8859-1 characters.
> All non iso-8859-1 characters are printed as square. (Bug 4474533)

> Workaround:  Try Xprint printing.

[...]

Looking at bugzilla now, but except for the stuff I didn't cut out,
none of what you posted seems to be applicable.  Thanks anyway, though.
I'll keep digging and also hoping someone else has seen this problem.

--


 
 
 

spaces missing when printing arial from Netscape 7 beta via Xprt

Post by Richard L. Hamilt » Sat, 19 Oct 2002 08:28:08





>>   When I configure Netscape 7 beta (Solaris) to print via Xprt, and I have
>>   Arial (8859-1 or 8859-15) selected as the Sans Serif font, then Sans Serif
>>   text prints all run together, without spaces, even though it looks fine
>>   in the browser window and in the print-preview.  If I instead use Lucida
>>   Sans, it works fine.  This wouldn't be that big a deal except thanks to MS,
>>   many web pages look best in their preferred fonts, i.e. Arial for Sans
>>   Serif and Times New Roman for Serif.  I've tried varying the location of
>>   the TTbitmaps directory in the font path for Xprt (from early to after all
>>   other locations where the font might be found) and that doesn't make any
>>   difference. I suppose the next step will be to try to prune the font
>>   path to just one diretory and re-create the problem, so I can see exactly
>>   which font is responsible.  But that still won't tell me why it's
>>   happening.

> First I've heard of Xprt.

> Any of the following helpful?

[...]

Just found something that seems to apply in bugzilla; not yet sure how
I'll use what I found to come up with a workaround.

http://bugzilla.mozilla.org/show_bug.cgi?id=139503

--