Strange NIS+ probs. under Solaris2.6

Strange NIS+ probs. under Solaris2.6

Post by Robert Oschwal » Tue, 21 Oct 1997 04:00:00



Hi NIS+ GURUS,

we've had a NIS+ root domain with Solaris2.5 root/replica servers
and all worked great.
Problems began, as we changed one replica to be Solaris2.6 machine
and then changed this replica to be the root server.

Our problems are:

Machines are SPARC SUN4m.
Domainname was name.domain.de (With 2.5 working NIS+ domain)

We've got a principal called "nisplus" in group 14.
Nisplus is the owner of all tables/directorys.

When we now start adminsuite, hostmanager and usermanager complains
about
"domain name.domain.de not found"

If we change domainname to "name.domain.de.", we can browse the contents
of the tables, but if we try to change any credentials, usermanager
complains:

" Principal nisplus tried to change credentials in name.domain.de.."
" Principal nisplus should only change in his domain name.domain.de."
(Not the exact message, but the meaning is correct)

What the hell is going on there???

We're not able to change any credential tables with adminsuite at the
moment.
So our NIS+ domain is very "static" :-((((

We can change tables using database manager, if we are "root" user on
the NIS+ root server (rootserver is also principal) only and domain is
set to "name.domain.de."
(But I think database manager is not changing any credentials, or?)

We've also deleted NIS+ completely and reinstalled our 2.6
master/replicas and the Solaris 2.5/2.6 clients with the same result.

Could anyone help us in solving this REAL problem?

Thanks in advance,
Robert

 
 
 

Strange NIS+ probs. under Solaris2.6

Post by Supak Lailer » Wed, 22 Oct 1997 04:00:00


: When we now start adminsuite, hostmanager and usermanager complains
: about
: "domain name.domain.de not found"

: If we change domainname to "name.domain.de.", we can browse the contents
: of the tables, but if we try to change any credentials, usermanager
: complains:

It's a bug in AdminSuite. I can't remember the BugID and patch number.

Supak

 
 
 

1. nis(not nis+) on solaris2.1 and its setup.

Hi, I have been trying to install NIS+ as the manual book said,and
actually, it was running fine for a couple of days. Then there was
much trouble.I don't know if  NIS+ is  not buggy at all and I am
doing something wrong with the way I set it up.But I have decided
to try "nis" this time -all after I spent so much time trying to
get it working.

Is there a book for "nis setup for solaris2.1"?  Can I just apply
the same instruction of nis setup for bsd4.x to solaris2.1?
Is "nis setup" working as smoothly as it is on bsd4.x?

Help will be greatly appreciated.
-OonGil

--
----------------------------------------------------------------
CALIFORNIA INSTITUTE OF TECHNOLOGY  |IIIIIIIIIIIIIIIIIIIIIIIIIII

-----------------------------------------------------------------

2. HP NNM Unix trap

3. freeBSD NIS-sever - LINUX(RH-9) NIS-client LOGIN/AUTH probs

4. FCP info wanted

5. sendmail and DNS probs on Solaris2.5

6. dynamic linker prob

7. Probs with rsh(1) under Solaris2.4

8. setuid or su to root help

9. NPI DAS FDDI Probs with Solaris2.3

10. Trn3.3 & Solaris2.1 probs.

11. strange sendmail behavior (Solaris2.2)?

12. Strange problem with sunos4.1.3 vs solaris2.x

13. gcc + solaris2.6 strange problem (inet_ntoa)??