Parallel port problem with sparc classic

Parallel port problem with sparc classic

Post by Paul Dougl » Thu, 15 Aug 2002 17:34:15



I'm trying to enable printing on a sparc classic (for a friend whom I've
advised to buy a faster machine!).  I'm not an expert but have done this
on several sparcs of my own without difficulty, but am completely stuck
on this one.

The problem appears to be writing to the parallel port.  I'm using gs as
a filter to convert ps to pcl, to drive an HP ljet 4.  Using lp xxx.ps
just prints out lots of banner pages, pretty much ad nauseam.  At least
this indicates that it's possible to get data to the printer over the
parallel link, though.

If I create a .pcl file and cat it to /dev/bpp0 I get the error message
"/dev/bpp0: cannot create" even if I do this as root, yet it works fine
on my U30.  So far as I can see, all the ownerships and permissions are
the same on both machines.  I've printed the .pcl file created on the
classic on the U30 and that's fine, so it's not a file content error.

The print queue seems to be accepting jobs, and even trying to process
them (but only by the endless banner page printing).  

I'm now completely stuck!!  Any advice much appreciated.

Thanks - Paul Douglas

 
 
 

Parallel port problem with sparc classic

Post by Paul Dougl » Thu, 15 Aug 2002 18:12:48


O/S is Solaris 7, btw

 
 
 

Parallel port problem with sparc classic

Post by Greg Andre » Fri, 16 Aug 2002 06:47:41



>If I create a .pcl file and cat it to /dev/bpp0 I get the error message
>"/dev/bpp0: cannot create" even if I do this as root, yet it works fine
>on my U30.

Your U30 doesn't have a /dev/bpp0 device file for the parallel port.
It has /dev/ecpp0.  Your commands must be different on the two boxes.
If you typed the same command, that's probably the problem.

  -Greg
--
Do NOT reply via e-mail.
Reply in the newsgroup.

 
 
 

Parallel port problem with sparc classic

Post by Paul Dougl » Sat, 17 Aug 2002 21:41:36




>>If I create a .pcl file and cat it to /dev/bpp0 I get the error message
>>"/dev/bpp0: cannot create" even if I do this as root, yet it works fine
>>on my U30.

>Your U30 doesn't have a /dev/bpp0 device file for the parallel port.
>It has /dev/ecpp0.  Your commands must be different on the two boxes.
>If you typed the same command, that's probably the problem.

Sorry I wasn't clear enough - I used ecpp0 on U30 and bpp0 on classic;
what I meant by "the same" was (a) that the permissions on eccp0 on U30
were the same as those of bpp0 on classic, and (b) that cat-ing a file
to ecpp0 on U30 printed it, and cat-ing it to bpp0 on classic produced
the "/dev/bpp0: cannot create" error msg.

Paul

 
 
 

1. Parallel printer on Sun Sparc Classic

Hello out there,

Does anyone knows, how to configure a parallel printer on a SUN
Sparc Classic. Please followup by E-Mail.

Many thanks and best regards

                                 Hermann

--------------------------------------------------------------------------------
Hermann Buergi
SKW Engineering AG                   Tel. 061 901 15 55
Schneckelerstrasse 4                 Fax  061 901 20 66

                                     X.400 C=CH; A=ARCOM; P=EUNET; O=SKW S=SKW

2. Ftape does not work under X?

3. Parallel port on Classic - Experience settin up?

4. turtle beach tropez code broken

5. RELIABLE Parallel port printing (SS10/Classic etc)

6. lp0/printing problem

7. Parallel port printing (SS10/Classic etc)

8. stopping cgi processes

9. Using the Parallel Port on the Classic ?

10. port below the parallel port on the Sparc 20

11. Solaris 8 Parallel Port problem on SPARC

12. How to use Exabyte 8205 with SPARC Classic, SPARC 10??