Help with NFS....

Help with NFS....

Post by yroh » Tue, 23 Jun 1998 04:00:00



I am trying to export file system from solaris to linux.
I add "share -o ro=mylinux,root=mylinux  /export/home4/oracle" to /etc/dfs/dfstab
and run "exportfs -a".

Files seems exported, but when I mount the filesystem on linux, it says
"mount: RPC: Program not registered".

When I tried to mount, I command "mount mysolaris:/export/home4/oracle /root/oracle"

Is there something wrong ?
Please help me folks..
Thanks.

 
 
 

Help with NFS....

Post by Jagdish Prasa » Tue, 23 Jun 1998 04:00:00



> I am trying to export file system from solaris to linux.
> I add "share -o ro=mylinux,root=mylinux  /export/home4/oracle" to /etc/dfs/dfstab
> and run "exportfs -a".

> Files seems exported, but when I mount the filesystem on linux, it says
> "mount: RPC: Program not registered".

> When I tried to mount, I command "mount mysolaris:/export/home4/oracle /root/oracle"

> Is there something wrong ?
> Please help me folks..
> Thanks.

Hi,

Try running the command "/etc/init.d/nfs.server start" on the
solaris machine and then try to mount. Should do now ...

Cheers
Jagdish.

 
 
 

Help with NFS....

Post by Michael Bloo » Tue, 23 Jun 1998 04:00:00



> I add "share -o ro=mylinux,root=mylinux  /export/home4/oracle" to /etc/dfs/dfstab
> and run "exportfs -a".

> Files seems exported, but when I mount the filesystem on linux, it says
> "mount: RPC: Program not registered".
> Is there something wrong ?

Yes.  You're not running mountd.  This is because you had no NFS exports the last time you booted.
For the same reason, you're presumably not running nfsd.  To get started without rebooting,
type:
        /usr/lib/nfs/nfsd  -a  [ 16 ]
        /usr/lib/nfs/mountd

The "16" is the boot-time default. I personally wouldn't use a number that high on
my personal workstation if I was exporting oracle databases.  You might want to change
that constant. It's in: /etc/init.d/nfs.server.  Make a backup, but be careful not to
break the links if you edit it.

Michael Bloom

 
 
 

Help with NFS....

Post by root » Tue, 23 Jun 1998 04:00:00


Thank you very much !!!

 
 
 

1. Help needed: NFS V3 and NFS V2

I have a performance problem using NFS mount.
I export a file system from a machine using NFS V3 (AIX 4.2.1)
I mount this filesystem on a machine with NFS V2 (AIX 4.1.4)
The  transfer rate is worse than NFS V2 mounted on NFS V2
On the other hand if I mount the same exporeted filesystem on another
NFS V3 sysstem and that i use the "nfs3" filesystem type the transfer
rate is excellent.

Does anybody knows the solution to speed up my NFS mount when the client
runs NFS V2 (AIX 4.1.4) and the server runs NFS V3 (AIX 4.2.1).
I do not want to update my AIX 4.1.4 system.

        Thanks

                Olivier
--
 ===================================================================

 Bull S.A, Rue Jean Jaures B.P.68, 78340 Les Clayes sous Bois FRANCE
 Tel:01.30.80.63.99 Bullcom:23-76399 Fax:01.30.80.77.99

2. Yet another benchmark?

3. HELP: Slow NFS client to server causing Very slow NFS install

4. Toshiba: Portege 610ct: FreeBSD installation fails on MFS floppy disk

5. Help--readonly nfs mounts

6. margins when printing ps?

7. Help with NFS or FTP installation of Redhat Linux v5.0

8. nxterm... what.. why.. where?

9. help with nfs

10. Help: Automatic nfs and smb at startup

11. Need help with NFS mount hang

12. Help on NFS

13. HELP Intercepting NFS Requests