Help - mtx confused reporting back status/inquiry command

Help - mtx confused reporting back status/inquiry command

Post by Leo Gonzales, Jr » Wed, 08 Aug 2001 00:38:50



Hi,

I recently installed mtx on Sol 8 to control Sun StorEgde L280 autoloader.
It seems to be working fine but
occasionally I get the message "no Storage Elements reported" when I inquire
or status the device. I sometimes
need to send the status/inquire command several times before I get the
correct response instead of the
"no Storage Elements reported" message.

Is there something I can do so that I only get the message "no Storage
Elements reported" on when I have to?

Any help is greatly appreciated.

Thanks in advance,
Leo

 
 
 

1. Help: mtx -f /dev/rmt/0 inquiry and status L280

Hi,

I'm just recently installed StorEgde L280 autoloader w/ DLT 7000 drive on
Sun 220R running Solaris 8. I also want to
use mtx / amanda to control the L280. I added the following lines to the
sgen.conf file and reboot -- -r:

device-type-config-list="changer";
name="sgen" class="scsi" target=0 lun=0;
name="sgen" class="scsi" target=1 lun=0;

'mtx -f /dev/rmt/0 status' command returns:
mtx: Request Sense: Long Report=yes
mtx: Request Sense: Valid Residual=no
mtx: Request Sense: Error Code=70 (Current)
mtx: Request Sense: Sense Key=Not Ready
mtx: Request Sense: FileMark=no
mtx: Request Sense: EOM=no
mtx: Request Sense: ILI=no
mtx: Request Sense: Additional Sense Code = 04
mtx: Request Sense: Additional Sense Qualifier = 00
mtx: Request Sense: BPV=no
mtx: Request Sense: Error in CDB=no
mtx: Request Sense: SKSV=no
READ ELEMENT STATUS Command Failed

and

'mtx -f /dev/rmt/0 inquiry' command returns:
Product Type: Tape Drive
Vendor ID: 'QUANTUM '
Product ID: 'DLT7000         '
Revision: '2560'
Attached Changer: No

Questions:
1. Are the lines I added in the sgen.conf correct?
2. Do I need to do something to st.conf or some other conf file?
3. Why do I get 'READ ELEMENT STATUS Command Failed'?
4. Shouldn't the 'mtx -f /dev/rmt/0 inquiry'  return 'Attached Changer: YES'
instead of NO?

Thanks in advance,
Leo

2. glibc

3. mtx - Inquiry command Failed - help

4. Xkb Related help

5. Back from the dead (status report)

6. Need help with socket 370 upgrade

7. SOHOware PCMCIA card -- support status enquiry

8. New Problem to Old Solution?

9. Bug-report: SCSI related hang doing INQUIRY (DC390 card, 2.4.x kernels)

10. mtx command

11. Inquiry command aborts

12. problems using ioctl USCSICMD with scsi inquiry command SunOS4.1.1

13. getting status from first command in a piped command line