sendmail stoped working

sendmail stoped working

Post by John Stil » Thu, 03 Aug 2000 04:00:00



Problem: Server can't send mail.


----------------------------
Bounce Error message:
   ----- The following addresses had delivery problems -----

   ----- Transcript of session follows -----

not found)

----------------------------
/var/log/syslog is empty.

/etc/resolv.conf lists the correct name servers

I ran nslookup, ls -d my.domain.com lists the MX record for my mail
server.  

I inherated this system from many other admins.
The last time it worked was summer of 1999.

Should I just reinstall?  What does the message mean?
-------------------------------------------------------------------
John S. Stile                             /  / (_)__   _   ____  __
Network & Applications Admin        powered  /  /_/ / _  \/ /_/ /\ \/ /
Ohlone College                  by:     / ___/_/_/ /_/\_,__/ /_/\_\
(510) 659 - 7346                
-------------------------------------------------------------------

 
 
 

sendmail stoped working

Post by ho.. » Thu, 03 Aug 2000 04:00:00



> Problem: Server can't send mail.

> ----------------------------
> Bounce Error message:
>    ----- The following addresses had delivery problems -----

>    ----- Transcript of session follows -----

> not found)
> ----------------------------
> /var/log/syslog is empty.
> /etc/resolv.conf lists the correct name servers
> I ran nslookup, ls -d my.domain.com lists the MX record for my mail
> server.  
> I inherated this system from many other admins.
> The last time it worked was summer of 1999.
> Should I just reinstall?  What does the message mean?

This is the default behaviour of sendmail from Sun, if you look in
/etc/mail/sendmail.cf for:

# "Smart" relay host (may be null)
DSmailhost.$m

This is where it's trying to resolve "mailhost".  Remove "mailhost" so
it's just "DS" and it won't try to relay to a specific mailserver for all
email, it will send to whatever hostname is specified by the MX record.

--
--
Hogan Whittall
__________________________________________________________________
This is formal notice under California Assembly Bill 1629, enacted
9/26/98 that any UCE sent to my email address will be billed $50
per incident to the legally allowed maximum of $25,000.
__________________________________________________________________

 
 
 

sendmail stoped working

Post by John Stil » Thu, 03 Aug 2000 04:00:00




> > Problem: Server can't send mail.


> > ----------------------------
> > Bounce Error message:
> >    ----- The following addresses had delivery problems -----

> >    ----- Transcript of session follows -----

> > not found)

> > ----------------------------
> > /var/log/syslog is empty.

> > /etc/resolv.conf lists the correct name servers

> > I ran nslookup, ls -d my.domain.com lists the MX record for my mail
> > server.

> > I inherated this system from many other admins.
> > The last time it worked was summer of 1999.

> > Should I just reinstall?  What does the message mean?

> This is the default behaviour of sendmail from Sun, if you look in
> /etc/mail/sendmail.cf for:

> # "Smart" relay host (may be null)
> DSmailhost.$m

> This is where it's trying to resolve "mailhost".  Remove "mailhost" so
> it's just "DS" and it won't try to relay to a specific mailserver for all
> email, it will send to whatever hostname is specified by the MX record.

Thank you!  it sort-of worked.
I can only make it work with
DR$m
CR$m

The from address only lists the server's name without a domain name.
I fixed the /etc/nodename and /etc/defaultdomain, but thechange is not
effecting sendmail.

-------------------------------------------------------------------
John S. Stile                             /  / (_)__   _   ____  __
Network & Applications Admin        powered  /  /_/ / _  \/ /_/ /\ \/ /
Ohlone College                  by:     / ___/_/_/ /_/\_,__/ /_/\_\
(510) 659 - 7346                
-------------------------------------------------------------------

 
 
 

sendmail stoped working

Post by ho.. » Fri, 04 Aug 2000 04:00:00



> Thank you!  it sort-of worked.
> I can only make it work with
> DR$m
> CR$m
> The from address only lists the server's name without a domain name.
> I fixed the /etc/nodename and /etc/defaultdomain, but thechange is not
> effecting sendmail.

Ahhh, I remember having that problem in the past with SMI.  My fix?

Compile and install the latest Berkeley sendmail.  :)  If you've up for
that task, I would recommend it.  There are also basic configs you can use
with it for Solaris so it's fairly easy to get working AND with the
generic Solaris sendmail.cf file it will block relaying and such.

Beyond that, I have no idea.  I remember trying to fix that a couple of
years ago, getting frustrated, and replacing it with a standard Berkeley
sendmail.  Glad it sort-of fixed your problem.  =)

--
--
Hogan Whittall
__________________________________________________________________
This is formal notice under California Assembly Bill 1629, enacted
9/26/98 that any UCE sent to my email address will be billed $50
per incident to the legally allowed maximum of $25,000.
__________________________________________________________________

 
 
 

sendmail stoped working

Post by James A. William » Fri, 04 Aug 2000 04:00:00


You can define a mailhost in your /etc/hosts file, e. g.

123.456.11.123  host_name       mailhost


> Problem: Server can't send mail.


> ----------------------------
> Bounce Error message:
>    ----- The following addresses had delivery problems -----

>    ----- Transcript of session follows -----

> not found)

> ----------------------------
> /var/log/syslog is empty.

> /etc/resolv.conf lists the correct name servers

> I ran nslookup, ls -d my.domain.com lists the MX record for my mail
> server.

> I inherated this system from many other admins.
> The last time it worked was summer of 1999.

> Should I just reinstall?  What does the message mean?
> -------------------------------------------------------------------
> John S. Stile                             /  / (_)__   _   ____  __
> Network & Applications Admin    powered  /  /_/ / _  \/ /_/ /\ \/ /
> Ohlone College                  by:     / ___/_/_/ /_/\_,__/ /_/\_\
> (510) 659 - 7346
> -------------------------------------------------------------------

 
 
 

sendmail stoped working

Post by Gopal » Fri, 04 Aug 2000 04:00:00



qualified ) just make sure that user who is sending mail has been
included in the list.
By default sendmail strips down the DOMAIN partof the FQDN if the mails
being exchanged are within the domain.
I am not quite sure about the Variable on which it is set. On Senmail
5.5 it was CN. On Sendmail v8.x i see it is CD. Please correct me if I
am wrong.

HTH
Gopi.

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

1. Stoping sendmail from logging everything in /var/adm/messages

I am running sendmail on Linux machine.  I noticed that it is making
entries in the /var/adm/messages file everytime it receives or
delivers mail.  i would like it to stop doing that, but dont know how
to.  i dont want to mess with the sendmail.cf file although i did
read through it and found nothing relevant.
        can someone please tell me how to stop sendmail from making
these entries?  would appreicate it. thanks.
--
Sanjay Bhatia
I'm Alive.

2. Help Bmouse & SB16 SCSI 2

3. uugetty stoped working after new kernel 1.1.50 -> 1.1.54

4. Splitting archives - part 2

5. help: make stoped working when installed new gcc

6. How to deploy JSP/servlets for lots of users ?

7. SCSI Zip drive stoped working

8. (FAQ?) Support for Future Domain 1670

9. encore ne2k clone stoped working.

10. ild stoped working...

11. Ethernet card stoped working. 3COM 3C509.

12. KPPP stoped working after XFree 3.3.5 upgrade

13. Kernel 1.0 - backspace stoped working