OpenOffice 2.0 and Solaris 8

OpenOffice 2.0 and Solaris 8

Post by Mats Larsso » Fri, 25 Nov 2005 21:47:48



I've installed the OpenOffice 2.0 on a Solaris 8 machine and when I try
to start it I get the following error:

% /usr/bin/soffice
ld.so.1: soffice.bin: fatal: libgnomevfs-2.so.0: open failed: No such
file or directory
ld.so.1: soffice.bin: fatal: relocation error: file
/opt/openoffice.org2.0/program/ucpgvfs1.uno.so: symbol
gnome_vfs_initialized: referenced symbol not found

Is GNOME a pre-requisite for OO2? The system req's page
http://www.openoffice.org/dev_docs/source/sys_reqs_20.html doesn't
clearly state that. Anyone?

/MOL

 
 
 

OpenOffice 2.0 and Solaris 8

Post by PM » Fri, 25 Nov 2005 22:49:06



> I've installed the OpenOffice 2.0 on a Solaris 8 machine and when I try
> to start it I get the following error:

> % /usr/bin/soffice
> ld.so.1: soffice.bin: fatal: libgnomevfs-2.so.0: open failed: No such
> file or directory
> ld.so.1: soffice.bin: fatal: relocation error: file
> /opt/openoffice.org2.0/program/ucpgvfs1.uno.so: symbol
> gnome_vfs_initialized: referenced symbol not found

> Is GNOME a pre-requisite for OO2? The system req's page
> http://www.openoffice.org/dev_docs/source/sys_reqs_20.html doesn't
> clearly state that. Anyone?

Cannot confirm this. 'ooffice' runs here on 5.8 without gnome ...
And I cannot find any 'ucpgvfs1.uno.so' in the program directory.
Where is your OO-packet from? May be something self-made with
gnome-vfs support compiled in?

PM

 
 
 

OpenOffice 2.0 and Solaris 8

Post by Mats Larsso » Fri, 25 Nov 2005 23:54:37



Quote:> Cannot confirm this. 'ooffice' runs here on 5.8 without gnome ...
> And I cannot find any 'ucpgvfs1.uno.so' in the program directory.
> Where is your OO-packet from? May be something self-made with
> gnome-vfs support compiled in?

I did download OO from www.openoffice.org and 'ucpgvfs1.uno.so' comes from:

% grep 'ucpgvfs1.uno.so' /var/sadm/install/contents
/opt/openoffice.org2.0/program/ucpgvfs1.uno.so f none 0444 root bin
164756 44013 1126367782 openofficeorg-gnome-integration

 
 
 

OpenOffice 2.0 and Solaris 8

Post by Marc » Sat, 26 Nov 2005 02:30:23



> I did download OO from www.openoffice.org and 'ucpgvfs1.uno.so' comes from:

> % grep 'ucpgvfs1.uno.so' /var/sadm/install/contents
> /opt/openoffice.org2.0/program/ucpgvfs1.uno.so f none 0444 root bin
> 164756 44013 1126367782 openofficeorg-gnome-integration

You might want to pkgrm openofficeorg-gnome-integration if gnome is not
installed...
 
 
 

OpenOffice 2.0 and Solaris 8

Post by Mats Larsso » Tue, 29 Nov 2005 18:52:39



Quote:> You might want to pkgrm openofficeorg-gnome-integration if gnome is not
> installed...

Came to the same conclusion... thanks anyway.
 
 
 

1. OpenOffice on YDL 2.0: where's Java?

I'm a newbie. I did the "everything" install of YDL 2.0 and now I'm
trying to install OpenOffice. The installer tells me that I have to
point it to my Java runtime environment, "jdk" or "jre 1.3".

I've started at the root level and searched all through every directory
I can find, but I can't find what I need.

With a YDL 2.0 "everything" install, where should my Java runtime be? Is
it in fact NOT included? I would find that hard to believe.

Wheat Williams
Atlanta, Georgia

2. Static X11, unresolved

3. openOffice.org announces openOffice.org 1.0

4. Newbie: Installation of 4.3 on 43P-133 bombs

5. OpenOffice 1.0.2 port(dk-openoffice) broken=

6. dip -t "Hostname lookup failed"

7. Matrox Mystique ands X.

8. Pine on AIX 4.2.1

9. FS: SOLARIS 7 SERVER, SOLARIS EASY ACCESS 2.0, SOLARIS 2.6 KIT

10. Openoffice 1.0 port for Sparc Solaris 2.6

11. openoffice 1.0.1 crashes on solaris 9

12. Solaris 10: The OpenOffice Model.

13. Solaris 1.1 vs. Solaris 2.0 (BSD vs AT&T)