terminal problem w/ vi

terminal problem w/ vi

Post by Laura Klemme-Da » Sat, 10 May 1997 04:00:00



I have a user with a system using Solaris 5.2 with the Open Windows GUI.
The default setup has been set to increase the size of the windows when
opening a new terminal csh window.  The larger window size is required
for better viewing.  However, when typing, vi <filename> the bottom of
the screen does not scroll properly.  Instead, the lines write over
themselves when using the up/down navigation keystrokes.

Does anyone have an idea on how to fix this problem?  Perhaps an
addition to the .cshrc file?

Thanks.
--

======================================= Laura Klemme-Day  
===    /\                      \  / === System Administrator
===   /__\    ______  ___  ___  \/  === AMPEX Corporation
===  /    \  /  /  / /__/ /__   /\  === 500 Broadway MS-2103
=== /      \/  /  / /    /___  /  \ === Redwood City, CA  94063

Web:  http://www.ampex.com              Tel: (415)367-3706
======================================= Fax: (415)367-2840

 
 
 

terminal problem w/ vi

Post by Richard Bowma » Tue, 13 May 1997 04:00:00



> I have a user with a system using Solaris 5.2 with the Open Windows GUI.
> The default setup has been set to increase the size of the windows when
> opening a new terminal csh window.  The larger window size is required
> for better viewing.  However, when typing, vi <filename> the bottom of
> the screen does not scroll properly.  Instead, the lines write over
> themselves when using the up/down navigation keystrokes.

not a csh problem but a terminal problem.

you are running solaris 5.2? wow how old/new is that? or solaris 2.5?

try using the resize commadn
        /usr/openwin/bin/resize

then if still messed up use the rows and columns returned
from the resize command with the stty commnad to FORCE
the rows & column sizes.

hellcat /opt/hpnp/bin> resize
set noglob;
setenv COLUMNS '85';
setenv LINES '35';
unset noglob;
hellcat /opt/hpnp/bin> stty rows 35 cols 85

enjoy!
rich


 
 
 

1. Vi host terminal problems?

Hi,

I have a strange problem with elvis version 1.8 under vms or ultrix
as the host. When I log on to either vms or ultrix and try to use
elvis version 1.8 under ckermit with either a xterm or console under
Linux, the cursor jumps all over the screen. The cursor moves to the right,
but also moves all the way to left side of the screen after each keypress.
When the cursor gets the right side of the screen it starts to jump to the
bottom of the screen also with each keypress. Note I'm talking about how vi
looks on my x-terminal or console.

Since this does not happen with OS/2 and ckermit. I suspect that
something is setup wrong with the terminals in Linux.

Any help would be apperciated.

Thanks,

Helen

2. CSA

3. vi and terminal problem

4. FS: ethernet hubs

5. vi - problem on ibm3151 terminal

6. network card problem (DEC DC21142 tulip)

7. Terminal set-up and vi problem

8. massive fragmentation on masqueraded link

9. vi question - unknown terminal type

10. Terminal settings for vi

11. vi doesn't restore the terminal (text) in Solaris 2.4

12. vi color schemes in rxvt terminal under X

13. Minicom terminal screwed up after using vi online