Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Post by Richard Kon » Tue, 23 Feb 1999 04:00:00



Just wondering, is there a patch that is floating out there for this
problem? Basically, I am using a Jumpstart server to build
2.6 boxes and it builds fine except for the reboot and it says that
it cannot find the boot block for the drive (I've tried 2 different
drives of the same model). i have even tried running "installboot"
manually and the command completes successfully but it still
fails the bootup process. The only patch that I saw that might
have anything to do with scsi was 106173-03. Has anyone
else seen this problem? Also 4GB EIDE drives work fine
for the Jumpstart (it is configured with "free" for slice 0, so
the partitioning info is not relevant - in otherwords we are using
the entire slice 0 for our /, /usr, etc and another slice for swap
but that's it).

Here's the bootup error:

Rebooting with command:

args:
bootblk: can't find the boot program
Program terminated
Type  help  for more information
ok probe-scsi

Target 3
  Unit 0   Disk     IBM     DDRS34560SUN4.2GS98E98432G8752
                    (C) Copyright IBM Corp.
                    1997. All rights reserved.

TIA,

Rich

 
 
 

Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Post by Mark Saile » Tue, 23 Feb 1999 04:00:00



> Here's the bootup error:

> Rebooting with command:

> args:
> bootblk: can't find the boot program
> Program terminated
> Type  help  for more information

I'm having the same problem on a Sparc20 with a gig scsi drive.
I have reloaded  2.6 get the same result.  This had been working before
this.
I'm scratching my head.

--
........ Mark Sailer

 
 
 

Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Post by Roger Marqui » Wed, 24 Feb 1999 04:00:00



Quote:>in otherwords we are using
>the entire slice 0 for our /, /usr, etc and another slice for swap
>but that's it).

Is your root partition 1.98GB or smaller?

--
Roger Marquis
Roble Systems Consulting
http://www.roble.com/

 
 
 

Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Post by Trond Norby » Wed, 24 Feb 1999 04:00:00



> Just wondering, is there a patch that is floating out there for this
> problem? Basically, I am using a Jumpstart server to build
> 2.6 boxes and it builds fine except for the reboot and it says that
> it cannot find the boot block for the drive (I've tried 2 different
> drives of the same model). i have even tried running "installboot"
> manually and the command completes successfully but it still
> fails the bootup process. The only patch that I saw that might
> have anything to do with scsi was 106173-03. Has anyone
> else seen this problem? Also 4GB EIDE drives work fine
> for the Jumpstart (it is configured with "free" for slice 0, so
> the partitioning info is not relevant - in otherwords we are using
> the entire slice 0 for our /, /usr, etc and another slice for swap
> but that's it).

You need to make your root partition less than 2GB (I think it is a
limitation in the boot prom of old SPARC's). That worked for me on a SS4
with Trusted Solaris.

Trond Norbye
--
Software Engineer


Professor Brochs g 6
N-7030 Trondheim                                  phone: +47 73 54 02 36
NORWAY

 
 
 

Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Post by Richard Kon » Wed, 24 Feb 1999 04:00:00


Thanks for the replies everybody. I am checking with SUN to see if a PROM
upgrade for the Sparc 20s is in order, and that looks to be the problem.


> > Just wondering, is there a patch that is floating out there for this
> > problem? Basically, I am using a Jumpstart server to build
> > 2.6 boxes and it builds fine except for the reboot and it says that
> > it cannot find the boot block for the drive (I've tried 2 different
> > drives of the same model). i have even tried running "installboot"
> > manually and the command completes successfully but it still
> > fails the bootup process. The only patch that I saw that might
> > have anything to do with scsi was 106173-03. Has anyone
> > else seen this problem? Also 4GB EIDE drives work fine
> > for the Jumpstart (it is configured with "free" for slice 0, so
> > the partitioning info is not relevant - in otherwords we are using
> > the entire slice 0 for our /, /usr, etc and another slice for swap
> > but that's it).

> You need to make your root partition less than 2GB (I think it is a
> limitation in the boot prom of old SPARC's). That worked for me on a SS4
> with Trusted Solaris.

> Trond Norbye
> --
> Software Engineer


> Professor Brochs g 6
> N-7030 Trondheim                                  phone: +47 73 54 02 36
> NORWAY

 
 
 

Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Post by Richard Kon » Wed, 24 Feb 1999 04:00:00


ok, chatted with SUN engineers about this, and they said that the
4m (ie: Sparc 5s and 20s) PROMs will not be upgraded
to handle root filesystems that are bigger than 1.98 in order
to boot off of them that is. The 4u (Ultra whatevers) are
using PROM version 3.x and they have not seen a problem
as of yet although it is not supported for 9GB drives (that you
want to make slice 0 the whole disk that is). bummer, but that's
life and i'll have to modify the Jumpstart scripts to reflect this.

They said info doc: 16065 on the sunsolve site explains this.

Thanks again for everyone's help!

Rich


> Just wondering, is there a patch that is floating out there for this
> problem? Basically, I am using a Jumpstart server to build
> 2.6 boxes and it builds fine except for the reboot and it says that
> it cannot find the boot block for the drive (I've tried 2 different
> drives of the same model). i have even tried running "installboot"
> manually and the command completes successfully but it still
> fails the bootup process. The only patch that I saw that might
> have anything to do with scsi was 106173-03. Has anyone
> else seen this problem? Also 4GB EIDE drives work fine
> for the Jumpstart (it is configured with "free" for slice 0, so
> the partitioning info is not relevant - in otherwords we are using
> the entire slice 0 for our /, /usr, etc and another slice for swap
> but that's it).

> Here's the bootup error:

> Rebooting with command:

> args:
> bootblk: can't find the boot program
> Program terminated
> Type  help  for more information
> ok probe-scsi

> Target 3
>   Unit 0   Disk     IBM     DDRS34560SUN4.2GS98E98432G8752
>                     (C) Copyright IBM Corp.
>                     1997. All rights reserved.

> TIA,

> Rich

 
 
 

Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Post by Richard Kon » Wed, 24 Feb 1999 04:00:00


ok, chatted with SUN engineers about this, and they said that the
4m (ie: Sparc 5s and 20s) PROMs will not be upgraded
to handle root filesystems that are bigger than 1.98 in order
to boot off of them that is. The 4u (Ultra whatevers) are
using PROM version 3.x and they have not seen a problem
as of yet although it is not supported for 9GB drives (that you
want to make slice 0 the whole disk that is). bummer, but that's
life and i'll have to modify the Jumpstart scripts to reflect this.

They said info doc: 16065 on the sunsolve site explains this.

Thanks again for everyone's help!

Rich


> Just wondering, is there a patch that is floating out there for this
> problem? Basically, I am using a Jumpstart server to build
> 2.6 boxes and it builds fine except for the reboot and it says that
> it cannot find the boot block for the drive (I've tried 2 different
> drives of the same model). i have even tried running "installboot"
> manually and the command completes successfully but it still
> fails the bootup process. The only patch that I saw that might
> have anything to do with scsi was 106173-03. Has anyone
> else seen this problem? Also 4GB EIDE drives work fine
> for the Jumpstart (it is configured with "free" for slice 0, so
> the partitioning info is not relevant - in otherwords we are using
> the entire slice 0 for our /, /usr, etc and another slice for swap
> but that's it).

> Here's the bootup error:

> Rebooting with command:

> args:
> bootblk: can't find the boot program
> Program terminated
> Type  help  for more information
> ok probe-scsi

> Target 3
>   Unit 0   Disk     IBM     DDRS34560SUN4.2GS98E98432G8752
>                     (C) Copyright IBM Corp.
>                     1997. All rights reserved.

> TIA,

> Rich

 
 
 

Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Post by Richard Kon » Wed, 24 Feb 1999 04:00:00


ok, chatted with SUN engineers about this, and they said that the
4m (ie: Sparc 5s and 20s) PROMs will not be upgraded
to handle root filesystems that are bigger than 1.98 in order
to boot off of them that is. The 4u (Ultra whatevers) are
using PROM version 3.x and they have not seen a problem
as of yet although it is not supported for 9GB drives (that you
want to make slice 0 the whole disk that is). bummer, but that's
life and i'll have to modify the Jumpstart scripts to reflect this.

They said info doc: 16065 on the sunsolve site explains this.

Thanks again for everyone's help!

Rich


> Just wondering, is there a patch that is floating out there for this
> problem? Basically, I am using a Jumpstart server to build
> 2.6 boxes and it builds fine except for the reboot and it says that
> it cannot find the boot block for the drive (I've tried 2 different
> drives of the same model). i have even tried running "installboot"
> manually and the command completes successfully but it still
> fails the bootup process. The only patch that I saw that might
> have anything to do with scsi was 106173-03. Has anyone
> else seen this problem? Also 4GB EIDE drives work fine
> for the Jumpstart (it is configured with "free" for slice 0, so
> the partitioning info is not relevant - in otherwords we are using
> the entire slice 0 for our /, /usr, etc and another slice for swap
> but that's it).

> Here's the bootup error:

> Rebooting with command:

> args:
> bootblk: can't find the boot program
> Program terminated
> Type  help  for more information
> ok probe-scsi

> Target 3
>   Unit 0   Disk     IBM     DDRS34560SUN4.2GS98E98432G8752
>                     (C) Copyright IBM Corp.
>                     1997. All rights reserved.

> TIA,

> Rich

 
 
 

Solaris 2.6 - Having trouble installing boot block on 4GB SCSI drive

Post by Richard Kon » Wed, 24 Feb 1999 04:00:00


ok, chatted with SUN engineers about this, and they said that the
4m (ie: Sparc 5s and 20s) PROMs will not be upgraded
to handle root filesystems that are bigger than 1.98 in order
to boot off of them that is. The 4u (Ultra whatevers) are
using PROM version 3.x and they have not seen a problem
as of yet although it is not supported for 9GB drives (that you
want to make slice 0 the whole disk that is). bummer, but that's
life and i'll have to modify the Jumpstart scripts to reflect this.

They said info doc: 16065 on the sunsolve site explains this.

Thanks again for everyone's help!

Rich


> Just wondering, is there a patch that is floating out there for this
> problem? Basically, I am using a Jumpstart server to build
> 2.6 boxes and it builds fine except for the reboot and it says that
> it cannot find the boot block for the drive (I've tried 2 different
> drives of the same model). i have even tried running "installboot"
> manually and the command completes successfully but it still
> fails the bootup process. The only patch that I saw that might
> have anything to do with scsi was 106173-03. Has anyone
> else seen this problem? Also 4GB EIDE drives work fine
> for the Jumpstart (it is configured with "free" for slice 0, so
> the partitioning info is not relevant - in otherwords we are using
> the entire slice 0 for our /, /usr, etc and another slice for swap
> but that's it).

> Here's the bootup error:

> Rebooting with command:

> args:
> bootblk: can't find the boot program
> Program terminated
> Type  help  for more information
> ok probe-scsi

> Target 3
>   Unit 0   Disk     IBM     DDRS34560SUN4.2GS98E98432G8752
>                     (C) Copyright IBM Corp.
>                     1997. All rights reserved.

> TIA,

> Rich

 
 
 

1. Problem with labeling a 4GB SCSI HDD in "format" utility in INTEL Solaris 2.6

Problem with labeling a 4GB SCSI HDD in "format" utility in INTEL Solaris
2.6

When I used only 50% of the entire space that is available in fdisk,
labeling works fine and newfs and mount will eventually give me an extra
HDD, but with only 2GB space, less than I need.

I am using Solaris 2.6 FOR INTEL and was told that it was designed to
eliminate the 2GB ghost.

If any of you professionals and expert can give me a hint or an advice, it
would be wonderful indeed.

Thanks a lot,

Tadao, a Solaris beginner in Japan

2. lpr with HP5MP

3. install new scsi drive on Solaris 2.6

4. looking for driver for hpt 370 Raid controller w/ dual gig. proc. capabilities.

5. Solaris 2.6 Install only recognizes SCSI ID 0 drive

6. Setting up Ctrl-Alt-Ins = halt

7. Anyone having trouble installing Linux on a drive using EZ Drive should read this post.

8. ati rage ii and gateway 17inch crystalscan

9. Help: Can't boot Solaris 2.6 having saved System State.

10. Trouble to add New Hard Drive to Ultra 1 Solaris 2.6

11. Do Solaris 2.6 support 4GB swap?

12. Redhat 5.0 multia and having trouble formating scsi drive.