netgroup under NIS on 2.5

netgroup under NIS on 2.5

Post by Greg Robins » Thu, 18 Jul 1996 04:00:00



Hi,

I was wondering if anybody knows if netgroups even WORKS under Solaris 2.5?

I continually get permission denied.

This is using NIS/YP not NIS+.

We are about to install patch #103053-01 (mkalias) patch, so this migh
fix something.

Thankx,

Greg.

--


 
 
 

netgroup under NIS on 2.5

Post by Charles Stephen » Sat, 20 Jul 1996 04:00:00


 GR> I was wondering if anybody knows if netgroups even WORKS under
 GR> Solaris 2.5?

 GR> I continually get permission denied.

 GR> This is using NIS/YP not NIS+.

 GR> We are about to install patch #103053-01 (mkalias) patch, so this
 GR> migh fix something.

How are you using netgroups.  In /etc/passwd or for exporting NFS
filesystems, or perhaps a custom app?

cfs
--

Software Engineer (I think)        = "And thus spake the great lawyers:
SunSoft, a SMI Business            =  thou shall not speaketh for Sun or its
Menlo Park, California, USA        =  subsidaries, and disclaim all information
                                   =  hereforth, so they sue you, not us."
Spitting is strictly prohibited.   = THIS SPACE FOR SUBLEASE, reasonable rates.

 
 
 

netgroup under NIS on 2.5

Post by Greg Robins » Tue, 23 Jul 1996 04:00:00



:
:  GR> I was wondering if anybody knows if netgroups even WORKS under
:  GR> Solaris 2.5?
:
:  GR> I continually get permission denied.
:
:  GR> This is using NIS/YP not NIS+.
:
:  GR> We are about to install patch #103053-01 (mkalias) patch, so this
:  GR> migh fix something.
:
: How are you using netgroups.  In /etc/passwd or for exporting NFS
: filesystems, or perhaps a custom app?

Exporting NFS filesystems.  And that's all.  Even a wildcard ( (,,) )
doesn't work.

We've logged a call with Sun Australia.

Greg.

--


 
 
 

netgroup under NIS on 2.5

Post by Erwin Fri » Wed, 24 Jul 1996 04:00:00






>:
>:  GR> I was wondering if anybody knows if netgroups even WORKS under
>:  GR> Solaris 2.5?
>:
>:  GR> I continually get permission denied.
>:
>:  GR> This is using NIS/YP not NIS+.
>:
>:  GR> We are about to install patch #103053-01 (mkalias) patch, so this
>:  GR> migh fix something.
>:
>: How are you using netgroups.  In /etc/passwd or for exporting NFS
>: filesystems, or perhaps a custom app?

>Exporting NFS filesystems.  And that's all.  Even a wildcard ( (,,) )
>doesn't work.

I use it extensively to export/share filesystems.  It works fine.  One thing
I've noticed though: if the host in a netgroup is a SunOS 4.1.3 machine
(without the upgrade _U1), I have to fully qualify the hostname or it doesn't
resolve.

For example, let's say I have a netgroup file like:

workstations (bill,,) (bob,,) (jane,,)

If Jane's machine doesn't have the 4.1.3 upgrade, I have to have it like this:

workstations (bill,,) (bob,,) (jane.domainname.com,,)

If I don't, then Jane can't mount the share.  

I suspect that's a bug with the 4.13 resolver, not with netgroups.

 
 
 

netgroup under NIS on 2.5

Post by Greg Robins » Fri, 26 Jul 1996 04:00:00




: >


: >:
: >:  GR> I was wondering if anybody knows if netgroups even WORKS under
: >:  GR> Solaris 2.5?
: >:
: >:  GR> I continually get permission denied.
: >:
: >:  GR> This is using NIS/YP not NIS+.
: >:
: >:  GR> We are about to install patch #103053-01 (mkalias) patch, so this
: >:  GR> migh fix something.
: >:
: >: How are you using netgroups.  In /etc/passwd or for exporting NFS
: >: filesystems, or perhaps a custom app?
: >
: >Exporting NFS filesystems.  And that's all.  Even a wildcard ( (,,) )
: >doesn't work.
: >
:  
: I use it extensively to export/share filesystems.  It works fine.  One thing
: I've noticed though: if the host in a netgroup is a SunOS 4.1.3 machine
: (without the upgrade _U1), I have to fully qualify the hostname or it doesn't
: resolve.

It could be a problem with the DNS name of jane.  Try looking at /etc/hosts
and the NIS hosts database etc.

Well, we have a solution:  There is none.  Yes, we've logged our own bug
with Sun!

We were (apparently) doing something funny:  Running NIS on one machine and
exporting directories from the *same* machine.  This is why netgroups
doesn't work.  If we had our nfs server on a different machine, presto,
things would work.  Why would you do this anyway?  For a big site, sure,
but if you're on a budget???

It will work if you mount the disk onto the master from the client, but
not the other way round.

It will be fixed in 2.6.  *big sigh*

Greg.

--


 
 
 

netgroup under NIS on 2.5

Post by James A. Dietri » Fri, 26 Jul 1996 04:00:00


: Well, we have a solution:  There is none.  Yes, we've logged our own bug
: with Sun!
:
: We were (apparently) doing something funny:  Running NIS on one machine and
: exporting directories from the *same* machine.  This is why netgroups
: doesn't work.  If we had our nfs server on a different machine, presto,
: things would work.  Why would you do this anyway?  For a big site, sure,
: but if you're on a budget???

  incorrect. Our NFS server and NIS master are in fact, the same
machine, and netgroups work just fine under 2.5 for us. Are you using an
older version of NSkit? There should have been a fix released for nskit
a couple months ago. (and to top it off, we're even using ODS4.0 in the mix
along with 3 SCSI busses)

-jim

 ____________________________________________________________________________
/                (James Dietrick Jr|Demon of S004|guido)                     \

|  Assistant Systems Administrator, Chemical Engineering Department of MTU.  |
\----------------------------------------------------------------------------/

 
 
 

1. NIS netgroup support broken under NIS+

I'm running an NIS+ server for a heterogeneous network of SunOS,
Solaris, and IRIX machines.  Obviously, I need to run using the NIS
compatibility mode.  Everything works except the "netgroup" map.  A
ypcat on "netgroup" yields nothing, but a ypmatch works.  Basically,
this breaks NFS exports that use netgroups.

I've checked the permissions and everything.  All the other maps work
correctly.  Only the netgroup map doesn't work.

I can't believe that this is still broken (see SunSolve bug report
#1128286) from 1993.  Tech support told me to upgrade to Solaris--no
can do.  This is a problem for me trying to migrate to NIS+.  Maybe
I'll just install the NIS server and forget about NIS+ for now.  Does
anyone have the same experience?  Is there a patch?
--

iliketaylorguitarsleeoskarharpsmackiemixerstheblueskingsxemacsperltcltk

2. Xlib problem

3. Using netgroup with NIS or NIS+

4. pthreads documentation

5. Secure NFS under Solaris 2.5/2.5.1 without NIS/NIS+ ?

6. problem with 2nd modem

7. Sol 2.5 NIS Server & 2.4 NIS Client?

8. regular expressions, which calls?

9. Solaris 2.3 w/NIS+ Upgrade to 2.5 w/ NIS+ (Master Server)?

10. configuring NIS in 2.5 not NIS+

11. Solaris 2.3 NIS+ Upgrade to Solaris 2.5 NIS+ Question!

12. NIS+ (Solaris 2.5) / NIS Emulation for AIX 3.2.5

13. LDAP and netgroup.byhost / netgroup.byuser