Please help: Wield login problem.

Please help: Wield login problem.

Post by Heling Y » Wed, 17 Sep 1997 04:00:00



Hi,

we have a wield login problem with Ultra 2 running Solaris 2.5.1. Root can
log in but normal users can't. The error message I got when I tried to
log in as a normal user is the following:

login: hello
Password:
No directory!

However, after logging as root, I found that the user home directories
mounted correctly. Moreover, I can't su the normal users, the error
message is

#su hello
su: No shell

BTW, we are using NIS,the Ultra 2 is a client. Other clients on the system
(including a Sparc 4 which is also runing Solaris 2.5.1 box) have no
problem at all.

Any idea?

Thanks a lot in advance!

Heling

 
 
 

Please help: Wield login problem.

Post by Alba Jervi » Sun, 21 Sep 1997 04:00:00



> Hi,

> we have a wield login problem with Ultra 2 running Solaris 2.5.1. Root can
> log in but normal users can't. The error message I got when I tried to
> log in as a normal user is the following:

> login: hello
> Password:
> No directory!

> However, after logging as root, I found that the user home directories
> mounted correctly. Moreover, I can't su the normal users, the error
> message is

> #su hello
> su: No shell

There you have it I think... Check in the /etc/password file or the
/etc/shadow file (if you are using that). Have a look at the path
specified for the users shell. I've seen this error when adding a
user with a special shell (i.e. tcsh) which was not in the place
stated in the password file. You might want to set up a symbolic link
to correct this problem.

The default shell for root is sh which is probably not the one specified
for the other users (which is why root works)

Mike Jervis
Western Atlas Logging Services

 
 
 

1. HELP!! Wield routing problem ..

I has a SUN Sparc computer with SOLARIS 2.5 installed.  The computer need has
two router address put on /etc/defaultrouter.  One access to Internet , another
access to other division of our company.  

E.G.
/etc/defaultrouter
        129.4.1.4   (firewall, router, DNS server go out to INTERNET)
        129.4.2.49  (router to other division 188.178.22.XXX)

/etc/netmask
        129.4.0.0       255.255.0.0

Currently, I have problem the network very inconsistency.  For example 5 minutes
ago, I can FTP to sun but 5 minutes I can NOT and get error message "unknown
host".  Same problem happen on access to 188.178.22.XXX computers.  Can anyone
tell me how to fix it?  Thank you.

2. Chkdsk for linux?

3. PLEASE PLEASE HELP Major problem with my SCSI & Redhat 5.0 PLEASE Help

4. Where are docs for Enhanced IDE

5. Sendmail problems. Please please please please help!

6. Trouble compiling GCC 2.7.0 under Solaris 2.3

7. LINUX instalation problems, PLEASE HELP !?!Subject: LINUX , instalation problems, PLEASE HELP !?!

8. One problem with Linux

9. Help:modem acting wield:dedicated printing when I connect

10. SUN E250 wield hang problem?

11. URGENT HELP PLEASE - Login problem

12. please help newbie with login problem

13. Login problem ,please help me.