Missing Library File

Missing Library File

Post by Carl Smi » Thu, 10 Jun 1999 04:00:00



To All:

I am currently working on a project which involves running an application
developed by an outside party.  I have installed their application onto a
Sun Ultra running Solaris 2.6 ("standard" install).  When I attempt to
start the application, I get an the following error message:

fatal:  libxnet.so.1: open failed: No such file or directory.

I realize that it is a shared library that cannot be opened, but I cannot
find such a library on my system.  The question that I have is then, is
libxnet a library used by developers, a library from SunOS5 (or
development tool/environment), or is it a third party library?  (The
application was developed on Suns running SunOS & Solaris.)

Thanks in advance for any info or clues.

Carl Smith.

 
 
 

Missing Library File

Post by dharz.. » Thu, 10 Jun 1999 04:00:00



Quote:> fatal:  libxnet.so.1: open failed: No such file or directory.

It should be in /usr/lib

Quote:> The question that I have is then, is libxnet a library used by
developers,
> a library from SunOS5 (or development tool/environment), or is it a
third
> party library?

It is part of the standard Solaris 2.6 libraries.

Noal
--
"Sure, it's every American's right to post false or misleading
information on the Internet."
-The Detroit News

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

 
 
 

Missing Library File

Post by Alan Coopersmi » Thu, 10 Jun 1999 04:00:00



>I am currently working on a project which involves running an application
>developed by an outside party.  I have installed their application onto a
>Sun Ultra running Solaris 2.6 ("standard" install).  When I attempt to
>start the application, I get an the following error message:

>fatal:  libxnet.so.1: open failed: No such file or directory.

>I realize that it is a shared library that cannot be opened, but I cannot
>find such a library on my system.

/usr/lib/libxnet.so.1 should be present on all Solaris 2.6 systems since
it's part of the SUNWcsu core package.

--
________________________________________________________________________

Univ. of California at Berkeley         http://soar.Berkeley.EDU/~alanc/

 
 
 

1. libpng.so.3 - missing library file missing

I reinstalled ghostscript from another mirror site Still have the same problem  .
Please HELP . some suggestions .
# ldd /opt/csw/bin/gs
        libXt.so.4 =>    /usr/lib/libXt.so.4
        libXext.so.0 =>  /usr/lib/libXext.so.0
        libX11.so.4 =>   /usr/lib/libX11.so.4
        libpng.so.3 =>   (file not found)
        libz.so.1 =>     /usr/lib/libz.so.1
        libm.so.1 =>     /usr/lib/libm.so.1
        libc.so.1 =>     /usr/lib/libc.so.1
        libSM.so.6 =>    /usr/lib/libSM.so.6
        libICE.so.6 =>   /usr/lib/libICE.so.6
        libdga.so.1 =>   /usr/openwin/lib/libdga.so.1
        libsocket.so.1 =>        /usr/lib/libsocket.so.1
        libnsl.so.1 =>   /usr/lib/libnsl.so.1
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libmp.so.2 =>    /usr/lib/libmp.so.2
#

2. How can I install solaris 7 to my sparcStation 5 from a Linux Computer CdRom ??

3. Gnome missing library file

4. Matrox G400 w/ Debain 2.1??

5. Missing Library Files

6. Netscape(libXpm.so.4)???

7. missing library files?

8. mouse doesn't work?

9. Missing Library File for many crucial programs!

10. Missing Library Files.

11. missing library files? ld.so.1 on Solaris 7

12. sendmail library file missing?!?

13. missing java library file