Veritas Netbackup issue - tape selection

Veritas Netbackup issue - tape selection

Post by ray » Thu, 05 Sep 2002 00:30:23



1000 appy-polly-loggies for posting a netbackup question to a solaris
group, but I saw where others had posted their netbackup issues here.
I am, however, running it on solaris 8 - e250. I'm running Veritas
netbackup version 3.4. I have an exabyte 440 tape library - using
mammoth-2 tapes/drives.

My question: I have a volume pool with three tapes in it...

3YearRetention pool

005002  8MM      TL8      0       3      A03     7     451296   ACTIVE
005001  8MM      TL8      0       2      A02     -     -      
AVAILABLE
005003  8MM      TL8      0       4      A04     -     -      
AVAILABLE

For some sick reason, netbackup continuously picks tape 5002 over 5001
and 5003. These two tapes (5001/5003)have no data on it and have never
been mounted.

From one of my debug logs, Netbackup only considers tapes that have
data.

10:34:07 [11241] <2> select_media: skipping media id 005016, it is not
the correct retention_level
10:34:07 [11241] <2> select_media: skipping media id 005000, it is not
the correct retention_level
10:34:07 [11241] <2> select_media: skipping media id 005004, it is not
the correct retention_level
10:34:07 [11241] <2> select_media: selected media id 005002 for
backup, hpdev-back(rl = 7) <----------
10:34:07 [11241] <2> write_backup: backup child process is pid 11244
10:34:07 [11241] <2> mount_open_media: Waiting for mount of media id
005002 on server drcsunbu1.

So it seems its selecting tapes that contain the same retention first,
then it selects from the pool. Is there some button/option I'm missing
to get it to select pool over retention - or to pick least number of
mounts in a pool first.
I'm not backing up huge amounts of data and there are several backups
running to this pool. I would like to spread the data out evenly in
the pool to prevent the one tape from being thrashed by a few
backups/day containing only about 100megs of data each.

Thanks.

 
 
 

Veritas Netbackup issue - tape selection

Post by Darren Dunha » Thu, 05 Sep 2002 04:34:10



> 1000 appy-polly-loggies for posting a netbackup question to a solaris
> group, but I saw where others had posted their netbackup issues here.

It is somewhat on-topic, but you may well get better answers if you post
it to the veritas netbackup mailing list instead.

Go look at http://mailman.eng.auburn.edu/mailman/listinfo/veritas-bu/

Quote:> I am, however, running it on solaris 8 - e250. I'm running Veritas
> netbackup version 3.4. I have an exabyte 440 tape library - using
> mammoth-2 tapes/drives.
> My question: I have a volume pool with three tapes in it...
> 3YearRetention pool
> 005002  8MM      TL8      0       3      A03     7     451296   ACTIVE
> 005001  8MM      TL8      0       2      A02     -     -      
> AVAILABLE
> 005003  8MM      TL8      0       4      A04     -     -      
> AVAILABLE
> For some sick reason, netbackup continuously picks tape 5002 over 5001
> and 5003. These two tapes (5001/5003)have no data on it and have never
> been mounted.
> From one of my debug logs, Netbackup only considers tapes that have
> data.
> 10:34:07 [11241] <2> select_media: skipping media id 005016, it is not
> the correct retention_level
> 10:34:07 [11241] <2> select_media: skipping media id 005000, it is not
> the correct retention_level
> 10:34:07 [11241] <2> select_media: skipping media id 005004, it is not
> the correct retention_level
> 10:34:07 [11241] <2> select_media: selected media id 005002 for
> backup, hpdev-back(rl = 7) <----------
> 10:34:07 [11241] <2> write_backup: backup child process is pid 11244
> 10:34:07 [11241] <2> mount_open_media: Waiting for mount of media id
> 005002 on server drcsunbu1.
> So it seems its selecting tapes that contain the same retention first,
> then it selects from the pool.

No, it's picking the right pool, but it does have to be the right
retention also.

Quote:> Is there some button/option I'm missing
> to get it to select pool over retention - or to pick least number of
> mounts in a pool first.

Generally, it will try to "use up" a tape.  5002 is still active.  If it
uses the others, then 5002 would have blank space at the end.

Quote:> I'm not backing up huge amounts of data and there are several backups
> running to this pool. I would like to spread the data out evenly in
> the pool to prevent the one tape from being thrashed by a few
> backups/day containing only about 100megs of data each.

Then you probably need to set up separate pools.

--

Unix System Administrator                    Taos - The SysAdmin Company
Got some Dr Pepper?                           San Francisco, CA bay area
         < This line left intentionally blank to confuse you. >

 
 
 

1. Veritas Netbackup and tape device permissions

Heelo!

We're running Veritas Netbackup Datacenter on a Sun Enterprise 250 with
Solaris 7.
Qaulstar 412300 AIT taperobot with 4xAIT-2 drives. One additional AIT-1
drive on a
different SCSI channel.

The AIT-1 drive is not included in the tape robot tape pool.

Veritas changes the permission of the /dev/rmt/0cbn device to 600.

# ls -l  /dev/rmt/0cbn
lrwxrwxrwx   1 root           45 Jan 14  1999 /dev/rmt/0cbn ->


crw-------   1 root      33, 476 Mar  5 02:58

I have tried to reset to 666, but Veritas keeps resetting to 600...

What's  wrong??

- Nils

2. sound problems with mandrake 9.0 and gigabyte mbo

3. Veritas Netbackup Tape Server Platform: SUN vs NT

4. Install from an NT share?

5. Veritas Netbackup Tape Drive Changes Move Drives from Media Server to Master

6. how to raise a process's priority to real-time via priocntl()

7. 4500 issue with veritas/clarrion issue

8. HP 100VG-AnyLAN/9000 - is it 100BaseT ethernet?

9. Veritas Netbackup vs Syncsort's Backup Express

10. Is Veritas netbackup crashing our E450"s?

11. Veritas Netbackup failure

12. Veritas Netbackup 3.2

13. Veritas Netbackup and robot problems...mode_sense failed