Fresco and Solaris 2.3

Fresco and Solaris 2.3

Post by Andre Apr » Wed, 22 Jun 1994 22:07:55



I have some problems when compiling Fresco with Sun's C++-4.0 on Solaris 2.3.
The following messages appear at the Xtf and Fresco library building stage:

rm -f libXtf.so.0.7~
(cd .; LD_RUN_PATH=/usr/X11R6/lib /usr/ccs/bin/ld -o ./libXtf.so.0.7~ -G -z text -h libXtf.so.0.7 Xtf.o )
Text relocation remains                       referenced
    against symbol                  offset      in file
__0oMXfFrescoImplctPCcRiPPcP6IXfOption 0x24             Xtf.o
<unknown>                           0x2c        Xtf.o
<unknown>                           0x34        Xtf.o
__0fJXtfFrescoIworkprocPvT          0x40        Xtf.o
__0fJXtfFrescoIworkprocPvT          0x44        Xtf.o

...

__0oOXtfDisplayImplctP6JXtfFrescoP6J_XDisplay 0xfec             Xtf.o
ld: fatal: relocations remain against allocatable but non-writable sections
*** Error code 1
make: Fatal error: Command failed for target `libXtf.so.0.7'

The same happens for the Fresco directory.
When i suppress '-z text', the library is build and seems to work, but Fresco
is unstable. After a few seconds, fdraw crashes with the following message:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  0 ()
  Serial number of failed request:  4808
  Current serial number in output stream:  4804

Does anyone have a solution ?

Andre

-----
Andre April
Unite d'Informatique
Universite Catholique de Louvain
Belgium


Tel: +32.10.47.31.13

 
 
 

Fresco and Solaris 2.3

Post by Andre Apr » Thu, 23 Jun 1994 22:49:32


: I have some problems when compiling Fresco with Sun's C++-4.0 on Solaris 2.3.
: The following messages appear at the Xtf and Fresco library building stage:

: rm -f libXtf.so.0.7~
: (cd .; LD_RUN_PATH=/usr/X11R6/lib /usr/ccs/bin/ld -o ./libXtf.so.0.7~ -G -z text -h libXtf.so.0.7 Xtf.o )
: Text relocation remains                       referenced
:     against symbol                  offset      in file
: __0oMXfFrescoImplctPCcRiPPcP6IXfOption 0x24             Xtf.o
: <unknown>                           0x2c        Xtf.o
: <unknown>                           0x34        Xtf.o
: __0fJXtfFrescoIworkprocPvT          0x40        Xtf.o
: __0fJXtfFrescoIworkprocPvT          0x44        Xtf.o

: ...

: __0oOXtfDisplayImplctP6JXtfFrescoP6J_XDisplay 0xfec             Xtf.o
: ld: fatal: relocations remain against allocatable but non-writable sections
: *** Error code 1
: make: Fatal error: Command failed for target `libXtf.so.0.7'

: The same happens for the Fresco directory.
: When i suppress '-z text', the library is build and seems to work, but Fresco
: is unstable. After a few seconds, fdraw crashes with the following message:

: X Error of failed request:  BadRequest (invalid request code or no such operation)
:   Major opcode of failed request:  0 ()
:   Serial number of failed request:  4808
:   Current serial number in output stream:  4804

After a few tests, I realized that fdraw effectively crashes after a few
seconds on a 4 processor SS10 (X display on a LX) with the previous message
or with

X Error of failed request:  BadLength (poly request too large or internal Xlib length error)
  Major opcode of failed request:  4 (X_DestroyWindow)
  Serial number of failed request:  30748
  Current serial number in output stream:  30736

but it does not crash at all on my LX (1 processor of course). Both of these
machines run Solaris 2.3. So, I suspect that my problem has something to
do with the fact that my SS10 has 4 processor. Is it a problem with threads ?

Does someone have the same problem on a multiprocessor sparc station or
server running Solaris 2.3 ?

: Does anyone have a solution ?

: Andre

-----
Andre April
Unite d'Informatique
Universite Catholique de Louvain
Belgium


Tel: +32.10.47.31.13

 
 
 

1. HELP: Solaris 2.3 <---> Solaris 2.3 PPP link problems

Hi all,

We are attempting to link up two Solaris 2.3 networks via PPP and we are
running into some problems.  The link initialy comes up and we are able to ping
both sides for about 30 seconds or so and then nothing.  Does anyone have a
clue what could be hapening? We are stumped here.

Thanx,

- Steve
--
=============================================================================
 Always going where no one has gone before...

=============================================================================

2. CD-ROM jukebox configuration in Solaris 2.4

3. HELP: Solaris 2.3 <---> Solaris 2.3 PPP link Problems

4. Need help xterm custom backgrounds in Afterstep

5. Help with Pageview under 2.3 (Re: Display Postscript X Solaris 2.3)

6. Mandrake-AFS-Ethernet card

7. SLIP for Solaris 2.3: slip-solaris-3

8. Streaming SIMD on Linux

9. Solaris 2.4 vs. Solaris 2.3

10. Solaris 2.3, Sparc 5 to Solaris 2.5, Ultra 170E upgrade

11. Solaris 2.3 prog exiting on kvm_open call on solaris 2.5

12. moving from SPARC solaris 2.3 to x86 solaris 2.4

13. backup Solaris 2.3 to tape connected to Solaris 1.1