Solaris 2.4

Solaris 2.4

Post by Bil Lew » Fri, 12 Aug 1994 10:15:02




: >1. When will be version 2.4 of Solaris available. If it's already on the
: >   market, what is the price ?

  SunSoft FCS is currently listed as 24.Aug

: >2. We are running Solaris 2.2 currently. Is it necessary to upgrade from
: >   2.2 to 2.3 and then from 2.3 to 2.4 or we can upgrade directly from
: >   2.2 to 2.4 ?

  Nope.  I haven't tried it, but it's supposed to work.  Even from 2.1.

: As far as I know, you will be able to upgrade from 2.2 to 2.4 (we are
: also running 2.2).  HOWEVER, I just found out yesterday that if you
: are using Sun's compilers, you will have to upgrade them for 2.3, and
: then again for 2.4.  That is, when you get Solaris 2.4 up and running,
: you will need to run 2 upgrade steps for the compilers.

  BUZZZ!!  Not.  Rewind.

  The compilers are not bound to the OS.  The old compilers are supposed to
run just fine on the new OS.  I *think* the new compilers run on the old OS
too.  (Well, excepting the hugh difference between SunOS 4.x & Solaris 2.x)

  You might want to check with your information source.

  (No!  Wait!!  That's a *wonderful* idea.  Boy, if we can sell upgrades
like that, we'll make a bundle!  Let's see, you'll buy it, right Doug?  How
many other folks are interested in this super deal?  I'll even throw in a
bridge to sweeten the deal :-)

--
  You must run as fast as to can, just to stay in the same place.  If you
want to get anywhere, you must run twice as fast!


 
 
 

Solaris 2.4

Post by Doug J. Brou » Thu, 11 Aug 1994 21:58:29



>Subject: Re: Solaris 2.4 upgrade
>Newsgroups: comp.unix.solaris

>1. When will be version 2.4 of Solaris available. If it's already on the
>   market, what is the price ?
>2. We are running Solaris 2.2 currently. Is it necessary to upgrade from
>   2.2 to 2.3 and then from 2.3 to 2.4 or we can upgrade directly from
>   2.2 to 2.4 ?

Hi,

I tried to Email you, but the mail came back "service unavilable".

2.4 is out now in pre-release form.  It should be available to the
"public" sometime this fall.  I don't know the price.

As far as I know, you will be able to upgrade from 2.2 to 2.4 (we are
also running 2.2).  HOWEVER, I just found out yesterday that if you
are using Sun's compilers, you will have to upgrade them for 2.3, and
then again for 2.4.  That is, when you get Solaris 2.4 up and running,
you will need to run 2 upgrade steps for the compilers.

Hope this helps.

Doug Brough
Shell Pipeline
Houston, TX



 
 
 

Solaris 2.4

Post by Carl Smi » Sat, 13 Aug 1994 03:48:32


Quote:> : As far as I know, you will be able to upgrade from 2.2 to 2.4 (we are
> : also running 2.2).  HOWEVER, I just found out yesterday that if you
> : are using Sun's compilers, you will have to upgrade them for 2.3, and
> : then again for 2.4.  That is, when you get Solaris 2.4 up and running,
> : you will need to run 2 upgrade steps for the compilers.

>   BUZZZ!!  Not.  Rewind.

>   The compilers are not bound to the OS.  The old compilers are supposed to
> run just fine on the new OS.  I *think* the new compilers run on the old OS
> too.  (Well, excepting the hugh difference between SunOS 4.x & Solaris 2.x)

>   You might want to check with your information source.

        I'll second that.  We build SunOS using the 2.0.1 compilers.  Works
just fine.

                        Carl

 
 
 

Solaris 2.4

Post by Ronald van der P » Sat, 13 Aug 1994 22:41:22




>: >1. When will be version 2.4 of Solaris available. If it's already on the
>: >   market, what is the price ?
>  SunSoft FCS is currently listed as 24.Aug

Both SPARC and x86 versions?

--

 
 
 

Solaris 2.4

Post by Richard Comb » Mon, 22 Aug 1994 20:43:21




>Upgrade from 2.1 will work on SPARC but not on x86.

>     Richard M. Mathews                      Freedom for Lithuania


Am I reading this correctly?  There are no releases for x86 between 2.1 and
2.4.  This artcile must have the SPARC and x86 reversed.
 
 
 

Solaris 2.4

Post by Willard F. Daws » Mon, 22 Aug 1994 23:45:01





>>Upgrade from 2.1 will work on SPARC but not on x86.

>>     Richard M. Mathews                  Freedom for Lithuania

>Am I reading this correctly?  There are no releases for x86 between 2.1 and
>2.4.  This artcile must have the SPARC and x86 reversed.

Why do you say that?  richard says the upgrade will not work from
2.1->2.4 on x86.  That is true, I think.  Heck, it's not obvious that an
upgrade from EA1 to EA2 of 2.4 will work; why would you think there'd be
any chance at all of 2.1->2.4 working, regardless of architecture?
 
 
 

Solaris 2.4

Post by Bob Palowo » Tue, 23 Aug 1994 04:51:33






: >>
: >>Upgrade from 2.1 will work on SPARC but not on x86.
: >>
: >>     Richard M. Mathews                        Freedom for Lithuania

: >Am I reading this correctly?  There are no releases for x86 between 2.1 and
: >2.4.  This artcile must have the SPARC and x86 reversed.

: Why do you say that?  richard says the upgrade will not work from
: 2.1->2.4 on x86.  That is true, I think.  Heck, it's not obvious that an
: upgrade from EA1 to EA2 of 2.4 will work; why would you think there'd be
: any chance at all of 2.1->2.4 working, regardless of architecture?

One of the major reasons why the 2.1->2.4 x86 ONLY upgrade dosn't work
is the disk devices names have changed.  This dosn't apply to the sparc
achitecture.  Going from 2.1->2.4 on x86 is a substatial change and
well worth it so back your user data up and do a clean install.  It's
not unreasonable.  Usually I've seen people grumble about this when
they have no backups.

---Bob

--
+----------------------------+-----------------------------+



+----------------------------+-----------------------------+

 
 
 

Solaris 2.4

Post by Calvin R Maur » Wed, 24 Aug 1994 02:39:56



|>
|> >>  SunSoft FCS is currently listed as 24.Aug
|>
|> >Both SPARC and x86 versions?
|>
|> I won't confirm the date, but SPARC and x86 will come out at the same time.
|>
|>      Richard M. Mathews                    Freedom for Lithuania

I was told today by a Sun representative that Solaris 2.4 will not be
released until DECEMBER!!

Surprise, surprise, surprise.
Calvin Maurer

/--------------------------------------------------------------------\

|                                                                    |
|  Image Processing Laboratory                Phone: (615) 343-6259  |
|  Department of Computer Science             FAX:   (615) 343-8006  |
|  Vanderbilt University                                             |
|                                                                    |
|  P.O. Box 121181                            Home:  (615) 383-8123  |
|  Nashville, TN  37212-1181                                         |
|--------------------------------------------------------------------|
|                                                                    |
|              |O                    o            \O                 |
|              _|\             `\_\_O             /|__, o            |
|            o/  \_               | \              /                 |
|                                 '               '                  |
|--------------------------------------------------------------------|
|  "I am aware of the downside to this wonderful facility that men   |
|  have: they become repressed, they fail in their relationships     |
|  with women, their conversation is trivial and boorish, they find  |
|  themselves unable to express their emotional needs, they cannot   |
|  relate to their children, and die lonely and miserable. But you   |
|  know, what the hell?"                                             |
|       -- Nick Hornby, on being a soccer fan (Fever Pitch, London:  |
|          Victor Gollancz, 1992)                                    |
\--------------------------------------------------------------------/

 
 
 

Solaris 2.4

Post by Bil Lew » Wed, 24 Aug 1994 02:13:49




: : >>
: : >>Upgrade from 2.1 will work on SPARC but not on x86.
: : >>
: : >>     Richard M. Mathews                      Freedom for Lithuania

: : >Am I reading this correctly?  There are no releases for x86 between 2.1 and
: : >2.4.  This artcile must have the SPARC and x86 reversed.

  I think we're talking apples & oranges here...

  UPGRADE refers to the ability to reinstall an OS without changing other
files on the same disk.  Without even losing you OS configuration files!
This is often a difficult thing to accomplish.

  REINSTALL is just putting a new OS on the same disk.  You have to save all
of your files to tape first, then replace the congifuration files.  A
hassle, but no big deal (unless you're doing 10,000 machines).

  Typically you'll have all your personal files on a different disk, in
which case you just reinstall & do whatever reconfiguration you need.

-Bil

--
  You must run as fast as to can, just to stay in the same place.  If you
want to get anywhere, you must run twice as fast!


 
 
 

Solaris 2.4

Post by Steve Lipetz-SunSoft-Atlan » Wed, 24 Aug 1994 03:51:16



> I was told today by a Sun representative that Solaris 2.4 will not be
> released until DECEMBER!!

> Surprise, surprise, surprise.
> Calvin Maurer

> /--------------------------------------------------------------------\


---
Portion of enormous .sig deleted

Well, this shouldn't be a "surprise" if you've been following the Sun
organization saga.

SunSoft will indeed release 2.4 for SPARC and x86 simultaneously as
promised (and shortly). And Sun Microsystems Computer Co., as an OEM
of SunSoft wants to take it and add their value to it, much like other
OEMs will do. That means there will be a lag before SMCC releases it.

X86 OEMs can do the same. They generally haven't yet and SunSoft does have
channels to make X86 available semi-directly. So, you will probably be able
to run 2.4 X86 on your PC before you can on your SPARCstation.
Don't know when Tatung or Tadpole et.al. will release 2.4 either but it will
probably NOT be on SunSoft FCS day.

We sell software. An OS isn't exactly an application. There is generally
a hardware requirement lurking there somewhere and the hardware manufacturer
may want to do a little extra to make the OS take special advantage of
the special features of their hardware.

-sal-
=========================================================================
Steven A. Lipetz                        SunSoft, Sun Microsystems Inc.
Strategic Accounts Sys Eng Mgr          115 Perimeter Center Place, N.E.

(404) 901-6915 FAX:(404)512-0566        Atlanta, GA 30346
=========================================================================

 
 
 

Solaris 2.4

Post by Sean McCollist » Wed, 24 Aug 1994 21:36:42


: X86 OEMs can do the same. They generally haven't yet and SunSoft does have
: channels to make X86 available semi-directly. So, you will probably be able
: to run 2.4 X86 on your PC before you can on your SPARCstation.

Will there be an upgrade path offered to current 2.1 for x86 customers, to
obtain 2.4 at a reduced price, directly from SunSoft?

--
---------------------------------------------------------------------------
Sean McCollister                               Working at Texas Instruments
Network Administrator                               DAD Workstation Support

                  ** I speak only for myself. **

 
 
 

1. Wu-ftpd 2.4 under Solaris 2.4

hi

i have problem with wu-ftpd 2.4 under Solaris 2.4
it works in general, but doesn't log sessions to syslog and doesn't
update lastlog.
I'm not sure about wtmp and utmp updates also.
It has been compiled with gcc 2.6.3 and makefile.sol.
Any help will be very appriciated.

rgds,
serge

--
+-------------------------------------+-------------------------------------+

| UN Internet Project                 | +380-44-228-6393                    |
| System and Network Administrator    | http://www.un.kiev.ua/                   |
+-------------------------------------+-------------------------------------+

2. Voodoo2

3. PPP on Solaris 2.4 for Sparc, Matrox PCI Millenium Card under Solaris 2.5 x86

4. Some questions

5. Solaris 2.4 vs. Solaris 2.3

6. DMA hangs...activated workarounds? please help!

7. Jumpstart Question: Solaris 2.6 vs Solaris 2.4

8. bash loops when sliplogin exits

9. Solaris 2.4 x86: How to sync Solaris and CMOS time?

10. Compatibility issue between solaris 2.4 and solaris 2.6

11. moving from SPARC solaris 2.3 to x86 solaris 2.4

12. Solaris 2.4 --> Solaris 2.5: strict POSIX compliance inquiry

13. In search of user/programmer visible Solaris 2.4 vs Solaris 2.5 differences