Setting up Modem on SUN

Setting up Modem on SUN

Post by Nattapong Mongkolnavi » Tue, 17 Aug 1999 04:00:00



Hi Folks,

I'm a SUN newbie who is trying to set up a modem on SUN box.
Unfortunately, I couldn't figure out how to set it up even I followed
the documentation from http://docs.sun.com.

I used "admintool" to set up my serial port.
I also used a command "pmadm -l -t ttya" to check my /dev/ttya status.
It seems like to port is set up correctly.

Whatelse do I need to do?
Do I need to config the "getty" program so the remote users can get
their
login prompt?

Help Please.

Nat.

 
 
 

Setting up Modem on SUN

Post by Dave Abne » Tue, 17 Aug 1999 04:00:00


There is a lot of information about this subject at
http://www.stokely.com.  Follow the link to Serial Port Resources.  If you
have setup the modem in Admintool, you still need to configure the
/etc/uucp/Devices file.  Go to the bottom of the file and look at the line
that starts:

ACU cua/b - any hayes

I you are on serial port a change the device to cua/a.  If on serial port
B make the device cua/b.  Change the word "any" to the actual baud rate
you selected with Admintool, for example 38400.  Test your modem with the
following commands:

cu -l cua/b
(should get Connected message)
atz
atdt555-5555 (or whatever)

Good luck,
Dave


> Hi Folks,

> I'm a SUN newbie who is trying to set up a modem on SUN box.
> Unfortunately, I couldn't figure out how to set it up even I followed
> the documentation from http://docs.sun.com.

> I used "admintool" to set up my serial port.
> I also used a command "pmadm -l -t ttya" to check my /dev/ttya status.
> It seems like to port is set up correctly.

> Whatelse do I need to do?
> Do I need to config the "getty" program so the remote users can get
> their
> login prompt?

> Help Please.

> Nat.