Printing Problems! Help!

Printing Problems! Help!

Post by James Shelt » Fri, 17 Jun 1994 23:27:22



Hello all,

I'm currently having problems printing with the following setup:
        Sparc 20 running Solaris 2.3 as a print client and
        a print server running SunOS 4.1.3
I've been following the procedure described in "Solaris Advanced
System Administrator's Guide" by Sunsoft for this type of setup.

However, nothing prints. I'd appreciate any help or suggestions
anyone might have as to how I can get this to work.
Or is there a version of the BSD printing package that has been
ported to Solaris 2.3?

Thanks in advance for any help or suggestions. Details of the
problem are listed below.

Sam Young
Galaxy Scientifc Corporation
____________________________________________________________
Here is some, hopefully, relevant output from various commands
and files:

# lpstat -t
scheduler is running
system default destination: laser
system for lw: jsun1
system for laser: jsun1 (as printer lw)
lw accepting requests since Tue Jun 14 08:58:35 EDT 1994
laser accepting requests since Thu Jun 16 09:54:55 EDT 1994
printer lw faulted. enabled since Tue Jun 14 08:58:35 EDT 1994. available.
        system not responding
        printer laser faulted. since Thu Jun 16 09:55:01 EDT 1994. available.
system not responding

# tail -100 /var/lp/logs/lpNet
06/16/94 08:44 p   171 <none> Starting.
06/16/94 08:44 p   171 <none> Starting lpNetParent.
06/16/94 08:44 p   171 <none> Initialized & Polling.
06/16/94 08:44 p   171 <none> Started child for jsun1, pid = 179
06/16/94 08:44 c   179 jsun1 * by remote lpd (106)
06/16/94 08:54 c   179 jsun1 * by remote lpd (106)
06/16/94 08:54 c   179 jsun1 waiting for remote queue to be enabled
06/16/94 09:04 c   179 jsun1 * by remote lpd (106)
06/16/94 09:14 c   179 jsun1 * by remote lpd (106)
06/16/94 09:24 c   179 jsun1 * by remote lpd (106)
06/16/94 09:34 c   179 jsun1 * by remote lpd (106)
06/16/94 09:44 c   179 jsun1 * by remote lpd (106)
06/16/94 09:54 c   179 jsun1 * by remote lpd (106)

more /etc/lp/printers/lw/faultMessage
jsun1: /usr/lib/lpd: Your host does not have line printer access

 
 
 

Printing Problems! Help!

Post by Michael Joost » Thu, 23 Jun 1994 07:55:04


.... deleted

   # tail -100 /var/lp/logs/lpNet
   06/16/94 08:44 p   171 <none> Starting.
   06/16/94 08:44 p   171 <none> Starting lpNetParent.
   06/16/94 08:44 p   171 <none> Initialized & Polling.
   06/16/94 08:44 p   171 <none> Started child for jsun1, pid = 179
   06/16/94 08:44 c   179 jsun1 * by remote lpd (106)
   06/16/94 08:54 c   179 jsun1 * by remote lpd (106)
   06/16/94 08:54 c   179 jsun1 waiting for remote queue to be enabled
   06/16/94 09:04 c   179 jsun1 * by remote lpd (106)

   more /etc/lp/printers/lw/faultMessage
   jsun1: /usr/lib/lpd: Your host does not have line printer access

I, too, wasted a few hours for solving this problem. Your client-side setup
seems to be ok, but the server refuses to accept jobs from you/your host or to
this queue. Could it be that /etc/hosts.lpd (or so...) does not mention your
Solaris machine? A quick glance at the NET2-Sources tell me this is most
probably the case...

Good Luck, Michael

--
 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| Michael Joosten   |       Tel.  : (+49) (+) 5251-284 168                 |
| CADLAB            |       Fax   : (+49) (+) 5251-284 140                 |

| 33102 Paderborn   |               ...!uunet!unido!cadlab!joost           |

|--------------------------------------------------------------------------|
| CADLAB is a cooperation between Uni-GH Paderborn & SNI AG                |
 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

 
 
 

1. Stange Printing Problem. Help!!!

I just inalled Linux (slackware 3.0) on my system.
When sending something to the printer (either by
cat file > /dev/lp2 or using lpr file) I get blank
pages!!! The number of pages that I get are correct
e.g. if I'm sending a two page file I get two blank
pages from my printer. Printer works fine under
Windows95 and OS/2. Anyone knows what's wrong?

Thanks in advance.

Vasken.

2. How to reset modem on HP-UX?

3. Simple Print problem ? Help!

4. cron errors

5. Simple Printing problems ! HELP !

6. Unzip problem

7. HELP PRINTING -- HELP PRINTING -- HELP PRINTING

8. X-Windows and TAR (unrelated)

9. HP Printing Problem & Printing.HOWTO can't help!!!

10. Printing problem (Not printing first line) Help!

11. Help required for printing through Barricade print server.

12. Please Help: print script to mail PS documents instead of print

13. Help regarding printing from a Dbase exe program to print