ghostview with Solaris 2.3, gcc and gs261.

ghostview with Solaris 2.3, gcc and gs261.

Post by Giuseppe Rodrigu » Thu, 26 May 1994 19:48:09



Dear everybody,

I compiled ghostview on a SUN sparc10 with Solaris 2.3, gcc and gs261.
everything goes ok, but when i try to load a ps file (file..open..)
I get an information window with the message

        gs: Malformed ghostview color property.
        Error: PostScript interpreter failed in main window.

and nothing appear in the main window.
by the way, gs alone works well.

did anybody have the same problem?

thank you, Giuseppe

--

,.....................................................          _   _
: Giuseppe Rodriguez                                 |_| |\| | |_  |-|
: Dipartimento di Matematica - Universita' di Cagliari               :
: viale Merello 92,  09123 Cagliari,  Italy                          :
:    Tel: (+39)-70-2000411/2000404,  Fax: (+39)-70-2000420           :

:..........A computer usually works better if you plug it in.........:

 
 
 

ghostview with Solaris 2.3, gcc and gs261.

Post by Robin Duquet » Fri, 27 May 1994 13:05:38




>Dear everybody,

>I compiled ghostview on a SUN sparc10 with Solaris 2.3, gcc and gs261.
>everything goes ok, but when i try to load a ps file (file..open..)
>I get an information window with the message

>    gs: Malformed ghostview color property.
>    Error: PostScript interpreter failed in main window.

>and nothing appear in the main window.
>by the way, gs alone works well.

>did anybody have the same problem?

>thank you, Giuseppe

--
--------------------------------------------+----------------------------------

--------------------------------------------+ phone : (514) 652-8239
 Service Logiciels et algorithmes de reseau | fax   : (514) 652-8005

 
 
 

ghostview with Solaris 2.3, gcc and gs261.

Post by Thomas Feuersta » Fri, 27 May 1994 18:26:24



Quote:> I compiled ghostview on a SUN sparc10 with Solaris 2.3, gcc and gs261.
> everything goes ok, but when i try to load a ps file (file..open..)
> I get an information window with the message

>    gs: Malformed ghostview color property.
>    Error: PostScript interpreter failed in main window.

> and nothing appear in the main window.
> by the way, gs alone works well.

I 've had the same effect while compiling Ghostview 1.5. The only workaround i've
found was to use the older version 1.4.1 instead of 1.5. I'm also deeply interested
in a better solution.

Kind regards - Thomas

 
 
 

ghostview with Solaris 2.3, gcc and gs261.

Post by Giuseppe Rodrigu » Fri, 27 May 1994 18:08:43


|>
|> Dear everybody,
|>
|> I compiled ghostview on a SUN sparc10 with Solaris 2.3, gcc and gs261.
|> everything goes ok, but when i try to load a ps file (file..open..)
|> I get an information window with the message
|>
|>   gs: Malformed ghostview color property.
|>   Error: PostScript interpreter failed in main window.
|>
|> and nothing appear in the main window.
|> by the way, gs alone works well.
|>
|> did anybody have the same problem?
|>
|> thank you, Giuseppe
|>
|>

Since I received some emails from people experiencing the same problem, I
post the solution.

It is necessary to apply the 4 available patches for gs 2.6.1: one of them
fixes this.

Thank you to Thomas, Fredrik and Mike for answering me.

Bye, Giuseppe.

--

,.....................................................          _   _
: Giuseppe Rodriguez                                 |_| |\| | |_  |-|
: Dipartimento di Matematica - Universita' di Cagliari               :
: viale Merello 92,  09123 Cagliari,  Italy                          :
:    Tel: (+39)-70-2000411/2000404,  Fax: (+39)-70-2000420           :

:..........A computer usually works better if you plug it in.........:

 
 
 

ghostview with Solaris 2.3, gcc and gs261.

Post by Robin Duquet » Fri, 27 May 1994 23:44:03





> >I compiled ghostview on a SUN sparc10 with Solaris 2.3, gcc and gs261.
> >everything goes ok, but when i try to load a ps file (file..open..)
> >I get an information window with the message

> >       gs: Malformed ghostview color property.
> >       Error: PostScript interpreter failed in main window.

> >and nothing appear in the main window.
> >by the way, gs alone works well.

> >did anybody have the same problem?

Sorry for replying twice, but I have some problems with my news reader.

Now my message: yes, I have the same problem with gcc and cc on Solaris 2.3.
Any help will be appreciated.

Thanks in advance,

---
--------------------------------------------+----------------------------------

--------------------------------------------+ phone : (514) 652-8239
 Service Logiciels et algorithmes de reseau | fax   : (514) 652-8005
 Institut de recherche d'Hydro-Quebec       |    
 1800 montee Ste-Julie,                     |
 Varennes (Quebec) Canada J3X 1S1           |
--------------------------------------------+----------------------------------

 
 
 

ghostview with Solaris 2.3, gcc and gs261.

Post by Robert Coh » Sat, 04 Jun 1994 10:18:29




>> I compiled ghostview on a SUN sparc10 with Solaris 2.3, gcc and gs261.
>> everything goes ok, but when i try to load a ps file (file..open..)
>> I get an information window with the message

>>        gs: Malformed ghostview color property.
>>        Error: PostScript interpreter failed in main window.

>> and nothing appear in the main window.
>> by the way, gs alone works well.
>I 've had the same effect while compiling Ghostview 1.5. The only workaround i've
>found was to use the older version 1.4.1 instead of 1.5. I'm also deeply interested
>in a better solution.

Apply the 4 fixes to gs-2.6.1 stored in the GNU archive.
Why they havent been integrated into the tar file I dont know.
I've seen this problem crop up time and time again...

(stupid
damn
news
software
made
me
do
this
so
dont
blame
me
.
.
.
.
)

--

PhD Student,  Dept of Computer Science,
Australian National University.            ===============================
----------------------> Code fast, crash young, and leave a pretty core!

 
 
 

1. Trouble compiling ghostview for Solaris 2.3

I am trying to compile Ghostview-1.5 on a SPARCstation 20 workstation
with a 20 inch color monitor with the turbo-GX frame buffer.  The system
is running Solaris 2.3.

I have used SUN's Professional C compiler as well as gcc to compile the
source code.  In each case, the code seems to compile with no problems.
However, when I attempt to use ghostview to view a postscript file, I
receive the following error messages.

              gs: Malformed ghostview color property.
              Error: PostScript interpreter failed in main window.

Ghostview recognizes how many pages are in the postscript document, but
does not display any text for the active page.

I am able to use the "gs" command independantly to view the postscript
documents with no problems.

Can someone tell me what modifications I need to make in order to get
the Ghostview-1.5 code to compile and run correctly?   Please send
responses to my email address.

Thanks in advance.

Michael Ewing

--
********************************************************************************

Michael A. Ewing                       University of Iowa
Systems Analyst                        Electrical and Computer Engineering Dept.
Phone:  319-335-5962                   4400EB
Fax:    319-335-6028                   Iowa City, IA 52242 (USA)

********************************************************************************

2. The Linux Clothing Project

3. Summary:ghostview-1.5 under solaris 2.3

4. RAID_0 (stripping) software for Linux?

5. ghostscript/ghostview problems with Solaris 2.3

6. iptables DNAT via 2.4.0-test9

7. ghostview on Solaris 2.3

8. Linux TCPIP and 3com509

9. Q: ghostview-1.5 under solaris 2.3

10. 'ghostview' on Solaris 2.3??

11. HELP: Solaris 2.3 <---> Solaris 2.3 PPP link problems

12. HELP: Solaris 2.3 <---> Solaris 2.3 PPP link Problems

13. Problems with gcc ver 2.5.6 on solaris 2.3