IDE CD-ROM problem Solaris 2.6/x86

IDE CD-ROM problem Solaris 2.6/x86

Post by Sean Ake » Mon, 05 Oct 1998 04:00:00



I received my free copy of Solaris 2.6 X86 this week and it installed
no problem :-).

However, I have a problem with the CD-ROM. It works fine if I boot
Solaris with a CD already in the drive, but if I insert a new CD in
the drive it will not read the disc. It keeps trying but won't do it.
It will not open the disc or allow me to eject it or anything. The
only way I can regain access to the CD drive is to re-boot.

My system is as follows :

AMD K6/2-300 in a FIC VA-503+ motherboard running at 66Mhz bus speed
with 128Mb SIMM EDO RAM.

1st HD = Quantum fireball 6.4Gb EIDE as primary master
2nd HD = IBM 8.4 GB EIDE as primary slave
3rd HD = Fujitsu 2GB EIDE as secondary master
CD-ROM = Goldstar IDE as secondary slave

I have Windows 98 and NT4.0 taking up all of the 1st HD
I have 4 partitions on the 2nd HD with SUSE 5.3 Linux on the 1st 3GB
parition, Solaris on the 2nd 3GB partition, 1 extended partition of
2GB with 2 logical drives of 1GB FAT16 and 1GB NTFS
I have 1NTFS, 1 Linux swap and 1 Linux partition on the 3rd HD

I boot Solaris using the NT bootloader and it boots fine as do all the
other operating systems.

Solaris works OK except for the problem with changing CDs. I use CDE
as my working environment.

Does anyone have any suggestions. It's a pain having to re-boot to
change CDs.

Cheers,

Sean Akers.

 
 
 

IDE CD-ROM problem Solaris 2.6/x86

Post by John D Groenve » Mon, 05 Oct 1998 04:00:00


Try using eject(1) to umount and eject the CD. If you still can't
vold to mount susequent disks, perhaps you can try restarting it.

As root
/etc/init.d/volmgt stop; sleep 30; /etc/init.d/volmgt start
John


 
 
 

IDE CD-ROM problem Solaris 2.6/x86

Post by Bruce Adle » Mon, 05 Oct 1998 04:00:00



> I received my free copy of Solaris 2.6 X86 this week and it installed
> no problem :-).

> However, I have a problem with the CD-ROM. It works fine if I boot
> Solaris with a CD already in the drive, but if I insert a new CD in
> the drive it will not read the disc. It keeps trying but won't do it.
> It will not open the disc or allow me to eject it or anything. The
> only way I can regain access to the CD drive is to re-boot.

> My system is as follows :

> AMD K6/2-300 in a FIC VA-503+ motherboard running at 66Mhz bus speed
> with 128Mb SIMM EDO RAM.

> 1st HD = Quantum fireball 6.4Gb EIDE as primary master
> 2nd HD = IBM 8.4 GB EIDE as primary slave
> 3rd HD = Fujitsu 2GB EIDE as secondary master
> CD-ROM = Goldstar IDE as secondary slave

> I have Windows 98 and NT4.0 taking up all of the 1st HD
> I have 4 partitions on the 2nd HD with SUSE 5.3 Linux on the 1st 3GB
> parition, Solaris on the 2nd 3GB partition, 1 extended partition of
> 2GB with 2 logical drives of 1GB FAT16 and 1GB NTFS
> I have 1NTFS, 1 Linux swap and 1 Linux partition on the 3rd HD

> I boot Solaris using the NT bootloader and it boots fine as do all the
> other operating systems.

> Solaris works OK except for the problem with changing CDs. I use CDE
> as my working environment.

> Does anyone have any suggestions. It's a pain having to re-boot to
> change CDs.

Try using the updated ata driver:

        http://access1.sun.com/drivers/DU3/drivers/images/du3ata.bin

Neither the 2.6 5/98 release or the 2.6 MU2 release includes the updated ata
driver.

BA

 
 
 

IDE CD-ROM problem Solaris 2.6/x86

Post by s.. » Fri, 09 Oct 1998 04:00:00


Thanks a lot for your help. The new driver works perfectly and my CD
ROM problems are solved.

Sean



Quote:>Try using the updated ata driver:

>        http://access1.sun.com/drivers/DU3/drivers/images/du3ata.bin

>Neither the 2.6 5/98 release or the 2.6 MU2 release includes the updated ata
>driver.

>BA

 
 
 

IDE CD-ROM problem Solaris 2.6/x86

Post by Richard Denni » Sat, 10 Oct 1998 04:00:00


Article: 150198 of comp.unix.solaris
Path: news.cix.co.uk!peernews.cix.co.uk!ayres.ftech.net!news.ftech.net!colt.net!baron.netcom.net.uk!netcom.net.uk!news.enterprise.net!not-for-mail

Newsgroups: comp.unix.solaris
Subject: Re: IDE CD-ROM problem Solaris 2.6/x86
Date: Thu, 08 Oct 1998 09:01:39 GMT
Organization: Enterprise PLC - Internet Services
Lines: 17




NNTP-Posting-Host: 194.72.205.132
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Newsreader: Forte Agent .99g/32.339
Xref: news.cix.co.uk comp.unix.solaris:150198

Thanks a lot for your help. The new driver works perfectly and my CD
ROM problems are solved.

Sean



Quote:>Try using the updated ata driver:

>        http://access1.sun.com/drivers/DU3/drivers/images/du3ata.bin

>Neither the 2.6 5/98 release or the 2.6 MU2 release includes the updated ata
>driver.

>BA

 
 
 

1. 12/24x IDE CD-ROM drives for Solaris-x86 2.6?

In examining the latest HCL for 2.6-x86 I noticed that no 12/24x CD-ROM drive
is listed. As such drives have been shipping standard from the PC-makers for
months, and as I'm soon to acquire one of these systems myself (Dell)... I was
wondering if people have had any trouble using such drives with Solaris (as I
intend to).  If the manufacturer's corresponding 8x or 12x drive is supported,
for instance, is the faster variant usually ok too? Any of them known NOT to
work?? Grateful for any insights,
                                    Kevin

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
& Kevin Rauch, Department of Astronomy, University of Maryland               &

&   "Got my sights on the stars--won't get that far, but I'll try anyway..." &
&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&& --G. L. &&&&&&&&&&

2. Very Simple Questions

3. Solaris 2.6 x86, Dell Dimension XPS D300, UltraDMA, and Toshiba 24x CD-ROM

4. RTFM'ed to death..

5. 2.6 x86 CD-ROM detection problem

6. Good mpeg player for Linux?

7. CD-ROM problems with Solaris 2.6

8. why write to socket succeeds when reading end shuts down

9. Solaris 2.4 x86 supporting Sony 55E IDE CD-ROM?

10. [Will IDE CD-ROM work for Solaris x86?]

11. Q: Does Solaris 2.4 x86 support IDE CD-ROM

12. Problems with 2nd IDE i/f and IDE CD-ROM on Compaq Presario CDS 972

13. x86, IDE CD-ROM Problem