Apache 1.3.12/ATG Dynamo 4.5.1/Solaris 7 - Compatible?

Apache 1.3.12/ATG Dynamo 4.5.1/Solaris 7 - Compatible?

Post by Magpie1 » Wed, 08 Aug 2001 23:31:58



Hi all,

Got the apache_dyn_cm source and recompiled Apache 1.3.12 (Solaris 7) with
DSO support and the dynamo.so module. I verified the .so was in libexec and
edited the httpd.conf file to reflect the LoadModule dynamo_module
/etc/apache_1.3.12/libexec/dynamo.so loaction. I verified that the
DynamoManager IP was at the end of the file.

I also verified the srm.conf and mime.types settings are correct

Now when I try to start the HTTPD service I get this error message:

syntax error on line 208 of  etc/apche_1.3_12/conf/httpd.conf: Can't locate
API module structure 'dynamo_module' in file
/etc/apache_1.3.12/libexec/dynamo.so ld.so.1: ./httpd: fatal: dynamo_module
can't find symbol

I see on the ATG documentation that Apache version 1.3.6 and later are not
supported under Dynamo 4.5.1 - is this an issue?

Thanks for any help!

Mark

 
 
 

1. Problems installing Apache 1.3.12 & ApacheJServ 1.1.12

Machine Spec: Celeron Processor 400MHZ
Operating System: Linux Mandrake 7.0 Complete

I am using the "INSTALL" docs that came with ApacheJServ 1.1.12 and
trying to
build Apache with ApacheJServ support in it from the source files.

The doc has said to

./configure \
--prefix=/usr/local/apache
--activate-module=src/modules/jserv/libjserv.a
make
make install

Problem is I cannot find the file libjserv.a or mod_jserv.c in the
Apache 1.3.12 directory or any of its subdirectories.

The C files are in ApacheJServ 1.1.12 including mod_jserv.c but there is
no
libjserv.a only the file libjserv.module. Are these files equivalent???

Can someone please tell me what to do to configure Apache to work with
Apachejserv support please.

Thanks

Everill

2. Xf86: with a S3 trio64 v+ (s3 86c765) card: Anyone successful?

3. Error compiling Apache 1.3.12 on Solaris 7 (Intel)

4. Any program to convert still images to mov/avi/mpeg

5. File Size problem using Apache 1.3.12 on Solaris

6. Linux Manual

7. Apache 1.3.12 - Solaris 8, Ultra 1 Bus Error

8. Easy to setup, Easy to go -- Linux... the working mom's OS :) (satire)

9. where I can find online to download the Apache 1.3.12 binary for Solaris 2.6. ?

10. Compiling Apache 1.3.12 on Solaris 7

11. Apache 1.3.12 + Solaris 2.7 gives fork errors under high load

12. Solaris DSO problem / Apache 1.3.12

13. Building Apache/1.3.12 Ben-SSL/1.41 on Solaris 7 as a DSO