applications running out of colours

applications running out of colours

Post by Andrew Hullic » Thu, 18 Jan 2001 14:56:03



Hi,

Can anyone give me an idea how I can overcome the lack of colours
available to applications running in CDE 1.4 under Solaris 2.7/2.8
I am unsure why, but my login is fine (ie, I rarely have the above
problem) but all of the users I am administering experience colour
problems (applications coming up in black and white) if they have more
than approx half a dozen apps open at once.

Thanks in advance

Andrew

 
 
 

applications running out of colours

Post by Pascal Grostabussia » Thu, 18 Jan 2001 17:49:17



> Hi,

> Can anyone give me an idea how I can overcome the lack of colours
> available to applications running in CDE 1.4 under Solaris 2.7/2.8
> I am unsure why, but my login is fine (ie, I rarely have the above
> problem) but all of the users I am administering experience colour
> problems (applications coming up in black and white) if they have more
> than approx half a dozen apps open at once.

You can use the presentation panel and choose "More color for application"
else you may have to push your graphics card / Xserver into 24 bit-mode if
it
supports it.

/Mvh Pascal.

  pascal.vcf
< 1K Download

 
 
 

applications running out of colours

Post by Chris and Susan Kordis » Fri, 19 Jan 2001 14:12:09


hi ,

Several of these offending apps are trying to use
the same colors in the same colormap and thats
what causes the flashing

the reason you may not see it is because
you might have 24 bit graphics while your users
have 8 bit graphics ... ( a guess on my part )

basically you need to find out which apps
are colormap flashing and then in a users
homedir you need to edit a .Xresource file
to control the colors that each app uses
so they do not conflict with one another

i included a snippet from the X manual page
% man X

.
.
         XTerm*cutToBeginningOfLine: off
         XTerm*titeInhibit:  on
         XTerm*ttyModes:  intr ^c erase ^? kill ^u
         XLoad*Background: gold
         XLoad*Foreground: red
         XLoad*highlight: black
         XLoad*borderWidth: 0
         emacs*Geometry:  80x65-0-0
         emacs*Background:  rgb:5b/76/86
         emacs*Foreground:  white
         emacs*Cursor:  white
         emacs*BorderColor:  white
         emacs*Font:  6x10
         xmag*geometry: -0-0
         xmag*borderColor:  white  
.
.

these are X resources that get merged into
the X resource database

they include:

app_name*Xresource_name: attribute(or value)

each of your apps will have some X resources
that you can control and xrdb should dump them out
for you (do a man on xrdb + you might want to read
the Xlib manual)

hth
chris


> Hi,

> Can anyone give me an idea how I can overcome the lack of colours
> available to applications running in CDE 1.4 under Solaris 2.7/2.8
> I am unsure why, but my login is fine (ie, I rarely have the above
> problem) but all of the users I am administering experience colour
> problems (applications coming up in black and white) if they have more
> than approx half a dozen apps open at once.

> Thanks in advance

> Andrew

  kordish.vcf
< 1K Download