Upgrading Solaris-Need to upgrade Progress?

Upgrading Solaris-Need to upgrade Progress?

Post by mir.. » Wed, 02 Oct 1996 04:00:00



Shortly we might be buying an SUN UltraServer (3000 or something like that).

Right now our system is still operating under Solaris 2.3, but apparently we
will have to upgrade to Solaris 2.5.1.

All our applications use Version 6 Progress 4GL & databases. Since there is no
Progress version 6 available especially for Solaris 2.5.1, we tried to load &
go the version 6 applications to version 7. About 1% of all programs did not
compile so load & go is apparently not good enough, and I don't feel like
rewriting right now.

So the question is:
Can we run the Progress version 6 software we use under Solaris 2.3 under
Solaris 2.5.1.

Any ideas?
Has anyone tried this (or something similar)?

All suggestions welcome.

John Spiegels
Utrecht, Holland.

 
 
 

Upgrading Solaris-Need to upgrade Progress?

Post by Igor Breza » Wed, 02 Oct 1996 04:00:00




Quote:

> Shortly we might be buying an SUN UltraServer (3000 or something like
that).

> Right now our system is still operating under Solaris 2.3, but apparently
we
> will have to upgrade to Solaris 2.5.1.

> All our applications use Version 6 Progress 4GL & databases. Since there
is no
> Progress version 6 available especially for Solaris 2.5.1, we tried to
load &
> go the version 6 applications to version 7. About 1% of all programs did
not
> compile so load & go is apparently not good enough, and I don't feel like
> rewriting right now.

> So the question is:
> Can we run the Progress version 6 software we use under Solaris 2.3 under
> Solaris 2.5.1.

You will be fine with Progress v6 under Solaris 2.5.1.  However, progress
does not support v6 under 2.5.x.  I do not even think they will.  So, if
you have a problem with progress, you are on your own.

Regards,
Igor