My 'ncftp' does not work on Solaris 2.4

My 'ncftp' does not work on Solaris 2.4

Post by Shigetaka Matsumo » Sat, 18 Nov 1995 04:00:00



My 'ncftp'  does not work on Solaris 2.4

My 'ncftp'  does not correctly work on Solaris 2.4. At first, I could
make 'ncftp-2.0.5' without 'sokcs' to work sufficiently. I compiled it
successfully both by 'gcc' and 'SUN C 3.0.1'.  Next I tried to add sokcs
libraries to it. Problems are

1. 'configure' does not correctly judge existence of ?libsocks.a? which is
 created from ?sokcs/lib/Rconnect.o? and put both in directories ?ncftp-2.
0.5? and ?/opt/lib?.

2. ?ncftp? was compiled without error message when defining HAVE_SOCKS_LIB
 in ?Config.h?. However, it could not parse command when started without ?
-L? option?. If  command ?open? was entered, it  complained such like ?inc
orrect command?.

3. The object file ?Rconnect.o? seems to require BSD compatible libraries.
 So, I linked ?/usr/ucblib/libucb.a? to the object file.

 
 
 

1. 'X Error: BadRequest' using 'xv' on Solaris 2.4

I occasionly see the following X Error using the 'xv' image viewer
(and other applications with slightly different 'BadRequest' messages).

X Error: BadRequest (invalid request code or no such operation)
  Major Opcode:  0

Has anyone else seen this intermittent X Error - and if so, do you have
any solutions. Perhaps our 2.4 'Xsun' server or our X11 libraries
have known problems that this symptom indicates?? Any suggestions
and/or corroboration would be greatly appreciated.

PS - 1 of our apps is "Purified" and exibiting this behavior so I
don't think its a memory corruption - but who knows!

Thanks in advance...

2. Massive segfaults during installation.

3. PROBLEM: my Aviator Webgear 2.4 doesn't work with kernel version 2.4.x

4. secure ftp

5. Solaris 2.4 chmod on /home directory doesn't work

6. PPP 2.2.0c and Kernel 1.2.13

7. olvwm doesn't work on Solaris 2.4

8. RH 7.0 cannot find address of localhost

9. tcp_keepalive_interval doesn't work in 2.4 Solaris

10. Why doesn't keepalive work on Solaris 2.4?

11. "sag" command on solaris 2.4 ..can't get it working !!!

12. CRONTAB -e on Solaris 2.4 doesn't work

13. variable block mode with Exabyte 8500C under Solaris 2.4 doesn't work