adding items to menu under solaris 2.3 OW 3.3

adding items to menu under solaris 2.3 OW 3.3

Post by Robert Wies » Tue, 22 Mar 1994 21:02:00



Answering a msg of <19 Mar 94>, from ANDREW COLE BURNETTE to All,
Area < COMP.UNIX.SOLARIS > :

 Hello ANDREW,

 <cutted> .....
 ACB> The configuration files in /usr/openwin/lib/xdm have not been
 ACB> modified, and all seems to work well,  except...... I've built
 ACB> several apps and placed them in /opt/games/bin (example) and
 ACB> edited the file /usr/openwin/lib/openwin-menu to include several
 ACB> additional files,  styled
 ACB> after /usr/openwin/lib/openwin-menu-applications etc.

I've got the same problem using the Xwin-Emulator for PC (Windows)
with my Solaris 1.1 Server.
If I'm starting programs like XVIEW (rsh or rexec), the Server allways
says:
".so:  libX11.so.4 not found"
The problem isn't fixed if i am creating a Symbolic link in /openwin/lib
from libX11.so.4 --> libX11.so.4.3

(Programs like XCLOCK or the FILEMGR are running well)
Any ideas?

Bye,
Robert

  ====================================================================
  -    FIDONET :                     2:2480/25.15                    -


  ====================================================================

 
 
 

adding items to menu under solaris 2.3 OW 3.3

Post by Andrew Harrison SUNUK Consultan » Sun, 27 Mar 1994 03:58:52


 ACB> The configuration files in /usr/openwin/lib/xdm have not been
 ACB> modified, and all seems to work well,  except...... I've built
 ACB> several apps and placed them in /opt/games/bin (example) and
 ACB> edited the file /usr/openwin/lib/openwin-menu to include several
 ACB> additional files,  styled
 ACB> after /usr/openwin/lib/openwin-menu-applications etc.

:I've got the same problem using the Xwin-Emulator for PC (Windows)
:with my Solaris 1.1 Server.
:If I'm starting programs like XVIEW (rsh or rexec), the Server allways
:says:
:".so:  libX11.so.4 not found"
:The problem isn't fixed if i am creating a Symbolic link in /openwin/lib
:from libX11.so.4 --> libX11.so.4.3

:(Programs like XCLOCK or the FILEMGR are running well)
:Any ideas?

:Bye,
:Robert

You need to have the libX11.so.4 in your LD_LIBRARY_PATH

you coud do this by creating a script which you execute.

example
#!/bin/sh
# takes arg of display to send output to
DISPLAY="$1"
LD_LIBRARY_PATH="/usr/openwin/lib:/usr/lib"
export DISPLAY LD_LIBRARY_PATH
"run your prog"

================================

Hope this helps
Andrew Harrison SUNUK

 
 
 

1. adding items to menu under solaris 2.3 OW 3.3

I am running solaris 2.3 with all mandatory patches, and OW 3.3.
I start xdm with a StartX script in /etc/rc3.d

The configuration files in /usr/openwin/lib/xdm have not been modified, and
all seems to work well,  except......
I've built several apps and placed them in /opt/games/bin (example)
and edited the file /usr/openwin/lib/openwin-menu to include
several additional files,  styled after
/usr/openwin/lib/openwin-menu-applications etc.  

When using the menu to start such an X app,  ~/.xsession-errors shows any
various number of libs not found,  which are located in /usr/openwin/lib.

I use my own .cshrc files,  which call a skeleton file for all users,  which
then looks to see if the user has  a ~/.mycshrc file to customize his/her
environment.  My LD_LIBRARY_PATH  is /usr/lib:/usr/openwin/lib:/opt/gnu/lib

Any suggestions as to how to fix this, other than recompiling all those apps
witha  -R/usr/openwin/lib flag?

Thanks,
--
******************************************************************************

Engineering Computer Operations

2. Changes to the printing interaction via samba from windoze 95/98 to redhat between 5.2 and 6.0 ?

3. HELP!: Solaris 2.3/OW 3.3: Mailtool doesn't work!

4. Apache / openssl upgrade problems / Linux.Slapper

5. Various Solaris 2.3 Hardware: 5/94 / OW 3.3 oddities ...

6. Ports in ipfwadm?

7. top 3.3 on Solaris 2.3

8. recvfrom():how to receive multiple UDP packets.

9. Trouble with Openwin 3.3 and Solaris 2.3

10. Solaris 2.3, OpenWin 3.3 "connection to X server lost" - WHY?

11. Installation of XView under OpenWindows 3.3/Solaris 2.3?

12. olvwm / Solaris 2.3 / OpenWindows 3.3

13. HELP: olwm hangs, SPARCstation 10, Solaris 2.3, OpenWindows 3.3