Solaris 2.2: Rwhod not working?

Solaris 2.2: Rwhod not working?

Post by Peter Erikss » Sun, 04 Jul 1993 08:48:54



The subject says it all. Anyone got rwhod to work under Solaris 2.2 ?

/Peter

--

Lysator Computer Club                             ...!uunet!lysator.liu.se!pen
University of Linkoping, Sweden                               Support the LPF!

 
 
 

Solaris 2.2: Rwhod not working?

Post by Jussi Eloran » Sun, 04 Jul 1993 16:19:36



>The subject says it all. Anyone got rwhod to work under Solaris 2.2 ?

Yes, it works here. What's the problem you are having?

Jussi

--
============================================================================
Jussi Eloranta               Internet(/Bitnet):    ! The ultimate trip is

Finland                      [130.234.0.1]         !  -- Jim Morrison

 
 
 

Solaris 2.2: Rwhod not working?

Post by Casper H.S. D » Sun, 04 Jul 1993 18:56:58



>The subject says it all. Anyone got rwhod to work under Solaris 2.2 ?

What's the problem. Simply dump in the right scripts in /etc/init.d
and /etc/rc?.d and make the directory /var/spool/rwho.

Casper

 
 
 

Solaris 2.2: Rwhod not working?

Post by Peter Erikss » Sun, 04 Jul 1993 21:29:32




>>The subject says it all. Anyone got rwhod to work under Solaris 2.2 ?

>Yes, it works here. What's the problem you are having?

Nothing happens. I start up /usr/sbin/in.rwhod and it runs just fine.
But nothing gets written into /var/spool/rwho, and the other hosts
(not running SunOS 5) never gets any broadcasts from the Solaris 2.2
machines.

Our machines are on a subnetted B-network. Netmask is 255.255.255.0
and we use <net>.255 as the broadcast address.

/Peter

--

Lysator Computer Club                             ...!uunet!lysator.liu.se!pen
University of Linkoping, Sweden                               Support the LPF!

 
 
 

Solaris 2.2: Rwhod not working?

Post by Jim Pirz » Mon, 05 Jul 1993 11:12:48





>>>The subject says it all. Anyone got rwhod to work under Solaris 2.2 ?

>>Yes, it works here. What's the problem you are having?
>Nothing happens. I start up /usr/sbin/in.rwhod and it runs just fine.
>But nothing gets written into /var/spool/rwho, and the other hosts
>(not running SunOS 5) never gets any broadcasts from the Solaris 2.2
>machines.
>Our machines are on a subnetted B-network. Netmask is 255.255.255.0
>and we use <net>.255 as the broadcast address.

Pre Solaris 2.x suns use <net>.0 as their standard broadcast address.  We have
a mix of machines and some 4.1.x machines see the Soarlsi 2.x machine and
others do not.  I am not really sure why, but when I changed the broadcast
address (ifconfig), the 4.1.x machine saw the 2.x machine (but not the other
unchanged 4.1.x machines).  Also the subnet mask will affect the results to
rwho.  We have one machine at standard Class B and the others are subnetted
and the non subnetted machine does not see the subnetted 4.1.x machines, but
does see our lone intergraph.  BTW the Solaris 2.x machine sees all machines,
whether broadcast or netmask is different.

- Jim Pirzyk
--

TAC & GrassNet System Administrator, US Army Corps of Engineers
Construction Engineering Research Labs, Champaign IL USA

 
 
 

Solaris 2.2: Rwhod not working?

Post by Lavoie*Mart » Sat, 17 Jul 1993 07:05:18


Hi Everyone !

        I would appreciate if somebody can help me with a little (hum!) problem
I have with LWP on Solaris 1.1.

        After compiling the program with:
                         gcc file.c -lnbio -llwp -o file

        I noticed that I have garbage when I type CTRL-C at the prompt
of the scanf after the program exits.  The weird thing is that if you put
the read within comments, you won't get all that shit !

        If someone knows how to get that garbage away, but without the
read, I would appreciate some hints !!!!

---------------------------------

b()
{
        int x=0;
        read();

Quote:}

main()
{       int bid;
        pod_setmaxpri(10);
        printf("Type ctrl-c\n");
        scanf("%d",&bid);
        printf("Exiting\n");

Quote:}

---------------------------------

        Thank you in advance...

PS: I would really appreciate a reply via e-mail ( because news aren't easy
    to access ).

+------------------------------------------------------------------------------+

| AI Laboratory                         |                                      |
| St-Jean Royal Military College,       |  telephone: (514) 358-6851           |
| Quebec, Canada                        |  fax: (514) 358-6799                 |
+------------------------------------------------------------------------------+

 
 
 

1. Xdm (Openwin 3.2 Solaris 2.2) not working ?

--
|>
|>I am trying to setup Xdm as supplied with Solaris 2.2 (openwin 3.2) to
|>manage a group of Xterminals. I gan get the nice xdm "Welcome" message
|>to come up via xdmcp. But when a user tries to login, xdm dies with
|>"error (pid 231): Unknown session exit code 2816 from process 304"
|>(where 304 PID of the spawned xdm).
|>
|>Anyone seen this ? Does Xdm as supplied work ?
|>

As it turns out, xdm interegates the passwd file to validate a login, but
Solaris 2.2 now has the shadow file which it uses to store the encrypted
password. You can probably guess what is happening.

One solution is to remove the '*' from /etc/passwd for your account, but
then you leave a security risk. The other is to apply patch 100953-02, which
seems to work.

Oh, Sun also say that this has been fixed in 2.3.

annoying signature follows....
                                  /\
                                / /\ \
------------------------------/ /    \ \------------------------------------

  Systems Programmer                            ph: (Aust: 61) 69 22 2823
  Division of Information Technology,          fax: (Aust: 61) 69 22 2454
  Charles Sturt University - Riverina,
  PO Box 588, Wagga Wagga, NSW, 2650, AUSTRALIA                            
------------------------------\ \    / /------------------------------------
                                \ \/ /
                                  \/
  Jennings Corollary to the Law of Selective Gravity:  The chance of the
  bread falling with the butter side down is directly proportional to
  the value of the carpet.                                            
----------------------------------------------------------------------------

2. ftape and Conner TSM 420R - kernelme.ssa [01/01]

3. Non-blocking connect()'s not working on Solaris 2.2?

4. How to compile for lower level AIX system

5. QUESTION: Solaris 2.2 rsh commands not working

6. How to Change fvwm95 to olvwm

7. unlink on Solaris 2.2 not working

8. svga library problem

9. RWHOD Is not working?

10. X11v1.1 not working with 0.96c & GCC2.2.2

11. Cyclades card does not work with VA Linux box and 2.2 Kernel

12. Kernel 2.2 does not work with Acer 8x CD-ROM?

13. korganizer recurring events not working in 2.2