spaces missing when printing arial from Netscape 7 beta via Xprt

spaces missing when printing arial from Netscape 7 beta via Xprt

Post by Bj?rn Kutt » Sun, 30 Mar 2003 13:28:33




Quote:> When I configure Netscape 7 beta (Solaris) to print via Xprt, and I have
> Arial (8859-1 or 8859-15) selected as the Sans Serif font, then Sans Serif
> text prints all run together, without spaces, even though it looks fine
> in the browser window and in the print-preview.  If I instead use Lucida
> Sans, it works fine.

check http://xprint.mozdev.org/bugs/show_bug.cgi?id=3353 - solaris
bug.
with mozilla1.3b the old postscript/default driver is gone, making
this issue pretty much important for solaris users.
 
 
 

spaces missing when printing arial from Netscape 7 beta via Xprt

Post by Richard L. Hamilt » Mon, 31 Mar 2003 14:38:13





>> When I configure Netscape 7 beta (Solaris) to print via Xprt, and I have
>> Arial (8859-1 or 8859-15) selected as the Sans Serif font, then Sans Serif
>> text prints all run together, without spaces, even though it looks fine
>> in the browser window and in the print-preview.  If I instead use Lucida
>> Sans, it works fine.

> check http://xprint.mozdev.org/bugs/show_bug.cgi?id=3353 - solaris
> bug.
> with mozilla1.3b the old postscript/default driver is gone, making
> this issue pretty much important for solaris users.

Another bugid

http://bugzilla.mozilla.org/show_bug.cgi?id=139503

has more information.  I see a workaround (prefs.js hack) but no true fix.

--


 
 
 

1. spaces missing when printing arial from Netscape 7 beta via Xprt

When I configure Netscape 7 beta (Solaris) to print via Xprt, and I have
Arial (8859-1 or 8859-15) selected as the Sans Serif font, then Sans Serif
text prints all run together, without spaces, even though it looks fine
in the browser window and in the print-preview.  If I instead use Lucida
Sans, it works fine.  This wouldn't be that big a deal except thanks to MS,
many web pages look best in their preferred fonts, i.e. Arial for Sans
Serif and Times New Roman for Serif.  I've tried varying the location of
the TTbitmaps directory in the font path for Xprt (from early to after all
other locations where the font might be found) and that doesn't make any
difference. I suppose the next step will be to try to prune the font
path to just one diretory and re-create the problem, so I can see exactly
which font is responsible.  But that still won't tell me why it's
happening.

--

2. Procmail & Popclient problem

3. Konqueror shows webpage arial font as arial black

4. AIC-7770

5. XftConfig - X using Abi Arial in preference to MS Arial

6. FTP program to (m)get directory trees ?

7. add serial device discovery via ACPI name space and via EFI HCDP

8. Network Printing (with NT4.0)

9. Printing via Netscape on HP laserjet 5L

10. printing to hp500 via netscape in RH Linux 5.2

11. Printing via IBM AIX to a Vt320 attached printer,thats connected via a Cisco 2512

12. What TCP port is used for AIX printing to print server via spooler?

13. Printing via print server