Netscape crashing Xnest?

Netscape crashing Xnest?

Post by Paul Da » Wed, 14 May 2003 23:37:11



Howdy all,

Has anyone come across this one and a solution: Exporting a dt/CDE
session from Solaris 9 boxes (tested it on two now, thinking it might be
a problem with one of them) to an Xnest session within Xfree86 4.2.1
(well Apple's XDarwin).

Whenever I load Netscape, or accidently open something that loads
Netscape, the Xnest crashes with something like:
 X Error of failed request:  BadMatch (invalid parameter attributes)
   Major opcode of failed request:  1 (X_CreateWindow)
   Serial number of failed request:  16616
   Current serial number in output stream:  16627
and the client obviouxly exist with:
 X connection to machine:1.0 broken (explicit kill or server shutdown).

Has anyone comes across this before or is it just me and my Apple
Xfree86? I don't remember coming across it using Sol8, but don't have a
box handy to test it.

PD

--
Paul Day     Web: www.bur.st/~bonfire

 
 
 

Netscape crashing Xnest?

Post by Barbie LeVil » Thu, 15 May 2003 02:37:56


On 13 May 2003 22:37:11 +0800


> Howdy all,

> Has anyone come across this one and a solution: Exporting a dt/CDE
> session from Solaris 9 boxes (tested it on two now, thinking it might be
> a problem with one of them) to an Xnest session within Xfree86 4.2.1
> (well Apple's XDarwin).

> Whenever I load Netscape, or accidently open something that loads
> Netscape, the Xnest crashes with something like:
>  X Error of failed request:  BadMatch (invalid parameter attributes)
>    Major opcode of failed request:  1 (X_CreateWindow)
>    Serial number of failed request:  16616
>    Current serial number in output stream:  16627
> and the client obviouxly exist with:
>  X connection to machine:1.0 broken (explicit kill or server shutdown).

> Has anyone comes across this before or is it just me and my Apple
> Xfree86? I don't remember coming across it using Sol8, but don't have a
> box handy to test it.

Well, i haven't come across an Xnest that is not crashing left and right all
the time.
As nice as the idea of it is, its close to useless from the all time
crashing imo.

--
Barbie - Prayers are like junkmail for Jesus

I have seen things you lusers would not believe.
I've seen Sun monitors on fire off the side of the multimedia lab.
I've seen NTU lights glitter in the dark near the Mail Gate.
All these things will be lost in time, like the root partition last week.
Time to die.

 
 
 

Netscape crashing Xnest?

Post by Roland Main » Thu, 29 May 2003 01:25:13



> Has anyone come across this one and a solution: Exporting a dt/CDE
> session from Solaris 9 boxes (tested it on two now, thinking it might be
> a problem with one of them) to an Xnest session within Xfree86 4.2.1
> (well Apple's XDarwin).

> Whenever I load Netscape, or accidently open something that loads
> Netscape, the Xnest crashes with something like:
>  X Error of failed request:  BadMatch (invalid parameter attributes)
>    Major opcode of failed request:  1 (X_CreateWindow)
>    Serial number of failed request:  16616
>    Current serial number in output stream:  16627
> and the client obviouxly exist with:
>  X connection to machine:1.0 broken (explicit kill or server shutdown).

> Has anyone comes across this before or is it just me and my Apple
> Xfree86? I don't remember coming across it using Sol8, but don't have a
> box handy to test it.

Maybe it's related to the issue that all GTK+ applications trigger
crashes in Xnest sooner or later (Mozilla/Netscape6+7 are GTK+ based
unless you have compiled the "Xlib port" yourself from source...) ...

One option to dig around for a solution and/or workaround may be to file
a bug under http://bugzilla.mozilla.org and CC:

to work around the issue...

----

Bye,
Roland

--
  __ .  . __


  /O /==\ O\  MPEG specialist, C&&JAVA&&Sun&&Unix programmer
 (;O/ \/ \O;) TEL +49 641 99-41370 FAX +49 641 99-41359