NIS+ problems

NIS+ problems

Post by william_schwa.. » Fri, 02 Jun 2000 04:00:00



I'm working on setting up my first nis+ server and things seemed go go well
as I followed the book in setting up the root server.

After everything was set and I rebooted the server I can no longer
access it from other systems.  I get connection refused errors.

/var/adm/messages has:
Jun  1 17:31:54 nis1 /usr/lib/nfs/lockd[148]: Cannot get address for transport udp host \1 service lockd
Jun  1 17:31:54 nis1 inetd[149]: ftp/tcp: unknown service
Jun  1 17:31:54 nis1 inetd[149]: telnet/tcp: unknown service
Jun  1 17:31:54 nis1 /usr/lib/nfs/lockd[148]: Cannot establish NLM service over
/dev/udp: transport setup problem.
Jun  1 17:31:54 nis1 inetd[149]: name/udp: unknown service
Jun  1 17:31:54 nis1 inetd[149]: shell/tcp: unknown service
Jun  1 17:31:54 nis1 /usr/lib/nfs/lockd[148]: Cannot get address for transport tcp host \1 service lockd
Jun  1 17:31:54 nis1 /usr/lib/nfs/lockd[148]: Cannot establish NLM service over
/dev/tcp: transport setup problem.
Jun  1 17:31:54 nis1 inetd[149]: login/tcp: unknown service
Jun  1 17:31:54 nis1 /usr/lib/nfs/lockd[148]: Could not start NLM service for any protocol. Exiting.
Jun  1 17:31:54 nis1 inetd[149]: exec/tcp: unknown service
Jun  1 17:31:54 nis1 inetd[149]: comsat/udp: unknown service

etc... for all the services.

when I try to connect out from the box I get:
# telnet anubis
telnet: tcp/telnet: unknown service

Not sure what I missed here, if anyone has any ideas i'd be greatful.

It'sa Solaris 2.7 system.

thanks,
Bill

 
 
 

NIS+ problems

Post by Neil W Ricker » Tue, 06 Jun 2000 04:00:00



>I'm working on setting up my first nis+ server and things seemed go go well
>as I followed the book in setting up the root server.
>After everything was set and I rebooted the server I can no longer
>access it from other systems.  I get connection refused errors.
>/var/adm/messages has:
>Jun  1 17:31:54 nis1 /usr/lib/nfs/lockd[148]: Cannot get address for transport udp host \1 service lockd
>Jun  1 17:31:54 nis1 inetd[149]: ftp/tcp: unknown service
>...

You forgot to initialize all of your tables.

        /usr/lib/nis/nisaddent -f /etc/services services

That should fix your services table.  Give it a minute or two to
settle down.  Then send a SIGHUP to inetd, and see if it can restart
properly.

Then check whether you have properly initialized other tables.

 
 
 

1. NIS+ problems. NIS transition kit better ?

The subject says it all. I have enough of this buggy NIS+
code. This morning, it cleared my aliases table when I added
an entry ! Now I cannot modify anything. It says "perm. denied"
even if it worked yesterday.

#FLAME ON
I'm sure even the developpers are affraid to look into their
source files.
#FLAME OFF

Now did you get better experience with the NIS transition kit
for Solaris 2.x ? I have heard a new version shoule be out soon.

Is it more stable than NIS ?

---
 ---
 Charles Bueche
 [Unix, Network and Wind] - Surfer

 +41 65 24 33 74 - VOICE
 +41 65 24 21 43 - FAX

2. help with AMI MegaRAID controller

3. NIS problem on multivendor nis configuration

4. HP Colorado 8GB Tape Drive

5. NIS problem with HP-NIS

6. G3 all in one setup and such

7. Bizarre NIS+ problem - nisdefaults thinks I am NIS+ master principal

8. Serial Comm/Modem Weirdness

9. NIS problems => Apache problems

10. NIS problem solved with IY06887 but other problem

11. rsh problem and NIS problem

12. NIS Problems

13. NIS problem