strange output of "who am I" & "last" on solaris 9

strange output of "who am I" & "last" on solaris 9

Post by To » Sun, 10 Oct 2004 06:01:34



OS:
%  uname -a
SunOS sunbox-1 5.9 Generic_117171-09 sun4u sparc SUNW,Ultra-2
ssh on Solaris 9 comes with the OS.

When I tried to "ssh" from another machine (Soalris 7 + OpenSSH)
to it, the output of "who am i" and "lst" is strange, the IP address
part is weird.

%  who am i
tom       pts/3        Oct  8 13:54    (t?)

%  last |more
tom   pts/3        t?             Fri Oct  8 13:54   still logged in

When I tried to ssh from another Solaris 9 (ssh comes with OS),
the IP address part is missing in the output of "who am i" and "last":
%  who am i
tom       pts/1        Oct  8 14:00

%  last |more
tom      pts/1                         Fri Oct  8 14:00   still logged in

Any idea?

Thanks.

 
 
 

strange output of "who am I" & "last" on solaris 9

Post by ps » Sun, 10 Oct 2004 06:53:53




Quote:> OS:
> %  uname -a
> SunOS sunbox-1 5.9 Generic_117171-09 sun4u sparc SUNW,Ultra-2
> ssh on Solaris 9 comes with the OS.

> When I tried to "ssh" from another machine (Soalris 7 + OpenSSH)
> to it, the output of "who am i" and "lst" is strange, the IP address
> part is weird.

> %  who am i
> tom       pts/3        Oct  8 13:54    (t?)

> %  last |more
> tom   pts/3        t?             Fri Oct  8 13:54   still logged in

> When I tried to ssh from another Solaris 9 (ssh comes with OS),
> the IP address part is missing in the output of "who am i" and "last":
> %  who am i
> tom       pts/1        Oct  8 14:00

> %  last |more
> tom      pts/1                         Fri Oct  8 14:00   still logged in

> Any idea?

> Thanks.

http://www.google.com/groups?hl=en&lr=lang_en&c2coff=1&safe=off&frame...
th=e4db1390d4e5c1e2&seekm=ciepu9%24r18%241%40pegasus.csx.cam.ac.uk#link1

 
 
 

strange output of "who am I" & "last" on solaris 9

Post by Peter Bunclar » Tue, 12 Oct 2004 16:30:50



>OS:
>%  uname -a
>SunOS sunbox-1 5.9 Generic_117171-09 sun4u sparc SUNW,Ultra-2
>ssh on Solaris 9 comes with the OS.

>When I tried to "ssh" from another machine (Soalris 7 + OpenSSH)
>to it, the output of "who am i" and "lst" is strange, the IP address
>part is weird.

>%  who am i
>tom       pts/3        Oct  8 13:54    (t?)

>%  last |more
>tom   pts/3        t?             Fri Oct  8 13:54   still logged in

>When I tried to ssh from another Solaris 9 (ssh comes with OS),
>the IP address part is missing in the output of "who am i" and "last":
>%  who am i
>tom       pts/1        Oct  8 14:00

>%  last |more
>tom      pts/1                         Fri Oct  8 14:00   still logged in

>Any idea?

>Thanks.

T113273-10 is being tested right now, and will presumably become
publicly avaiable
shortly. If you can go back to -07 that would fix that problem (and
reintroduce the problems
fixed up till -09, of course).

Pete.

 
 
 

1. strange output of "who am i" & "last" in Solaris 9

[snip]

What revision of patch 113273 do you have installed?  I think patch
113273-08 introduced this problem; it and 113273-09 are both marked
WITHDRAWN.  This problem was brought up last month:

http://groups.google.com/groups?threadm=chvct4%244m0%241%40fantastix....

--
Michael Fuhr
http://www.fuhr.org/~mfuhr/

2. Kpilot Makefile Loop

3. GETSERVBYNAME()????????????????????"""""""""""""

4. mgetty reports errors for serial port tty

5. Strange "w", "who" and "uptime" output

6. Q: /etc/make.conf

7. """"""""My SoundBlast 16 pnp isn't up yet""""""""""""

8. Installation problem with TNT2 on Linux

9. """the last day of sale"""

10. Type "(", ")" and "{", "}" in X...

11. strange string in "last" output

12. how to use "last" to show "xterm" info?

13. "access" < 0 && "errno" == 0 ??