libpng.so.3 - missing library file missing

libpng.so.3 - missing library file missing

Post by hpy_a.. » Tue, 16 Mar 2004 01:27:39



I reinstalled ghostscript from another mirror site Still have the same problem  .
Please HELP . some suggestions .
# ldd /opt/csw/bin/gs
        libXt.so.4 =>    /usr/lib/libXt.so.4
        libXext.so.0 =>  /usr/lib/libXext.so.0
        libX11.so.4 =>   /usr/lib/libX11.so.4
        libpng.so.3 =>   (file not found)
        libz.so.1 =>     /usr/lib/libz.so.1
        libm.so.1 =>     /usr/lib/libm.so.1
        libc.so.1 =>     /usr/lib/libc.so.1
        libSM.so.6 =>    /usr/lib/libSM.so.6
        libICE.so.6 =>   /usr/lib/libICE.so.6
        libdga.so.1 =>   /usr/openwin/lib/libdga.so.1
        libsocket.so.1 =>        /usr/lib/libsocket.so.1
        libnsl.so.1 =>   /usr/lib/libnsl.so.1
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libmp.so.2 =>    /usr/lib/libmp.so.2
#
 
 
 

libpng.so.3 - missing library file missing

Post by Michael Laajane » Tue, 16 Mar 2004 03:39:13


HI;

> I reinstalled ghostscript from another mirror site Still have the same problem  .
> Please HELP . some suggestions .
> # ldd /opt/csw/bin/gs
>         libXt.so.4 =>    /usr/lib/libXt.so.4
>         libXext.so.0 =>  /usr/lib/libXext.so.0
>         libX11.so.4 =>   /usr/lib/libX11.so.4
>         libpng.so.3 =>   (file not found)
>         libz.so.1 =>     /usr/lib/libz.so.1
>         libm.so.1 =>     /usr/lib/libm.so.1
>         libc.so.1 =>     /usr/lib/libc.so.1
>         libSM.so.6 =>    /usr/lib/libSM.so.6
>         libICE.so.6 =>   /usr/lib/libICE.so.6
>         libdga.so.1 =>   /usr/openwin/lib/libdga.so.1
>         libsocket.so.1 =>        /usr/lib/libsocket.so.1
>         libnsl.so.1 =>   /usr/lib/libnsl.so.1
>         libdl.so.1 =>    /usr/lib/libdl.so.1
>         libmp.so.2 =>    /usr/lib/libmp.so.2
> #

Is that true, I thought that gs always was a script and a script has no
shared libraries so ldd should not work at all!

Have you really installed things using blastwave?

/michael

 
 
 

libpng.so.3 - missing library file missing

Post by Beard » Tue, 16 Mar 2004 03:53:41



> I reinstalled ghostscript from another mirror site Still have the same problem  .
> Please HELP . some suggestions .
> # ldd /opt/csw/bin/gs
>         libXt.so.4 =>    /usr/lib/libXt.so.4
>         libXext.so.0 =>  /usr/lib/libXext.so.0
>         libX11.so.4 =>   /usr/lib/libX11.so.4
>         libpng.so.3 =>   (file not found)
>         libz.so.1 =>     /usr/lib/libz.so.1
>         libm.so.1 =>     /usr/lib/libm.so.1
>         libc.so.1 =>     /usr/lib/libc.so.1
>         libSM.so.6 =>    /usr/lib/libSM.so.6
>         libICE.so.6 =>   /usr/lib/libICE.so.6
>         libdga.so.1 =>   /usr/openwin/lib/libdga.so.1
>         libsocket.so.1 =>        /usr/lib/libsocket.so.1
>         libnsl.so.1 =>   /usr/lib/libnsl.so.1
>         libdl.so.1 =>    /usr/lib/libdl.so.1
>         libmp.so.2 =>    /usr/lib/libmp.so.2
> #

1. Did you not read Alan Coopersmith's response and suggestion to your
previous (and identical) post?

2. The concept of "mirror sites" is that they maintain identical images
of software (except when updates are being filtered through). Thus if
your first installation left you with a missing .so then reinstalling
from a mirror will more than likely produce the same result de facto.

You will not receive further assistance if you do not heed previous
attempts at helping you, and simply post the same question again.

 
 
 

libpng.so.3 - missing library file missing

Post by Alan Coopersmit » Tue, 16 Mar 2004 03:57:14



|I reinstalled ghostscript from another mirror site Still have the same
|problem  .
|Please HELP . some suggestions .
|# ldd /opt/csw/bin/gs
|        libpng.so.3 =>   (file not found)

I have no idea what you've done, but you've got something really messed
up.  I just ran 'pkg-get -i ghostscript' and it included the png package
you seem to be missing among the dependencies it downloaded and
installed, and the resulting /opt/csw/bin/gs is a shell script which you
can't run ldd on.  It runs /opt/csw/bin/gsc, and ldd on that shows no
problems finding any of the libraries.

Try pkgrm'ing the packages and running pkg-get again to reget them.

--
________________________________________________________________________


  Working for, but definitely not speaking for, Sun Microsystems, Inc.

 
 
 

libpng.so.3 - missing library file missing

Post by hpy_a.. » Tue, 16 Mar 2004 17:41:56


Is space may cause such I problem . How can I change the installation
directory from /opt/csw/bin into other directory ?

Any how I got that message about successfull installation .

## Installing part 1 of 1.
[ verifying class <none> ]
Mar 15 10:31:44 Xerox sendmail[479]: My unqualified host name
(localhost) unknown; sleeping for retry
Mar 15 10:32:44 Xerox sendmail[479]: unable to qualify my own domain
name (localhost) -- using short name
Mar 15 10:32:44 Xerox sendmail[479]: [ID 702911 mail.alert] unable to
qualify my own domain name (localhost) -- using short name
Mar 15 10:32:44 Xerox sendmail[479]: [ID 702911 mail.alert] unable to
qualify my own domain name (localhost) -- using short name

Installation of <CSWgs> was successful.
#

 
 
 

libpng.so.3 - missing library file missing

Post by Michael Laajane » Wed, 17 Mar 2004 21:09:04


HI;

> Is space may cause such I problem . How can I change the installation
> directory from /opt/csw/bin into other directory ?

You could mount a filesystem in /opt/csw from some other disk you have.

If you are on a standalone machine you could use the loopback filesystem
and "remount" the filesystem in /opt/csw, see below.

Assume that you have diskspace available in /export/u3

/export/u3/SunOS/5.8/sparc/csw - /opt/csw lofs 2 yes -

/michael

 
 
 

1. Missing libpng for XEmacs

I'm trying to install an RPM of Xemacs 20.3.4 on redhat 5.0, but
don't have the required libpng.so.1. I've got libpng.so.0 and .2,
but no .1. Does anyone know what package this library is supposed to
be in? Thanks.

--

Robert Ewald

http://www.students.uiuc.edu/~r-ewald

2. talk: Checking for Invitation on caller's machine...

3. Missing Library File

4. Memory lost

5. sendmail library file missing?!?

6. wrong disk index in /proc/stat

7. missing java library file

8. Good Cheap Motif

9. Gnome missing library file

10. Missing X11 library files?

11. Library files missing with kde 2.1 beta

12. Missing Library Files

13. missing lib.so file/library