semaphore facility inactive

semaphore facility inactive

Post by pik.. » Thu, 04 Jan 2001 04:41:31



Hi
Im new to solaris (a fe years experience in linux).
I've got the problem
command:
bash-2.03# ipcs
IPC status from <running system> as of Thu Jan  4 08:04:29 CET 2001
Message Queue facility inactive.
T         ID      KEY        MODE        OWNER    GROUP
Shared Memory:
m          0   0x50000b8f --rw-r--r--     root     root
Semaphore facility inactive.

I don't know how to turn semaphore ficility on :((
this is piece of my /etc/system:

set shmsys:shminfo_shmmax=4294967295
set shmsys:shminfo_shmmin=1
set shmsys:shminfo_shmmni=100
set shmsys:shminfo_shmseg=10
set semsys:seminfo_semmni=100
set semsys:seminfo_semmsl=110
set semsys:seminfo_semmns=250
set semsys:seminfo_semopm=100
set semsys:seminfo_semvmx=32767
* BEGIN RAID Manager addition
* DO NOT EDIT from BEGIN above to END below...
forceload: drv/sd
forceload: drv/rdnexus
forceload: drv/rdriver
* END RAID Manager addition

and modinfo:
bash-2.03# modinfo -i 106
 Id Loadaddr   Size Info Rev Module Name
106 78068000   23d8  52   1  shmsys (System V shared memory)
106 78068000   23d8  52   1  shmsys (32-bit System V shared memory)

I don't know what else i'm doing wrong.
Please, help me:)

Maciej

 
 
 

semaphore facility inactive

Post by Fran » Thu, 04 Jan 2001 05:20:03


Hi Maciej

The IPC facility semaphores is configured but not used by any program.
Nothing is wrong with your configuration.
If there are no further problems everthing works as designed.

Frank

 
 
 

semaphore facility inactive

Post by Richard J. Seccondr » Thu, 04 Jan 2001 05:24:56


Some suggestions..

Make sure the file /kernel/sys/semsys exists and  isn't corrupted.
My Solaris 2.6.system shows a "size" value of  8152+276+12=8440 for semsys
Run "nm" against the module also and inspect the output.

Take a look at my /etc/system for my Oracle/Peoplesoft DB server.
These are my numbers. They work...

see below

set shmsys:shminfo_shmmax=4292967295
set semsys:seminfo_semmap=550
set semsys:seminfo_semmni=600
set semsys:seminfo_semmns=3000
set semsys:seminfo_semmsl=600
set semsys:seminfo_semmnu=3000
set semsys:seminfo_semume=500
set shmsys:shminfo_shmmin=500
set shmsys:shminfo_shmmni=500
set shmsys:shminfo_shmseg=3000
set msgsys:msginfo_msgmni=1000
set msgsys:msginfo_msgmap=1200

good luck

Rick Seccondro
EMC Technical Services, Inc.
UNIX Systems Consulting
Monroe Twp., N.J.

Brainbench.com MVP for UNIX Systems Administration


Quote:> Hi
> Im new to solaris (a fe years experience in linux).
> I've got the problem
> command:
> bash-2.03# ipcs
> IPC status from <running system> as of Thu Jan  4 08:04:29 CET 2001
> Message Queue facility inactive.
> T         ID      KEY        MODE        OWNER    GROUP
> Shared Memory:
> m          0   0x50000b8f --rw-r--r--     root     root
> Semaphore facility inactive.

> I don't know how to turn semaphore ficility on :((
> this is piece of my /etc/system:

> set shmsys:shminfo_shmmax=4294967295
> set shmsys:shminfo_shmmin=1
> set shmsys:shminfo_shmmni=100
> set shmsys:shminfo_shmseg=10
> set semsys:seminfo_semmni=100
> set semsys:seminfo_semmsl=110
> set semsys:seminfo_semmns=250
> set semsys:seminfo_semopm=100
> set semsys:seminfo_semvmx=32767
> * BEGIN RAID Manager addition
> * DO NOT EDIT from BEGIN above to END below...
> forceload: drv/sd
> forceload: drv/rdnexus
> forceload: drv/rdriver
> * END RAID Manager addition

> and modinfo:
> bash-2.03# modinfo -i 106
>  Id Loadaddr   Size Info Rev Module Name
> 106 78068000   23d8  52   1  shmsys (System V shared memory)
> 106 78068000   23d8  52   1  shmsys (32-bit System V shared memory)

> I don't know what else i'm doing wrong.
> Please, help me:)

> Maciej

 
 
 

1. problems configuring shared memory facility and semaphores facility

I suppose I needs to add this to the FAQ.

Anyway, semaphores aren't loaded until needed.  Ipcs is broken in that
it gives info on whether a system is loaded or not, not whether it
is available.  If you use them, you'll find the semaphores are there.

Casper
--
Casper Dik - Network Security Engineer - Sun Microsystems
This article is posted from my guest account at the University

Opinions expressed here are mine (but you're welcome to share them with me)

2. SUSE 9.1 & display adapter problem

3. "Message Queue facility inactive" -- HELP!

4. Multiple cookies in Apache Module

5. Semaphore facility not in System ??

6. Newbie: Connecting to internet on Sparc

7. Increasing # of semaphores in semaphore set?

8. Recommendation for Database Browser on SCO (ODBC or native interface)

9. Sys V Semaphores vs. POSIX Semaphores??

10. Check inactive users -HOW-

11. "inactive" NIC

12. inactive user tool

13. Question regarding inactive memory