X Server won't start up on PC with Sol.8

X Server won't start up on PC with Sol.8

Post by zur Bor » Tue, 20 Feb 2001 00:29:33



Hi all, I am having problems starting up the X server on Solaris 8 (x86)
with a Matrox Millennium G400 (16 MB) graphics card and a high-end
monitor. kdmconfig runs successfully without any problems. I have tried
with various resolutions and frequencies. The system comes up as normal
but starting X (dtlogin) fails. It shows the CDE sandclock, tries 3
times to start up but then gives up and shows the console login prompt.

Error messages in /var/dt/Xerrors:
X_mkdir: No such file or directory

such device
Can't control power levels
DPMSSupported: Invalid argument
Frame buffer 0 does not support DPMS
<several warnings about fonts and stuff>
Unable to load any usable fontset...

I hope this description is precise enough to get help from experts.
Any hint will be appreciated.
Thanks, Wernke

Email: Wernke at zur-Borg.de

 
 
 

X Server won't start up on PC with Sol.8

Post by Steven Satell » Tue, 20 Feb 2001 03:38:52


Is that an AGP card? I never got an AGP card to work with Solaris, I dont think it supports AGP at all. Does anyone know for definite if it does support it? I have an ATI PCI video card and it loves it try something like that.

  Hi all, I am having problems starting up the X server on Solaris 8 (x86) with a Matrox Millennium G400 (16 MB) graphics card and a high-end monitor. kdmconfig runs successfully without any problems. I have tried with various resolutions and frequencies. The system comes up as normal but starting X (dtlogin) fails. It shows the CDE sandclock, tries 3 times to start up but then gives up and shows the console login prompt.
  Error messages in /var/dt/Xerrors:
  X_mkdir: No such file or directory

  Can't control power levels
  DPMSSupported: Invalid argument
  Frame buffer 0 does not support DPMS
  <several warnings about fonts and stuff>
  Unable to load any usable fontset...

  I hope this description is precise enough to get help from experts.
  Any hint will be appreciated.
  Thanks, Wernke

  Email: Wernke at zur-Borg.de

 
 
 

X Server won't start up on PC with Sol.8

Post by Wernke zur Bor » Thu, 22 Feb 2001 01:25:01



> Is that an AGP card? I never got an AGP card to work with Solaris, I
> dont think it supports AGP at all. Does anyone know for definite if it
> does support it? I have an ATI PCI video card and it loves it try
> something like that.

Yes, the Matrox Millennium G400 AGP is listed in the hardware
compatibility list:

http://soldc.sun.com/support/drivers/hcl/8/101/files/c0110.htm

Although it does not pop up in the list of choices of kdmconfig... may
be I need a patch?

Wernke

 
 
 

X Server won't start up on PC with Sol.8

Post by Paul » Thu, 22 Feb 2001 12:54:02


Could never get an AGP card to work either.
Although the Hardware Compatability list says
the one I have will, no such luck.


  Is that an AGP card? I never got an AGP card to work with Solaris, I dont think it supports AGP at all. Does anyone know for definite if it does support it? I have an ATI PCI video card and it loves it try something like that.

    Hi all, I am having problems starting up the X server on Solaris 8 (x86) with a Matrox Millennium G400 (16 MB) graphics card and a high-end monitor. kdmconfig runs successfully without any problems. I have tried with various resolutions and frequencies. The system comes up as normal but starting X (dtlogin) fails. It shows the CDE sandclock, tries 3 times to start up but then gives up and shows the console login prompt.
    Error messages in /var/dt/Xerrors:
    X_mkdir: No such file or directory

    Can't control power levels
    DPMSSupported: Invalid argument
    Frame buffer 0 does not support DPMS
    <several warnings about fonts and stuff>
    Unable to load any usable fontset...

    I hope this description is precise enough to get help from experts.
    Any hint will be appreciated.
    Thanks, Wernke

    Email: Wernke at zur-Borg.de

 
 
 

X Server won't start up on PC with Sol.8

Post by Wernke zur Bor » Thu, 22 Feb 2001 18:22:41



> Is that an AGP card? I never got an AGP card to work with Solaris, I
> dont think it supports AGP at all. Does anyone know for definite if it
> does support it? I have an ATI PCI video card and it loves it try
> something like that.

How would you explain that kdmconfig displays a beautiful and colorful
high-resolution picture if the AGP card was not supported?

Wernke

 
 
 

1. Help - Sol 2.3 SS2 and Winsock PC won't talk!!!

As far as I can tell I've got everything properly configured but I get
no intelligible response from either side.

The SS2 does have the PC's inet address specified as the destination address
to the le0 interface and the routing table entry is present and correct.

The arp table does list the proper ethernet to ip mapping for both
the local card and the PC's card.

If a launch snoop and then ping the PC, it shows packets flying out over
the ethernet and disappering into the Great Ethervoid.

If I ping the SS2 from the PC, packets fly out over the ethernet and into
the SS2, which registers them as "Type=FFFF (Unknown)" and doesn't reply
to them.

Someone before had mentioned that they maybe using two different packet
types, 802.3 and something else, but I can't remember and searching all
the relevant man pages and Sysadmin Answerbook turned up nil.

I sure would appreciate any help on this as I've been trying to get these
things to talk for months now.  As it is, the SS2 is directly connected
to the net, but the PC's (which are on the same ethernet cable) aren't
simply because I can't this to work.  And to access this server,
they have to logon to our providers system and telnet over, which is
kinda stupid since they're on the same ethernet.

Is it possible that the transceiver I have on the Sun is the wrong kind.

The PC Lan is on BNC.

Thanks for any help.  Email would be best and I will DEFINITELY
post a summary.

Best Regards,
Cengiz

---

 __                                                                      __
<  >--------------------------------------------------------------------<  >
 || Cengiz Akinli                |  Every great achievement was once     ||
 || Netmar, Inc.                 |  considered impossible                ||
 || Voice - (919) 309-2459       |                          -Unknown     ||
 || Voice Mail - (919) 254-3561  |---------------------------------------||


<__>--------------------------------------------------------------------<__>

2. RedHat Apache problem

3. Shape Ups,Men's Shape Ups,Men's Skechers Shape Ups - new styles!

4. ipmasqadm / redirect with suse linux 6.3

5. URGENT: Sol 2.3 lpsched won't start!

6. mirror drives and raid.

7. 'Server already active for display 0' - won't start

8. New user

9. PC won't even start anymore......

10. Sol 2.4 (x86) DNS won't talk to it's secondaries

11. X server won't start

12. X server won't start up(Redhat 6.2)

13. SQL-Retrivers - Informix server won't start