xv-3.00 and setitimer bug on x86

xv-3.00 and setitimer bug on x86

Post by Paul De B » Fri, 24 Sep 1993 22:47:05



when i tried xv-3.00 with Solaris-2.1 x86 it frequently hung.
i traced it down to the setitimer use in xvmisc.c
when i made xv-3.00 use usleep instead of setitimer the problem
went away.

is anyone aware of this problem? is there a fix?
i also heard rumors that the usleep call i'm using now is also broken.
anyone know more about that?

Paul.

 
 
 

1. SOLVED : LILO gives me L 00 00 00 00 00 00 00

To everyone who mailed me with there suggestions and for my answers here
it is.

I finally did some checking and found that my BIOS was pretty new and
that where
it specifies the hard drives there is a column called Mode. This goes
from 1 to
4 and is as follows.

Mode 1 = Normal - all cylinders, heads and sectors stay the same.
Mode 2 = Large - it doubles your heads and halves your cylinders.
Thereby getting
                 less cylinders. However for my drive it was still over
1024.
Mode 3 = LBA - it quadruples your heads and divides your cylinders by 4.
Thereby
               getting even less cylinders than Large mode. This left me
with
               cylinders =  621, heads = 64, sectors = 63 which use to
be
                         = 2484,       = 16,           63.
Mode 4 = Auto - Don't know what this is for, but it did not work for me.

This approach probably won't work for most people with older BIOS's.
Unfortuanately I could not get to a linux software solution after many
hours
of testing different setups and posts. Hope this helps someone.

:-)

-------------------------------------------------------------------------------
Mr Zahir Toufie, Systems Consultant, NHD IT (Info Tech) Cape Tech
-------------------------------------------------------------------------------
Fax. (W) 808 4102        
Tel. (W) 808 3580     (H) 633 2695     (C) 083 268 8301
    ** Use dial code 021 for National or +27 21 for International calls.
**
-------------------------------------------------------------------------------

Home Page http://www.sun.ac.za/local/admin/infoteg/ard_pers.html
-------------------------------------------------------------------------------

2. Linux Frequently Asked Questions with Answers (Part 4 of 6)

3. Help LILO gives me L 00 00 00 00 00 00 00

4. Linux

5. DHCP Server Leasing Addresses to MAC Addresses of 00-00-00-00-00-00

6. What EIDE Controllers are supported?

7. HELP: ifconfig reports hwaddr 00-00-00-00-00...

8. Mathematica for Linux?

9. xv-3.00 and Solaris 2.3

10. LILO / L 00 00 00 ... / Large Disk problems

11. BootMagic LILO hangs with 00 00 00...

12. Ethernet Address 00-00-00...

13. error: received bad configure nak/rej 12 00 00 00