Using serial port of Envizex II X-terminal for Digitizer

Using serial port of Envizex II X-terminal for Digitizer

Post by Walter Lolha » Sat, 06 May 2000 04:00:00



Hi Folks,

I am trying to use the serial port of a HP Envizex II X-terminal to
connect a digitizer to. I have figured that I need to run a hpnptyd
daemon to make a network connection between the serial port and a
/dev/pty... device. However, when I run the daemon, the error log says
"Connection refused". I have enabled the serial port form the config
screen to be used as a "Tablet". None of the other choices seemed any
closer.

When the X-terminal boots, as it discovers the devices it shows an icon
for it, including an icon of a tablet, which I presume would enable the
serial port, but connection is still refused.

Q1: The default TCP port number which hpnptyd uses is 9100, is that the
right port? What would it be for the second serial port, or the paralle
port. I notices that x199 port is contactable, but does not work (where
x can have many values, such as 1, 2, 3, ....20, ...)

Q2: Is there something else I am missing in the config screen.

Q3. Has anybody out there done what I am trying to do?

Q4. Am I on the right track?

Thanks for any info.
--
Walter Lolham  |  Genasys Systems Pty Ltd
               |  13th Level, 33 Berry St, North Sydney, NSW, Australia
               |  Phone:  +61-2-9926-2800 (-2888 FAX)

 
 
 

Using serial port of Envizex II X-terminal for Digitizer

Post by Walter Lolha » Sat, 06 May 2000 04:00:00


Hi Folks,

I am trying to use the serial port of a HP Envizex II X-terminal to
connect a digitizer to. I have figured that I need to run a hpnptyd
daemon to make a network connection between the serial port and a
/dev/pty... device. However, when I run the daemon, the error log says
"Connection refused". I have enabled the serial port form the config
screen to be used as a "Tablet". None of the other choices seemed any
closer.

When the X-terminal boots, as it discovers the devices it shows an icon
for it, including an icon of a tablet, which I presume would enable the
serial port, but connection is still refused.

Q1: The default TCP port number which hpnptyd uses is 9100, is that the
right port? What would it be for the second serial port, or the paralle
port. I notices that x199 port is contactable, but does not work (where
x can have many values, such as 1, 2, 3, ....20, ...)

Q2: Is there something else I am missing in the config screen.

Q3. Has anybody out there done what I am trying to do?

Q4. Am I on the right track?

Thanks for any info.
--
Walter Lolham  |  Genasys Systems Pty Ltd
               |  13th Level, 33 Berry St, North Sydney, NSW, Australia
               |  Phone:  +61-2-9926-2800 (-2888 FAX)

--
Walter Lolham  |  Genasys Systems Pty Ltd
               |  13th Level, 33 Berry St, North Sydney, NSW, Australia
               |  Phone:  +61-2-9926-2800 (-2888 FAX)


 
 
 

Using serial port of Envizex II X-terminal for Digitizer

Post by Jean-Francois Monestie » Sat, 06 May 2000 04:00:00


Quote:>I am trying to use the serial port of a HP Envizex II X-terminal to
>connect a digitizer to. I have figured that I need to run a hpnptyd
>daemon to make a network connection between the serial port and a
>/dev/pty... device. However, when I run the daemon, the error log says
>"Connection refused". I have enabled the serial port form the config
>screen to be used as a "Tablet". None of the other choices seemed any
>closer.

I'm not certain you need to "enabled the serial port form the config screen
to be used as a "Tablet"."

Doing so, you probably load a "Tablet" driver of some sort, which opens the
serial port for itself.

Hence, you get your "Connection refused".

Quote:>When the X-terminal boots, as it discovers the devices it shows an icon
>for it, including an icon of a tablet, which I presume would enable the
>serial port, but connection is still refused.

>Q1: The default TCP port number which hpnptyd uses is 9100, is that the
>right port? What would it be for the second serial port, or the paralle
>port. I notices that x199 port is contactable, but does not work (where
>x can have many values, such as 1, 2, 3, ....20, ...)

According to the doc.
    9100 binds to serial 1
    9101 binds to the parallel port
    9102 binds to serial 2 (if any)

Quote:>Q2: Is there something else I am missing in the config screen.

Make sure your device communicates using the parameters displayed in
Serial(1) (or Serial(2))

Quote:>Q3. Has anybody out there done what I am trying to do?

I can remember setting up almost the same sort of com. to print out.
Successfully.

Quote:>Q4. Am I on the right track?

A question we all fear to answer :-)

Jean-Francois.

 
 
 

Using serial port of Envizex II X-terminal for Digitizer

Post by Jean-Francois Monestie » Sat, 06 May 2000 04:00:00


Quote:>Q2: Is there something else I am missing in the config screen.

By the way, make sure you're loading the "Remote Ports Extension". I think
this is the daemon (running on the XTerm) accepting connections onto 9100,
9101 and 9102.

To enable this :
    . Have a look in /opt/hpxt/enware2/xthome/bin
    . There is a file called 'directives'
    . Copy it to '<XTerm_hostname_or_IP>.directives'
    . Edit it, look for 'remportExt' and add an 'Auto' keywork in front of
the whole line

This way, you tell your '<XTerm_hostname_or_IP>' (and this one only) to
automatically load the 'remportExt'.

Then, reboot your XTerm, and from the Config. Screen,
[Terminal]-[Extensions] panel, check that the "Remote Ports Extension" is
marked as "Active".

A 'remsh <XTerm_hostname_or_IP> get installed' shall also show this in the
"Extensions" section.

Jean-Francois.

 
 
 

Using serial port of Envizex II X-terminal for Digitizer

Post by Matt Alderso » Sat, 06 May 2000 04:00:00


Yes, I have an Envizex II with a digitizer on the serial port.
One difference I have with the Envizex II and earlier Envizex
as well as RX700 Xterminals, all of which I have used a digitizer
on the serial port:
You must start the hpnptyd AFTER the Envizex II finishes booting.
Also, the Envizex II must be rebooted following a reboot of
the host system. This too is different from earlier HP Xterminals.
There does not seem to be a way for example to successfully
get the hpnptyd to work if the host system is rebooted and
hpnptyd is started from a script in /sbin/init.d. This works fine
for earlier Envizex and RX700 but NOT for Envizex II.
I think you are on the right track, try killing and restarting
the particular hpnptyd process for the Envizex II, I think it will work.
Please contact me via email if you need more information on
setting up hpnptyd to use an Xterminal serial port for digitizing.


> Hi Folks,

> I am trying to use the serial port of a HP Envizex II X-terminal to
> connect a digitizer to. I have figured that I need to run a hpnptyd
> daemon to make a network connection between the serial port and a
> /dev/pty... device. However, when I run the daemon, the error log says
> "Connection refused". I have enabled the serial port form the config
> screen to be used as a "Tablet". None of the other choices seemed any
> closer.

> When the X-terminal boots, as it discovers the devices it shows an icon
> for it, including an icon of a tablet, which I presume would enable the
> serial port, but connection is still refused.

> Q1: The default TCP port number which hpnptyd uses is 9100, is that the
> right port? What would it be for the second serial port, or the paralle
> port. I notices that x199 port is contactable, but does not work (where
> x can have many values, such as 1, 2, 3, ....20, ...)

> Q2: Is there something else I am missing in the config screen.

> Q3. Has anybody out there done what I am trying to do?

> Q4. Am I on the right track?

> Thanks for any info.
> --
> Walter Lolham  |  Genasys Systems Pty Ltd
>                |  13th Level, 33 Berry St, North Sydney, NSW, Australia
>                |  Phone:  +61-2-9926-2800 (-2888 FAX)


--
Matt Alderson    GIS Specialist   . Arizona Game and Fish Department

voice-mail: (602) 789-3610        . Phoenix, AZ 85023         U.S.A.
 
 
 

1. keymap problem with envizex II terminals

I have noticed an odd bug -- or misconfiguration -- but I
need to resolve this.  I am running Mandrake 8.2 running
on a Dell Dimension, serving X to Envizex II X-Terminals.

I have Envizex II X-terminals that work fine with Gnome 1.4,
but when I run KDE 2.0, I notice that the right arrow key
will cause the K-menu to pop-up.  To turn this off, I
went to Configuration->KDE->Look and Feel->Key Bindings.
Then I choose scheme = unix default, then press apply, then OK.

This solves the problem of the K-menu popping up, but
then the right arrow key does nothing.

Again, this is not a problem in Gnome 1.4, but as
I find KDE to be preferable to Gnome, I would like
to fix this.  Any ideas?

--BKH

(remove .nospam and nospam. from address to send mail to me)

2. ====== utmp/wtmp problems ======

3. Serial port problem /digitizer; please help

4. alias

5. Redirect serial line to X-Terminal

6. etherscan, where?

7. Using serial port on Tek's X-terminals via pty

8. Linux & Kingston Ethernet Cards?

9. Need Help on Setting Up Linux As X-terminal Through Serial Line

10. Using serial port terminals

11. Using Terminal Serv as Serial ports from Sol2.4

12. using linux box as a terminal threw the serial port can this be done

13. Using unix serial ports (to hook up terminals)