slirp: Connect Problems

slirp: Connect Problems

Post by Darren D Bo » Wed, 09 Aug 1995 04:00:00



I am having some trouble getting slirp to work properly.  I have
gotten everything to work but I see no results.  When I ftp into a
remote machine I see the login prompt and then the password prompt,
after that nothing.

The same thing happens with telnet.

When I get back to a terminal prompt and try to send my five zeros to
deavtivate slirp, it gives me an I/O error.

Any advice or opinions would be great.

Thanks,
Darren

--

University of Saskatchewan      |     http://www.cs.usask.ca/~ddb132/
Saskatoon Linux Group           | http://www.cs.usask.ca/~ddb132/slg/
--------------------------------|------------------------------------
        "Common sense is not so common."
                                Voltaire

 
 
 

slirp: Connect Problems

Post by Kisoo Li » Fri, 11 Aug 1995 04:00:00


Use the latest version;0.95d
You use dip script?
I use ppp option which dosc are included in README.ppp.
I connect by kermit and then I activate slirp on remote.
Back to kermit using ^\+c,suspend kermit and finally
pppd /dev/modem 19200 defaultroute
It works great now.
--
Kisoo Lim
http://bora.dacom.co.kr/~mstar

Seoul,Korea

 
 
 

1. PPP+SLiRP OK but CSLIP+SLiRP has display problem

I have slirp PPP running with DXPC compression but I was told
that CSLIP is faster than PPP. I have a Linux PC as server and a
Sun Sparc5 as client. I use a dip script to login and and
activate SLIRP on the Sun. The .slirprc file is:
##############################
add ptyexec /usr/bin/tcsh -1:10.0.2.1:23
compress
baudrate 38400
[I have tried adding the following:
redir X 10.0.2.15:0.0
redir 4000 4000
with no improvement]
############################
     The problem is that after giving xhost + to an xterm window
on the local Linux machine, I cannot find a setenv statement
that allows me to show Sun X programs on the local machine. If I
telnet to 10.0.2.0 to get the SLIRP command line: "show X"
it says use: "setenv DISPLAY [Sun IP adderess]:1.0" for the
display of the Sun command line. Testing with "xclock &" does not
bring up the X program on the screen. There is an error message:
"Unable to open [Sun IP address]:1.0" and also for :2, :8 etc.
aliases like 10.0.2.2 also do not work. Nor does the default:
"setenv DISPLAY :8"
     Has anybody got SLIRP CSLIP to work properly?
Thanks, Don

cslippro.asc
--
Donald F. Parsons MD, Wadsworth Ctr, (Rm D224A)
PO Box 509, Albany, NY 12201-0509. (518)474-7047 Fax: (518)474-7992


2. PCMCIA woes: Xircom card

3. Slirp Slirp

4. VXP - Motif GUI Builder

5. Slirp: Dial with minicom to shell then telnet to other shell to use slirp?

6. Slackware 3.0 - X hangs on <ctl> <alt> <f1> to console and back

7. Slirp Slirp

8. Perfect X environment

9. SliRp/Minicom: Starting Slirp through minicom?

10. How To connect to SLIRP server?

11. Cannot connect to slirp with linux

12. Slirp: how to connect?

13. PPP connecting to shell account /w SLiRP?