3c509 Refuses to work under Linux (the other nic also refuses)

3c509 Refuses to work under Linux (the other nic also refuses)

Post by Marino Simon » Mon, 13 Apr 1998 04:00:00



Hello,

I have problems getting my netwerk running under Linux (Slackware 3.4,
kernel 2.0.30)
First I tried it on my P187MMX with an RPCI Ethernet card, sits in the
PCI-slot.  No luck,  I tried starting it with insmod ne io=0xd400 (adress
shown in Win 95 and shown in Linux with cat blahbla)
However when I try insmod ne io=x0d400, the whole system freezes (who said
Linux didn't crash :))) )
So after try 1 day I turned my attention to my old trusty 486 DX4, which
should be running Linux one day (as internet gateway, fileserver etc)
The DX4 has 24mb, 800mb hdd (at the moment 250 dedicated to Linux, as it has
to run Win98 to get me on the internet) and a 3com 3C509b.
But Linux won't detect the card, it's an isa card in a VLB-machine (legacy).
The whole stuff works great under Win98 (otherwise I couldn't print or get
on the internet)
Does someone have any suggestions: on the 486 I tried to recombile the
kernel with only support for a 3c509 but without success.
Some story for the P187 I tried to recompile the kernel with only ne2000
support but no success.
I am new to Linux scene so I must be missing something, question is what


Thanks

 
 
 

3c509 Refuses to work under Linux (the other nic also refuses)

Post by wu.qi.. » Mon, 13 Apr 1998 04:00:00



> Hello,

> I have problems getting my netwerk running under Linux (Slackware 3.4,
> kernel 2.0.30)
> First I tried it on my P187MMX with an RPCI Ethernet card, sits in the
> PCI-slot.  No luck,  I tried starting it with insmod ne io=0xd400 (adress
> shown in Win 95 and shown in Linux with cat blahbla)
> However when I try insmod ne io=x0d400, the whole system freezes (who said
> Linux didn't crash :))) )
> So after try 1 day I turned my attention to my old trusty 486 DX4, which
> should be running Linux one day (as internet gateway, fileserver etc)
> The DX4 has 24mb, 800mb hdd (at the moment 250 dedicated to Linux, as it has
> to run Win98 to get me on the internet) and a 3com 3C509b.
> But Linux won't detect the card, it's an isa card in a VLB-machine (legacy).
> The whole stuff works great under Win98 (otherwise I couldn't print or get
> on the internet)
> Does someone have any suggestions: on the 486 I tried to recombile the
> kernel with only support for a 3c509 but without success.
> Some story for the P187 I tried to recompile the kernel with only ne2000
> support but no success.
> I am new to Linux scene so I must be missing something, question is what


> Thanks

You must set the 3c509 card to No-PNP mode!
OK!
Please try again!

 
 
 

3c509 Refuses to work under Linux (the other nic also refuses)

Post by Eugene Blanchar » Mon, 13 Apr 1998 04:00:00



> Hello,

> I have problems getting my netwerk running under Linux (Slackware 3.4,
> kernel 2.0.30)
> First I tried it on my P187MMX with an RPCI Ethernet card, sits in the
> PCI-slot.  No luck,  I tried starting it with insmod ne io=0xd400 (adress
> shown in Win 95 and shown in Linux with cat blahbla)
> However when I try insmod ne io=x0d400, the whole system freezes (who said
> Linux didn't crash :))) )
> So after try 1 day I turned my attention to my old trusty 486 DX4, which
> should be running Linux one day (as internet gateway, fileserver etc)
> The DX4 has 24mb, 800mb hdd (at the moment 250 dedicated to Linux, as it has
> to run Win98 to get me on the internet) and a 3com 3C509b.
> But Linux won't detect the card, it's an isa card in a VLB-machine (legacy).
> The whole stuff works great under Win98 (otherwise I couldn't print or get
> on the internet)
> Does someone have any suggestions: on the 486 I tried to recombile the
> kernel with only support for a 3c509 but without success.
> Some story for the P187 I tried to recompile the kernel with only ne2000
> support but no success.
> I am new to Linux scene so I must be missing something, question is what


> Thanks

In DOS (uggh!) use pnpdsabl.bat on the 3c509 card to disable the PnP.
Next manually configure your card using the 3c5x9cfg.exe program to
IRQ10 Base 300. It will work. If you leave the PnP enabled, Windoze may
change the card configuration if you are using LILO.
 
 
 

1. Telnet refused to my machine but all others work, help!

I am running linuxppc-1999 on a StarMax 3000/240. i
am on a cable modem.  all INET services and
otherwise work when a remote system tries to
connect but with telnet, the connection is refused
even before it gets to the login prompt. it says :

"unable to connect to remote host: connection
refused."

when i type 'in.telnetd' in the command prompt, it
says:

"in.telnetd: getpeername: socket operation on non-
socket"

how can i get telnet to work?  i have rebooted the
machine, restarted inet many times and network
too...please help...any suggestions would be
appreciated.  thanx.

Rick

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

2. Sendmail integration question

3. localhost connections refused, others fine, RH 3.03

4. Getting the wheel to work on mouse

5. NCurses progs refuse cooperation with others?

6. Problems Installing an ATI XPERT 98

7. gdm refuses to work (but xdm does work)

8. Virtual Hosting w/ user directories.

9. Fuji FinePix 1400z (mass storage) camera refuses to work under linux.

10. 3com 3c509 NIC not working in linux

11. 3Com 3c509 NIC not working in linux

12. logitech mouse refuses to work

13. sendmail refuses to work