HELP: SMC EtherEZ woes

HELP: SMC EtherEZ woes

Post by Bernard CE » Thu, 09 May 1996 04:00:00



Hi Linux Network Gurus!

I'd really appreciate some help on this one.
I am running RedHat Linux v.3.0.3 on several machines and got networking
working really easily (using RedHat's control panel gizmo) on machines using
NE2000 compatible cards.
I also have a Pentium with a an SMC EtherEZ card, which just doesn't want to
play ball. It gets detected by the kernel, I set up the TCP/IP stuff properly,
but all it does is spews errors at me.
I'm using kernel v.1.3.85, because I have an Adaptec 2940 on this machine
(the other machines are also running the same kernel version with no problems).
The card works fine under Windoze95. The parameters the kernel detects are
fine (no IRQ or ioport conflict - same as those under Windoze), but the only
thing that worries me is the the kernel shows the card at port 0x280 and
ifconfig shows it at 0x290 ?
Any help would be greatly appreciated - please also email your replies to me
as well as following up in the news group.
Cheers,
Bernard Cena

Here are all the dumps of the important stuff...

First the kernel messages on boot:

Nov 13 11:45:32 conchiglia kernel: smc-ultra.c:v1.12 1/18/95 Donald Becker (beck

Nov 13 11:45:32 conchiglia kernel: eth0: SMC EtherEZ at 0x280, 00 00 C0 7C 42 D2
, IRQ 7 memory 0xc0000-0xc1fff.
Nov 13 11:45:32 conchiglia kernel: Partition check:
Nov 13 11:45:32 conchiglia kernel:  sda: sda1 sda2 sda3 < sda5 sda6 sda7 sda8 >
Nov 13 11:45:32 conchiglia kernel: VFS: Mounted root (ext2 filesystem) readonly.
Nov 13 11:45:32 conchiglia kernel: Adding Swap: 104416k swap-space
Nov 13 11:45:57 conchiglia login: ROOT LOGIN ON tty1

The following are messages after I bring the net up:
Nov 13 11:47:24 conchiglia kernel: eth0: bogus packet size: 2071, status=0x15 nx
pg=0x16.
Nov 13 11:47:38 conchiglia kernel: eth0: bogus packet size: 12318, status=0x1e n
xpg=0x30.
Nov 13 11:47:38 conchiglia kernel: eth0: next frame inconsistency, 0x30
Nov 13 11:47:44 conchiglia kernel: Socket destroy delayed (r=0 w=252)
Nov 13 11:47:44 conchiglia kernel: Socket destroy delayed (r=0 w=252)
Nov 13 11:47:46 conchiglia kernel: eth0: bogus packet size: 12318, status=0x1e n
xpg=0x30.
Nov 13 11:47:46 conchiglia kernel: eth0: next frame inconsistency, 0x30
The above repeat themselves ad infinitum.

output of ifconfig:
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
          UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0
          TX packets:16 errors:0 dropped:0 overruns:0

eth0      Link encap:10Mbps Ethernet  HWaddr 00:00:C0:7C:42:D2
          inet addr:130.95.1.242  Bcast:130.95.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:1040 dropped:0 overruns:0
          TX packets:28 errors:0 dropped:0 overruns:0
          Interrupt:7 Base address:0x290 Memory:c0000-c2000

output of route:
Kernel routing table
Destination   Gateway      Genmask         Flags MSS   Window Use Iface
130.95.1.0    *            255.255.255.0   U     1500  0        3 eth0
loopback      *            255.0.0.0       U     3584  0        2 lo
(hangs for about a minute or so)
default       130.95.1.41  *               UG    1500  0        1 eth0

/proc/version

15:13:53 WST 1995

/proc/interrupts
 0:    61295   timer
 1:      602   keyboard
 2:        0   cascade
 4:     5958 + serial
 6:       10 + floppy
 7:      705   SMC EtherEZ
12:     3194 + aic7xxx
13:        0   math error

/proc/ioports
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : kbd
0070-007f : rtc
0080-009f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : npu
0280-029f : SMC EtherEZ
02f8-02ff : serial(auto)
0378-037f : lp
03c0-03df : vga+
03f0-03f5 : floppy
03f7-03f7 : floppy DIR
03f8-03ff : serial(auto)
6c00-6cbe : aic7xxx

/proc/net/dev
Inter-|   Receive                  |  Transmit
 face |packets errs drop fifo frame|packets errs drop fifo colls carrier
    lo:     16    0    0    0    0       16    0    0    0     0    0
  eth0:      0  881    0    0    0       26    0    0    0     0    0

/proc/net/route
Iface   Destination     Gateway         Flags   RefCnt  Use     Metric  Mask
        MTU     Window  IRTT

eth0    00015F82        00000000        01      0       2       0       00FFFFFF
        1500    0       0

lo      0000007F        00000000        01      0       2       0       000000FF
        3584    0       0

eth0    00000000        29015F82        03      0       1       1       00000000
        1500    0       0

--------"Patience, great things are afoot." - Slartibartfast--------

Department of Computer Science       /      \    tel: +61 9 380 3778
The University of Western Australia  *_.--._/    fax: +61 9 380 1089
Nedlands, 6907, WA, Australia              v    home: +61 9 337 8389
---------------------------------- http://www.cs.uwa.edu.au/~bernard

--

Department of Computer Science       /      \    tel: +61 9 380 3778
The University of Western Australia  *_.--._/    fax: +61 9 380 1089
Nedlands, 6907, WA, Australia              v    home: +61 9 337 8389

 
 
 

HELP: SMC EtherEZ woes

Post by Paul Gortmak » Thu, 09 May 1996 04:00:00



>Hi Linux Network Gurus!
>I'd really appreciate some help on this one.
>I am running RedHat Linux v.3.0.3 on several machines and got networking
>working really easily (using RedHat's control panel gizmo) on machines using
>NE2000 compatible cards.
>I also have a Pentium with a an SMC EtherEZ card, which just doesn't want to
>play ball. It gets detected by the kernel, I set up the TCP/IP stuff properly,
>but all it does is spews errors at me.

[...]

>First the kernel messages on boot:

>Nov 13 11:45:32 conchiglia kernel: eth0: SMC EtherEZ at 0x280, 00 00 C0 7C 42 D2
>, IRQ 7 memory 0xc0000-0xc1fff.

Whoa, alarm bells should be going off here. Note that 0xC0000 is where most
VGA cards have their ROM located. You can't expect things to work like that.
If you have the EtherEZ enabled for PIO mode, then use the PIO driver that
is in v1.3.99 (a 1.2.13 version is also avail. on Donald's WWW site as listed
in the Ethernet-HowTo). Otherwise, move the shared mem location to a
non-conflicting address, like 0xD0000 or 0xE0000.

Quote:>The following are messages after I bring the net up:
>Nov 13 11:47:24 conchiglia kernel: eth0: bogus packet size: 2071, status=0x15 nx
>pg=0x16.
>Nov 13 11:47:38 conchiglia kernel: eth0: bogus packet size: 12318, status=0x1e n
>xpg=0x30.
>Nov 13 11:47:38 conchiglia kernel: eth0: next frame inconsistency, 0x30

These errors come about because the driver is reading your VGA ROM and
not the memory on the ethernet card.

Quote:>eth0      Link encap:10Mbps Ethernet  HWaddr 00:00:C0:7C:42:D2
>          inet addr:130.95.1.242  Bcast:130.95.1.255  Mask:255.255.255.0
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:0 errors:1040 dropped:0 overruns:0

                        ^^^^^^^^^^^
No packets are received, because of the memory conflict.

Paul.

 
 
 

1. SMC 83c795 (EtherEZ) and SMC Ultra driver

I'm trying to get an SMC EtherEZ card (83c795) to run under kernel 2.0.32.
I've made a kernel that has the SMC Ultra driver in it but it won't
recognize my card, even if I pass in the IRQ and I/O base from lilo.

The card is running on IRQ 11 and I/O 240.
I'm using a 486 SX/33 with Redhat 5, and there are no other cards in the
system (save the gfx card).

The Enternet-HOWTO mentioned some sort of SMC Ultra compatibility mode for
the EtherEZ cards, but I can't find a jumper on the card, I have no
documentation, and no software to configure it. (thanks to those PnP
bastards)

Any ideas?

2. CDrom

3. Help with Ethernet SMC EtherEZ

4. Unable to manage Volume Group

5. SMC-EtherEZ(Ultra) giving "bogus packet size" HELP, PLEASE!

6. compiling kdebase1.1

7. Help on SMC-EtherEZ card, please

8. AIX 5.1L on a 43P Model 150 - cannot install!!!

9. help on SMC EtherEz(8416t)

10. Need help with the SMC EtherEz

11. Help: SMC EtherEZ SMC8416T card

12. Help! Install with SMC EtherEZ

13. Need help with SMC EtherEZ ethernet card setup...please read :)