Please help ! Linux - PPP (routed??)

Please help ! Linux - PPP (routed??)

Post by Albe » Wed, 04 Sep 1996 04:00:00



I am newbie. I started up my Linux communication recently and encounter the following problem.

I am using linux version 1.3.20, PPP-2.1.2, DIP 3.3.7n.

-----------------------------------------------------------

The followings are from /usr/var/messages:

Aug 30 15:15:48 macnock chat[275]: send (ATM1X4DT2739400^M)
Aug 30 15:15:48 macnock chat[275]: expect (CONNECT)
Aug 30 15:15:48 macnock chat[275]: ATM1X4DT2739400
Aug 30 15:16:06 macnock chat[275]: CONNECT -- got it
Aug 30 15:16:06 macnock chat[275]: send (^M)
Aug 30 15:16:06 macnock chat[275]: expect (sername:)
Aug 30 15:16:06 macnock chat[275]:  14400/ARQ/V32/LAPM/V42BIS
Aug 30 15:16:07 macnock chat[275]: BRF56-Jaring line 10 Dialup: 03-2738560 (hunting)
Aug 30 15:16:07 macnock chat[275]: User Access Verification
Aug 30 15:16:07 macnock chat[275]: Username: -- got it
Aug 30 15:16:07 macnock chat[275]: send (cchinkm^M)
Aug 30 15:16:07 macnock chat[275]: expect (ssword:)
Aug 30 15:16:07 macnock chat[275]:  cchinkm
Aug 30 15:16:07 macnock chat[275]: Password: -- got it
Aug 30 09:34:07 macnock chat[275]: send (????????^M)
Aug 30 09:34:54 macnock pppd[199]: pppd 2.1.2 started by root, uid 0
Aug 30 09:34:54 macnock kernel: ppp: channel ppp0 mtu = 1500, mru = 1500
Aug 30 09:34:54 macnock kernel: ppp: channel ppp0 open
Aug 30 09:34:54 macnock pppd[199]: set kernel debugging level to 0
Aug 30 09:34:54 macnock pppd[199]: Using interface ppp0
Aug 28 09:34:54 macnock pppd[199]: Connect: ppp0 <--> /dev/cua1
Aug 30 09:35:24 macnock kernel: ppp_ioctl: set debug level 2, netpacket 0
Aug 30 09:35:24 macnock kernel: ppp: channel ppp0 going down for IP packets!
Aug 30 09:35:24 macnock kernel: ppp: channel ppp0 closing.
Aug 30 09:35:24 macnock pppd[199]: Connection terminated.
Aug 30 09:35:24 macnock pppd[199]: set kernel debugging level to 2
Aug 30 09:35:24 macnock pppd[199]: Exit.

----------------------------------------------------------------------

Every times after dialing, the line is being cut off in about 30 seconds. I don't
know why. I had tried PPP and DIP but I still get the same thing.

I am sure I have passed thru login and passwd session.

Here I discover something. The manual page for 'routed' as below:

     Hosts acting as internetwork routers gratuitously supply their routing
     tables every 30 seconds to all directly connected hosts and networks.
     The response is sent to the broadcast address on nets capable of that
     function, to the destination address on point-to-point links, and to the
     router's own address on other networks.  The normal routing tables are
     bypassed when sending gratuitous responses.  The reception of responses
     on each network is used to determine that the network and interface are
     functioning correctly.  If no response is received on an interface, an-
     other route may be chosen to route around the interface, or the route may
     be dropped if no alternative is available.

Do you think I encounter the above problem? B'cos every time after I connect to jaring,
the line is cut off in exactly 30 seconds.

---> 09:34:54 macnock pppd[199]: Connect: ppp0 <--> /dev/cua1
---> 09:35:24 macnock kernel: ppp_ioctl: set debug level 2, netpacket 0

If this is the case, do anyone out there has any suggestion what i am going to do the next? Please help.

Your helps are appreciated.
Thanks in advances.

Albert
.end.