'serial line is looped back' causes ppp connection to drop - help...

'serial line is looped back' causes ppp connection to drop - help...

Post by Martin Walle » Sat, 28 Feb 1998 04:00:00



Hi,

    I've just put some new disks in my computer and upgraded (from
scratch - new disks) from debian 1.2 to 1.3.1.

    When using my modem to dial in to my ISP, it dials in fine, I get
authenticated etc.

    After the authentictaion bit in /var/log/ppp.log I get:

<authentication stuff>
.
ppp0 <---> /dev/cua1
.
.
serial line is looped back.
connection terminated

I don't know what this means, so haven't a clue what to do about it.

I have an internal 14.400 modem on COM2 which had no problems
previously.

On boot up, /dev/ttys0 and /dev/ttys1 are recognised (16550A UART).

After initial installation, the /dev/cuaN devices weren't there so I
mafe them (cua0 and cua1) with MAKEDEV.

setserial /dev/ttys1 gives:

ttys0: I/O error.

I am flummoxed as the error messages mean nothing to me.

My loopback device (lo) is set up correctly I believe (it shows up OK
with ifconfig as 127.0.0.1).

What's up?  I can't  get to the net from home until this is sorted...

Thanks for any help,

    Martin

 
 
 

'serial line is looped back' causes ppp connection to drop - help...

Post by Brian McCaule » Sat, 28 Feb 1998 04:00:00



>     After the authentictaion bit in /var/log/ppp.log I get:

> <authentication stuff>
> .
> ppp0 <---> /dev/cua1
> .
> .
> serial line is looped back.
> connection terminated

> I don't know what this means,

It means that /de/cua1 is not connected to a PPP server but rather to
an echo.  Could be it's connected to a terminal server, a dial-up
shell account, an modem in command mode, a paper-clip...

Try the steps in your chat script by hand using a terminal emmulator
and see what you find yourself connected to.

--

 .  _\\__[oo       from       | Phones: +44 121 471 3789 (home)

.  l___\\    /~~) /~~[  /   [ | PGP-fp: D7 03 2A 4B D8 3A 05 37...
 # ll  l\\  ~~~~ ~   ~ ~    ~ | http://wcl-l.bham.ac.uk/~bam/


 
 
 

1. PPP & 'serial line looped back'

Hello

I've spent nearly a week with my linux 2.0.21 and pppd 2.2.0f and I
haven't been able to make it work. After reading the Howto's and testing
almost everything, when I run 'pppd -d ....' after reading the log i
always get the same message :
...some 'sent[...]' & 'rcvd[...]' and then
' Serial line is looped back '

I think my modem is repeting whatever the Pc is sending him,
my ISP needs pap authentification and i hane the pap-secrets, I've
modified the resolv.conf with data from the ISP, but im afraid that
i'm not reaching so far :-(

Thanks in advance
/Luis

2. Success at last.

3. help on ppp: Serial line is looped back

4. Looking for people's opinions on "Rock Linux" for Alpha

5. Serial line looped back; connection terminated

6. Survey about future Sun keyboards and mice

7. ppp-serial line looped backed

8. New Introductory Security Paper

9. PPP: Serial line looped back...

10. ppp - Serial line is looped back

11. PPP problem : Serial line is looped back

12. ppp --> isp : serial line looped back

13. PPP- serial line is looped back