Help needed connecting to Non-MS-CHAP NT RAS with PPP - E=691

Help needed connecting to Non-MS-CHAP NT RAS with PPP - E=691

Post by Malcolm Fergus » Sun, 25 Jul 1999 04:00:00



A recent server upgrade has left me unable to connect to our NT RAS at
work.  Our Network Admin backed off the security for us so that it
wasn't insisting on MS-CHAP 80, but I still can't connect.  Can anybody
help me?

Below I've included the syslog pppd debug messages (username and
password '*'ed out) from my attempts using CHAP and PAP.  As you can
see, the RAS initially challenges with "auth chap 80", but accepts my
request for "auth pap".  However, it does not accept my username and
password, returning hardware error "E=691".  Why?  I can connect from NT
and 95.

I'm using Mandrake 6.0 (based on Red Hat 6.0???) and pppd version 2.3.7.

Connection using PAP:

Connect: ppp0 <--> /dev/ttyS1
sent [LCP ConfReq id=0x1<asyncmap 0x0> <magic 0x9332fb4c> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap 80> <magic 0xbb0>
<pcomp> <accomp>]
sent [LCP ConfNak id=0x0 <auth pap>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x9332fb4c> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0xbb0> <pcomp>
<accomp>]
sent [LCP ConfAck id=0x1 <asyncmap 0x0> <auth pap> <magic 0xbb0> <pcomp>
<accomp>]
sent [PAP AuthReq id=0x1 user="********" password="********"]
sent [PAP AuthReq id=0x2 user="********" password="********"]
rcvd [PAP AuthNak id=0x1 "E=691"]
Remote message: E=691
PAP authentication failed
rcvd [LCP TermReq id=0x2 00 00 02 b3]

sent [LCP TermAck id=0x2]
Hangup (SIGHUP)
Modem hangup
Connection terminated.

Connection using CHAP:

sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xedbb9a76> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap 80> <magic 0x674d>
<pcomp> <accomp>]
sent [LCP ConfNak id=0x0 <auth chap MD5>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xedbb9a76> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth 0xc027 01 00 00 01> <magic
0x674d> <pcomp> <accomp>]
sent [LCP ConfNak id=0x1 <auth chap MD5>]
rcvd [LCP ConfReq id=0x2 <asyncmap 0x0> <auth 0xc123 01 00 00 01> <magic
0x674d> <pcomp> <accomp>]
sent [LCP ConfNak id=0x2 <auth chap MD5>]
rcvd [LCP ConfReq id=0x3 <asyncmap 0x0> <auth pap> <magic 0x674d>
<pcomp> <accomp>]
sent [LCP ConfNak id=0x3 <auth chap MD5>]
rcvd [LCP ConfReq id=0x4 <asyncmap 0x0> <auth pap> <magic 0x674d>
<pcomp> <accomp>]
sent [LCP ConfNak id=0x4 <auth chap MD5>]
rcvd [LCP ConfReq id=0x5 <asyncmap 0x0> <auth pap> <magic 0x674d>
<pcomp> <accomp>]
sent [LCP ConfRej id=0x5 <auth pap>]
rcvd [LCP TermReq id=0x6 00 00 02 dc]
sent [LCP TermAck id=0x6]
Hangup (SIGHUP)

 
 
 

Help needed connecting to Non-MS-CHAP NT RAS with PPP - E=691

Post by Keith Brow » Sun, 25 Jul 1999 04:00:00



> A recent server upgrade has left me unable to connect to our NT RAS at
> work.  Our Network Admin backed off the security for us so that it
> wasn't insisting on MS-CHAP 80, but I still can't connect.  Can anybody
> help me?

> Below I've included the syslog pppd debug messages (username and
> password '*'ed out) from my attempts using CHAP and PAP.  As you can
> see, the RAS initially challenges with "auth chap 80", but accepts my
> request for "auth pap".  However, it does not accept my username and
> password, returning hardware error "E=691".  Why?  I can connect from NT
> and 95.

> I'm using Mandrake 6.0 (based on Red Hat 6.0???) and pppd version 2.3.7.

> Connection using PAP:

> Connect: ppp0 <--> /dev/ttyS1
> sent [LCP ConfReq id=0x1<asyncmap 0x0> <magic 0x9332fb4c> <pcomp>
> <accomp>]
> rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap 80> <magic 0xbb0>
> <pcomp> <accomp>]
> sent [LCP ConfNak id=0x0 <auth pap>]
> rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x9332fb4c> <pcomp>
> <accomp>]
> rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0xbb0> <pcomp>
> <accomp>]
> sent [LCP ConfAck id=0x1 <asyncmap 0x0> <auth pap> <magic 0xbb0> <pcomp>
> <accomp>]
> sent [PAP AuthReq id=0x1 user="********" password="********"]
> sent [PAP AuthReq id=0x2 user="********" password="********"]
> rcvd [PAP AuthNak id=0x1 "E=691"]
> Remote message: E=691
> PAP authentication failed
> rcvd [LCP TermReq id=0x2 00 00 02 b3]

> sent [LCP TermAck id=0x2]
> Hangup (SIGHUP)
> Modem hangup
> Connection terminated.

> Connection using CHAP:

> sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xedbb9a76> <pcomp>
> <accomp>]
> rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap 80> <magic 0x674d>
> <pcomp> <accomp>]
> sent [LCP ConfNak id=0x0 <auth chap MD5>]
> rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xedbb9a76> <pcomp>
> <accomp>]
> rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth 0xc027 01 00 00 01> <magic
> 0x674d> <pcomp> <accomp>]
> sent [LCP ConfNak id=0x1 <auth chap MD5>]
> rcvd [LCP ConfReq id=0x2 <asyncmap 0x0> <auth 0xc123 01 00 00 01> <magic
> 0x674d> <pcomp> <accomp>]
> sent [LCP ConfNak id=0x2 <auth chap MD5>]
> rcvd [LCP ConfReq id=0x3 <asyncmap 0x0> <auth pap> <magic 0x674d>
> <pcomp> <accomp>]
> sent [LCP ConfNak id=0x3 <auth chap MD5>]
> rcvd [LCP ConfReq id=0x4 <asyncmap 0x0> <auth pap> <magic 0x674d>
> <pcomp> <accomp>]
> sent [LCP ConfNak id=0x4 <auth chap MD5>]
> rcvd [LCP ConfReq id=0x5 <asyncmap 0x0> <auth pap> <magic 0x674d>
> <pcomp> <accomp>]
> sent [LCP ConfRej id=0x5 <auth pap>]
> rcvd [LCP TermReq id=0x6 00 00 02 dc]
> sent [LCP TermAck id=0x6]
> Hangup (SIGHUP)

Hi Malcolm,

I've also been dialing into an NT  RAS server at work. I'm using Mandrake
5.2 and kppp with CHAP.  I tried Mandrake 6.0 and could not make CHAP work
at all.  I was forced to go back to 5.2 so I could dial into work from
home.

--
Keith Brown