rp-pppoe

rp-pppoe

Post by Thomas » Sat, 31 Aug 2002 18:52:15



I have installed Redhat 7.3, RP-PPPOE has already been installed
during Redhat installation.

I have run adsl-setup, ifcfg- file is generated in network-scripts directory

But when I adsl-start, nothing happens.
when I adsl-status, it shows the error:

# adsl-start
# adsl-status
/sbin/adsl-status: Cannot read configuration file '/etc/ppp/pppoe.conf'

 
 
 

rp-pppoe

Post by Repo » Sat, 31 Aug 2002 20:17:03



> I have installed Redhat 7.3, RP-PPPOE has already been installed
> during Redhat installation.

> I have run adsl-setup, ifcfg- file is generated in network-scripts
> directory

> But when I adsl-start, nothing happens.
> when I adsl-status, it shows the error:

> # adsl-start
> # adsl-status
> /sbin/adsl-status: Cannot read configuration file '/etc/ppp/pppoe.conf'

try to install the latest version.
http://www.roaringpenguin.com/pppoe/
--
Repo
http://beginnerslinux.org
http://repo.mine.nu

 
 
 

rp-pppoe

Post by Hal Burgis » Sat, 31 Aug 2002 21:30:45



Quote:> I have installed Redhat 7.3, RP-PPPOE has already been installed
> during Redhat installation.

> I have run adsl-setup, ifcfg- file is generated in network-scripts directory

> But when I adsl-start, nothing happens.
> when I adsl-status, it shows the error:

> # adsl-start
> # adsl-status
> /sbin/adsl-status: Cannot read configuration file '/etc/ppp/pppoe.conf'

IIRC, RH mangled all this so that it fit into their configuration. I
suspect if properly setup, you should be able to do a 'service network
start', and in theory it should work. See the rp-pppoe home page for his
thoughts on RH's "innovations".

--
Hal Burgiss

 
 
 

rp-pppoe

Post by Bill Unr » Sun, 01 Sep 2002 02:24:10


]I have installed Redhat 7.3, RP-PPPOE has already been installed
]during Redhat installation.

]I have run adsl-setup, ifcfg- file is generated in network-scripts directory

]But when I adsl-start, nothing happens.
]when I adsl-status, it shows the error:

]# adsl-start
]# adsl-status
]/sbin/adsl-status: Cannot read configuration file '/etc/ppp/pppoe.conf'

Well, that seems pretty clear to me. It cannot read /etc/ppp/pppoe.conf.
Does the file exist? If it does does it have permissions which allow it
to be read?

 
 
 

rp-pppoe

Post by Sonnis » Sun, 01 Sep 2002 11:16:58


I had the same problem when I tried to use the version of RP that came w/
RH. Everytime I rebooted I had to go through a service restart and then
reconfig adsl.

I searched for and renamed all the old RP version stuff and compiled the
latest version. Works fine now.

You also should add an xdsl connector using network config tool (KDE control
panel, if that's the gui you're using.) it'll end up being ppp0 or
something, then run adsl-setup.

Sonnish



Quote:> I have installed Redhat 7.3, RP-PPPOE has already been installed
> during Redhat installation.

> I have run adsl-setup, ifcfg- file is generated in network-scripts
directory

> But when I adsl-start, nothing happens.
> when I adsl-status, it shows the error:

> # adsl-start
> # adsl-status
> /sbin/adsl-status: Cannot read configuration file '/etc/ppp/pppoe.conf'

 
 
 

rp-pppoe

Post by Raqueeb Hass » Mon, 02 Sep 2002 11:58:23


well, better to get the latest rpm from the rp-pppoe site. set that up
with adsl-setup script or read that famous HOW-TO-CONNECT file with
rp-pppoe.

hth

raqueeb hassan
bangladesh

 
 
 

1. RH8.0 bundled rp-pppoe (rp-pppoe-3.4-7) problem, please help.

Hello,

I have a problem in RH8.0 bundled rp-pppoe (rp-pppoe-3.4-7), please
help.

I am setting up linux server as NAT, which share t he internet
connection to the client PCs at home. I was using RH7.2 before and
there is no problem at all. My problem in RH8.0 is that: I setup
rp-pppoe (ifup ppp0) to run at startup of the machine. Basically, it
starts up without any problem at all. But, it never runs
/etc/ppp/ip-up. Which means that the ip masquerading process didn't
bring up at all. What I have to is to ssh to the server everytime
after the server boots up and run /etc/ppp/ip-up manually, before my
clients can use the internet connect. I realized that the
configurations files are quite different from the one that I was using
in 7.2, e.g it doesn't use /etc/ppp/pppoe.conf anymore, instated it
put all the information in
/etc/ppp/sysconfig/network-scripts/ifcfg-ppp0.

Anybody can give me some suggestions ?
Thanks
Bosco

2. DNS, Solaris 2.5.1, and a human who is about to give up

3. rp-pppoe 3.1 -- Robust PPPoE suite for Linux

4. subnote success, Novell DOS 7 + Slackware

5. rp-pppoe 3.3 -- Robust PPPoE client for Linux, NetBSD, and Solaris

6. Where can I get Linux?

7. SuSE 7.3 kernel pppoe vs. rp-pppoe

8. sendfile() equivalent in Solaris and SunOS?

9. rp-pppoe 3.2 -- Robust PPPoE suite for Linux

10. Need explanation of LCP_INTERVAL and computing PPPOE_TIMEOUT w/ RP-PPPoE

11. Getting pmfirewall,rp-pppoe and squid to work together

12. rp-pppoe and Corel SE

13. rp-pppoe, Verizon DSL, and firewall confusion