Upgrading kernel from 2.0 -> 2.2 broke PPP

Upgrading kernel from 2.0 -> 2.2 broke PPP

Post by Marcin Romaszewic » Sun, 09 May 1999 04:00:00



Hi All,

I've upgraded my kernel from 2.0.36 to the latest 2.2, and I can no
longer use pppd (with a simple chat script) to establish connections.
The modem dials in, a PPP connection is established, but no ppp0 device
is created, nor do I get entries in the routing table.

I can manually add interface ppp0 and make it the default route, but
I would like to know what the underlying cause is. I figured that maybe
the values of some constants changed, so I recompiled pppd, and I
still see the problem (with all pppd's versions 2.2.0 and up).

Does anyone know if pppd has some dependencies which need to be
recompiled
to work with kernel 2.2.x?

Thanks in advance.
-- Marcin

 
 
 

Upgrading kernel from 2.0 -> 2.2 broke PPP

Post by Clifford Ki » Sun, 09 May 1999 04:00:00


: I've upgraded my kernel from 2.0.36 to the latest 2.2, and I can no
: longer use pppd (with a simple chat script) to establish connections.
: The modem dials in, a PPP connection is established, but no ppp0 device
: is created, nor do I get entries in the routing table.

: I can manually add interface ppp0 and make it the default route, but
: I would like to know what the underlying cause is. I figured that maybe
: the values of some constants changed, so I recompiled pppd, and I
: still see the problem (with all pppd's versions 2.2.0 and up).

You've tried them all?  The linux/Documentation/Changes file that comes
with the kernel source code from 2.1.100 up says that you need at least
ppp-2.3.5 .

I've not seen this particular problem where you can bring up the
interface manually and route manually.  I'm using the 2.1.131 kernel,
and ppp-2.2.0 fails rapidly at the IPCP PPP negotiation stage without
bringing up an interface.  It works with both ppp-2.3.5 and ppp-2.3.7 .

: Does anyone know if pppd has some dependencies which need to be
: recompiled to work with kernel 2.2.x?

There's been no mention of anything like that.

--

/* Those who can't write, write manuals. */

 
 
 

1. upgrade kernel 2.2 from kernel 2.0.x without install redhat 6.0

I installed Redhat linux 5.2 on my pc. The kernel is 2.0.36. Can I
upgrade kernel to kernel2.2 without install redhat linux 6.0 (kernel is
2.2). Which patches do I need? Where can I download?

Thanks in advance

Leon

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

2. Broken port -- apache13-ssl ?

3. Wacky 2.0->2.2 upgrade problem ftp/telnet

4. Atmel USB WLAN - Migration to Berlios Driver?

5. >>> System hangs after upgrading to kernel 2.0 <<<

6. setitimer and sleep

7. proxy blocking upgrading 2.0->2.2

8. Windows CE IR Port

9. Porting Kernel Module: 2.0.x -> 2.2.x

10. Kernel Changes 2.0.x->2.2.x????

11. Kernel upgrade [1.2.13 ==> 1.3.45] breaks PPP

12. going kernel 2.0->2.2: insmod stops working

13. for 2.2.x i386 Linux kernel DoS - Affects 2.2.x and probably 2.0.x