need help for ppp connect to NT RAS with chap

need help for ppp connect to NT RAS with chap

Post by Jem Ch » Wed, 26 Nov 1997 04:00:00



ppp-on-dialer:
  pppd /dev/cua1 connect 'chat -v "" ATDT7135250 CONNECT' 38400 \
        debug +ua chap-secrets

/etc/ppp/options:
  lock
  defaultroute
  crtscts
  noipdefault
  modem
  asyncmap 0
  debug
  /dev/modem
  name xxx
  remotename uten

/etc/ppp/chap-secrets:
  # Secrets for authentication using MS-CHAP...
  # Account     RemoteHost   Password
  xxx           *            yyy

pppd.debug.log:
  Nov 25 00:53:07 linux chat[1416]: ATDT7135250^M^M
  Nov 25 00:53:07 linux pppd[1415]: Serial connection established.
  Nov 25 00:53:07 linux chat[1416]: CONNECT -- got it
  Nov 25 00:53:08 linux pppd[1415]: Using interface ppp0
  Nov 25 00:53:08 linux pppd[1415]: Connect: ppp0 <--> /dev/cua1
  Nov 25 00:53:08 linux pppd[1415]: sent [LCP ConfReq id=0x1 <mru 1500>
  <asyncmap 0x0> <magic 0x22082019> <pcomp> <accomp>]
  Nov 25 00:53:08 linux pppd[1415]: rcvd [LCP ConfReq id=0x0 <asyncmap
  0x0> <auth chap msoft> <magic 0x3782> <pcomp> <accomp>]
  Nov 25 00:53:08 linux pppd[1415]: sent [LCP ConfNak id=0x0 <auth chap
  md5>]
  Nov 25 00:53:09 linux pppd[1415]: rcvd [LCP ConfAck id=0x1 <mru 1500>
  <asyncmap 0x0> <magic 0x22082019> <pcomp> <accomp>]
  Nov 25 00:53:09 linux pppd[1415]: rcvd [LCP ConfReq id=0x1 <asyncmap
  0x0> <auth 0xc027 01 00 00 01> <magic 0x3782> <pcomp> <accomp>]
  Nov 25 00:53:09 linux pppd[1415]: sent [LCP ConfNak id=0x1 <auth chap
  md5>]
  Nov 25 00:53:09 linux pppd[1415]: rcvd [LCP ConfReq id=0x2 <asyncmap
  0x0> <auth 0xc123 01 00 00 01> <magic 0x3782> <pcomp> <accomp>]
  Nov 25 00:53:09 linux pppd[1415]: sent [LCP ConfNak id=0x2 <auth chap
  md5>]
  Nov 25 00:53:09 linux pppd[1415]: rcvd [LCP ConfReq id=0x3 <asyncmap
  0x0> <auth 0xc123 01 00 00 01> <magic 0x3782> <pcomp> <accomp>]
  Nov 25 00:53:09 linux pppd[1415]: sent [LCP ConfNak id=0x3 <auth chap
  md5>]
  Nov 25 00:53:09 linux pppd[1415]: rcvd [LCP ConfReq id=0x4 <asyncmap
  0x0> <auth 0xc123 01 00 00 01> <magic 0x3782> <pcomp> <accomp>]
  Nov 25 00:53:09 linux pppd[1415]: sent [LCP ConfNak id=0x4 <auth chap
  md5>]
  Nov 25 00:53:09 linux pppd[1415]: rcvd [LCP ConfReq id=0x5 <asyncmap
  0x0> <auth 0xc123 01 00 00 01> <magic 0x3782> <pcomp> <accomp>]
  Nov 25 00:53:09 linux pppd[1415]: sent [LCP ConfRej id=0x5 <auth 0xc123
  01 00 00 01>]
  Nov 25 00:53:09 linux pppd[1415]: rcvd [LCP TermReq id=0x6 00 00 37 82
  00 3c cd 74 00 00 03 97]
  Nov 25 00:53:09 linux pppd[1415]: sent [LCP TermAck id=0x6]
  Nov 25 00:53:10 linux pppd[1415]: Hangup (SIGHUP)
  Nov 25 00:53:10 linux pppd[1415]: Modem hangup
  Nov 25 00:53:10 linux pppd[1415]: Connection terminated.
  Nov 25 00:53:10 linux pppd[1415]: Exit.

 
 
 

1. Help needed connecting to Non-MS-CHAP NT RAS with PPP - E=691

A recent server upgrade has left me unable to connect to our NT RAS at
work.  Our Network Admin backed off the security for us so that it
wasn't insisting on MS-CHAP 80, but I still can't connect.  Can anybody
help me?

Below I've included the syslog pppd debug messages (username and
password '*'ed out) from my attempts using CHAP and PAP.  As you can
see, the RAS initially challenges with "auth chap 80", but accepts my
request for "auth pap".  However, it does not accept my username and
password, returning hardware error "E=691".  Why?  I can connect from NT
and 95.

I'm using Mandrake 6.0 (based on Red Hat 6.0???) and pppd version 2.3.7.

Connection using PAP:

Connect: ppp0 <--> /dev/ttyS1
sent [LCP ConfReq id=0x1<asyncmap 0x0> <magic 0x9332fb4c> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap 80> <magic 0xbb0>
<pcomp> <accomp>]
sent [LCP ConfNak id=0x0 <auth pap>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x9332fb4c> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0xbb0> <pcomp>
<accomp>]
sent [LCP ConfAck id=0x1 <asyncmap 0x0> <auth pap> <magic 0xbb0> <pcomp>
<accomp>]
sent [PAP AuthReq id=0x1 user="********" password="********"]
sent [PAP AuthReq id=0x2 user="********" password="********"]
rcvd [PAP AuthNak id=0x1 "E=691"]
Remote message: E=691
PAP authentication failed
rcvd [LCP TermReq id=0x2 00 00 02 b3]

sent [LCP TermAck id=0x2]
Hangup (SIGHUP)
Modem hangup
Connection terminated.

Connection using CHAP:

sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xedbb9a76> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap 80> <magic 0x674d>
<pcomp> <accomp>]
sent [LCP ConfNak id=0x0 <auth chap MD5>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xedbb9a76> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth 0xc027 01 00 00 01> <magic
0x674d> <pcomp> <accomp>]
sent [LCP ConfNak id=0x1 <auth chap MD5>]
rcvd [LCP ConfReq id=0x2 <asyncmap 0x0> <auth 0xc123 01 00 00 01> <magic
0x674d> <pcomp> <accomp>]
sent [LCP ConfNak id=0x2 <auth chap MD5>]
rcvd [LCP ConfReq id=0x3 <asyncmap 0x0> <auth pap> <magic 0x674d>
<pcomp> <accomp>]
sent [LCP ConfNak id=0x3 <auth chap MD5>]
rcvd [LCP ConfReq id=0x4 <asyncmap 0x0> <auth pap> <magic 0x674d>
<pcomp> <accomp>]
sent [LCP ConfNak id=0x4 <auth chap MD5>]
rcvd [LCP ConfReq id=0x5 <asyncmap 0x0> <auth pap> <magic 0x674d>
<pcomp> <accomp>]
sent [LCP ConfRej id=0x5 <auth pap>]
rcvd [LCP TermReq id=0x6 00 00 02 dc]
sent [LCP TermAck id=0x6]
Hangup (SIGHUP)

2. visudo works, but not when su'd to root

3. Connecting pppd to NT server without chap/ms-chap

4. . xargs question

5. Linux PPP + NT RAS + Callback ? Help needed.

6. xman is treating me cruel

7. NT/CHAP/PPP connect

8. mod_rewrite causes load on server to JUMP

9. PPP connecting to Windows NT RAS

10. How do I get Linux PPP to connect ot NT RAS?

11. Problem with ppp and MS-CHAP connecting to a WIN NT box

12. Problems with MS-CHAP and PPP connecting to Win NT