ELM doesn't open "mailbox"?

ELM doesn't open "mailbox"?

Post by John Davis » Mon, 11 Sep 1995 04:00:00



I get the error message:

Waiting to read mailbox while mail is being received: attempt #2

when I or any of my users try to run ELM. I have no problems running ELM
from root however. I came across this problem before (a long time ago)
and can't remember what the fix was. Can someone help me refresh my
memory? :)

Any advice would be appreciated,

+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+
John Davison                        + "I think there is a world market for
San Diego State University          +  maybe five computers."

http://rohan.sdsu.edu/home/davison/ + --Thomas Watson, Chairman of IBM, 1943

 
 
 

ELM doesn't open "mailbox"?

Post by Tor Houghton (SysAdm » Mon, 11 Sep 1995 04:00:00


Could someone email me a fix for this too?

Thanks.

-----------------------------------------------------------------------------

                         | Fax 01633 811829 | Imperial House, Newport NP1 9UH
-----------------------------------------------------------------------------

 
 
 

ELM doesn't open "mailbox"?

Post by LAURENT FRIGAU » Tue, 12 Sep 1995 04:00:00


JD>I get the error message:

JD>Waiting to read mailbox while mail is being received: attempt #2

JD>when I or any of my users try to run ELM. I have no problems running ELM
  >from root however. I came across this problem before (a long time ago)
  >and can't remember what the fix was. Can someone help me refresh my
  >memory? :)

check the access rights and ownership of /var/spool/mail and elm
and try this
su
chgrp mail /var/spool/mail
chmod g+rwx /var/spool/mail
chmod g+s `which elm`

hope this help

Lolo

 * 1st 2.00 #8107 * Two great Tennesseans:  Charlie and Jack Daniels.

 
 
 

ELM doesn't open "mailbox"?

Post by Mark Corni » Wed, 13 Sep 1995 04:00:00




> > I get the error message:
> > Waiting to read mailbox while mail is being received: attempt #2
> # chmod 711 /var/spool/mail
> should fix it.

DOH! That should be
# chmod 771 /var/spool/mail

/me hits himself with the stupid stick.
--msc

--
                             Mark Cornick

                  http://evol.resnet.jmu.edu/~mark/
                      finger for PGP public key

 
 
 

ELM doesn't open "mailbox"?

Post by Michael Buchenried » Wed, 13 Sep 1995 04:00:00



>I get the error message:
>Waiting to read mailbox while mail is being received: attempt #2
>when I or any of my users try to run ELM. I have no problems running ELM
>from root however. I came across this problem before (a long time ago)
>and can't remember what the fix was. Can someone help me refresh my
>memory? :)

Check the permissions of the mail spool directory -
the above message simply indicates that elm was unable to open the
user's mailbox in /usr/spool/mail.
Should be mode 771, I think.

Michael
--

**************************************************************************
* Our continuing mission: To seek out knowledge of C, to explore strange *
* UNIX commands and to boldly code where no one has manpage 4...         *

 
 
 

ELM doesn't open "mailbox"?

Post by Nicholas J. Leo » Thu, 14 Sep 1995 04:00:00



>>Waiting to read mailbox while mail is being received: attempt #2

>Check the permissions of the mail spool directory -
>the above message simply indicates that elm was unable to open the
>user's mailbox in /usr/spool/mail.
>Should be mode 771, I think.

Also, ELM should be setgid MAIL and owner by root.mail.

Quote:

>Michael

--

Nicholas!                                  [      System Administrator       ]
   LiNuXmAgIcTGraVEiSdNshADoWfIst3dSTudIo  [   \"Elegance Thru Simplicity\"  ]
   PeRlWorLDWiDeWEBheURiSTicLOgiCsELFcorr  [ http://www.binary9.com/nicholas ]

------------------------------------------------------------------------------

 
 
 

1. Why doesn't echo "text" 'command' "more text" work?

                 ^                                        ^
Wrong quotes, should be -
   echo "You have" `grep Subject: /usr/spool/mail/me | wc -l` "messages."
or -
   echo "You have `grep Subject: /usr/spool/mail/me | wc -l` messages."

But, another problem is, if you've no mail, /usr/spool/mail/me does not
exist, leading grep to say:
   grep: can't open /usr/spool/mail/me
Wc will still report 0.

You might try -
   sh -c 'echo "You have `grep 2>/dev/null Subject: /usr/spool/mail/me | wc -l` messages."'

Hope this helps.

2. How to prune wtmp ?

3. Need search engine/spider with proximity function

4. kfm: "Open with...." doesn't show anything to open with

5. ICMP redirect from xxx.xxx.xxx.xxx on eth0 ignored

6. """"""""My SoundBlast 16 pnp isn't up yet""""""""""""

7. tty hog - characters lost ?

8. GETSERVBYNAME()????????????????????"""""""""""""

9. Screen doesn't unblank with "screenblank" and "xlock" under 2.3

10. my PC doesn't reboot after "reboot" or "ctrl-alt-del"

11. "Can't open file" ( flat file ) and "flock()unimplemented ..."

12. Who's, Who in the "Free Software" / "Open Source" community